Showing results for 
Search instead for 
Did you mean: 

Web Authentication HELP!!!

Hi, I am trying to get web-authentication and web-passthrough to work with a 4404 WLC. I have 2 SSID's, one for contractors (web-auth) and the other for guest (web-passthrough). I can authenticate and associate fine with both SSIDs but when I open the web browser for both of them I don't get redirected to the Login page. Instead I just get routed to the requested web page.

I am not sure why this is happening because I thought that with those selected the WLC block IP traffic so I am a little confused why I am able to freely browse the web.

Any ideas are greatly appreciated!


Scott Fella
Hall of Fame Guru

Verify that you have the wlan configured correctly with webauth. Try to only setup one and see if that works or not. Then try the other. If webauth is enabled on the wlc, then associated users should get the login or pass through page before they have access to the net.

*** Please rate helpful posts ***

I am not sure what you mean by correctly ... I name the wlan ... configure the layer 2 security to none ... and configure the layer 3 to use web auth or pass through ... and then choose an ACL that I created that allows DNS through but blocks everything else to the network. The only other things I configured is the QOS (set to Bronze) and the setting to not allow static IP.

I read several configuration examples and tried to mirror those as well and still get no redirection instead I get right out to the web ... I thought it was my laptop storing cache so I tried another one with the same result.

Quick questions ... will setting the layer 2 security require me to touch an user laptop? And do you know if the code helps this matter? I know 5.x is not recommended but I didn't see or hear anything about that version ... I read the release notes and it appears to fix somethings but not sure how reliable it is.



If you set a layer2 security, then you will have to touch the users device. Will 4.2.130 help, not if it doens't work now. Should you load 5.0 code...


Post your show run-config so I can look at how you have it setup.

*** Please rate helpful posts ***

Thanks for your help ... I actually found the problem ... I had the ACL in the wrong place ... I had it configured in the preauthorizaton ACL under the WLAN layer 3 instead of in the interface setup ... once I changed that things worked fine.

Recognize Your Peers
Content for Community-Ad