07-11-2010 09:47 AM
Hi,
I need one suggestion from you.
I have 2 servers that need to be load balanced.
Real Server 1 IP Address: 10.10.10.10
Realo Server 2 IP Address: 10.10.10.11
VIP: 10.10.10.100
My requirement is: Real Server will raise request (loopback request as per Oracle Guys) towards the VIP. VIP will handover the request to the same server from where the original request was made.
Real Server 1--> Request--> VIP-->Real Server 1
Real Server 2--> Request--> VIP-->Real Server 2
Is this possible? If Yes, then whether some thing to be configured on ACE??
Kindly suggest..
07-12-2010 07:19 AM
Hello,
Yes, you can do this. See example below:
access-list ANYONE line 10 extended permit ip any any
rserver host SERVER_01
ip address 192.168.1.11
inservice
rserver host SERVER_02
ip address 192.168.1.12
inservice
rserver host SERVER_03
ip address 192.168.1.13
inservice
serverfarm host REAL_SERVERS
rserver SERVER_01
inservice
rserver SERVER_02
inservice
rserver SERVER_03
inservice
class-map match-all REAL_SERVERS
2 match source-address 192.168.1.0 255.255.255.0
class-map match-all VIP-30
2 match virtual-address 172.16.51.30 tcp eq www
policy-map type loadbalance first-match SLB_LOGIC
class class-default
serverfarm REAL_SERVERS
policy-map multi-match CLIENT_VIPS
class VIP-30
loadbalance vip inservice
loadbalance policy SLB_LOGIC
loadbalance vip icmp-reply active
class REAL_SERVERS
nat dynamic 1 vlan 451
interface vlan 251
description Client vlan
ip address 172.16.51.11 255.255.255.0
access-group input ANYONE
service-policy input REMOTE_MGT
service-policy input CLIENT_VIPS
no shutdown
interface vlan 451
description Servers vlan
ip address 192.168.1.1 255.255.255.0
access-group input ANYONE
service-policy input CLIENT_VIPS
nat-pool 1 192.168.1.10 192.168.1.10 netmask 255.255.255.0 pat
no shutdown
ip route 0.0.0.0 0.0.0.0 172.16.51.1
Hope this helps,
Sean
07-12-2010 10:32 PM
Thanks Sean for your reply. But my requirement is different:
Let me furnish my requirements:
2-3 Oracle Instances (Oracle 10G) are installed on same Server. There are 2 servers.
Server 1 will raise Loopback request to the ACE VIP & VIP will return back the same request to Server 1
Server 2 will raise Loopback request to the ACE VIP & VIP will return back the same request to Server 2.
Do u suggest something to be done in ACE for such scenario??
Kindly suggest.
Rgds,
Partha
07-13-2010 02:05 PM
Sure, you can still use the config I gave you and modify it a bit. You can put each server in its own serverfarm. Then you can load balance to its own serverfarm based on the source-ip address. With the example I provided, i'm using source-ip to do source NAT. In your case you would use source-ip to do NAT and to load balance to the serverfarm that the server resides.
Make sense?
Sean
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide