Showing results for 
Search instead for 
Did you mean: 

DATA_EXCEPTION: Enter Valid Relay Email Address


Has anyone else noted this? When I create an SMTP Notification device with an address like, things work fine. Turn it into, I get the error in the title when I use the REST API to set the Address

This is in, in my lab I have where it is fine, and prior to the upgrade to 10.0, it worked fine as well.

Here's a sample request that goes over the wire


Cache-Control: no-cache

Content-Type: application/xml

Accept: application/xml, */*

Authorization: Basic authorization

Cookie: JSESSIONIDSSO=30B6EFCDDE924DF537FF5D5B40AFF79A; Path=/; Secure; HttpOnly;JSESSIONID=704D50B4072BDE612AAE9922F115790D; Path=/vmrest/; Secure; HttpOnly;REQUEST_TOKEN_KEY=7533159619388272098; Path=/; Secure; HttpOnly;


Content-Length: 65

<Smtp><SmtpAddress></SmtpAddress></Smtp> does resolve just fine. Setting the same address via the web GUI also works.

3 Replies 3

Cisco Employee
Cisco Employee

I'm aware of a similar defect in a different version, where the operation fails if there are too many dots in the domain portion of the address.   I can't find any similar potential defect reports with respect to, but I will file a report for you. I'll let you know what I find out. 

In the meantime, you can create an email alias or just use the shorter domain (if that works) as a workaround.

By the way, have you tried a POST request?  There was an older problem that recommended POST as a workaround. 

Now, I've not tried post. I'm using Jeff's .NET lib - I'm running it in source code form so I could just swap out the HTTP method.

I opened a TAC case no this as I needed to give my customer a timeline for a fix: 632140967. The issue also happens in 10.5.1 (we tried upgrading as another solution approach).

Do you have any idea on how to create an alias if the email is external? Because that's what we're looking at.. an external Email to SMS service so we send to Naturally we have no say about what domain name we have to use.. the only part under our control is mobilenumber.

@edit: tested POST.. it returns 405 method not allowed.

Yes, 10.5.1 is the different version with the similar problem.  That's already fixed and the fix should be integrated into 10.5.2.  I see from your TAC case that someone is helping you with this. 

There are a number of ways to create an alias, but it depends on how your email is set up.  Here's one way, if you're using Linux:

Creating Aliases and Mail Redirects

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: