cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4952
Views
6
Helpful
20
Replies

Problem while deploying IWAN app - GUI bugs

Hello,

while I was deploying IWAN app few bugs happened;

1) can't change or delete IP Adress Pools

APIC_IWAN_.JPGAPIC_IWAN_01.JPG

2) Can't configure HUB or "Save & Continue"

APIC_IWAN_ 001.JPGAPIC_IWAN_ 002.JPGAPIC_IWAN_ 004.JPG

Tried with Firefox, Chrome and Opera, APIC-EM version 1.1.2.15.

How to solve that problems in order to continue with IWAN traffic-routing app development?

Thank you in advance

20 REPLIES 20
dgombovic
Beginner

As some script in GUI is constantly failing when clicking on configure hub icon and as even clean install of APIC-EM didn't help, is there any way to deploy IWAN with API?

dgombovic
Beginner

Hello again,

is it known GUI-bug in 1.1.2.15 or is something else wrong?

Thank you in advance!

Hi Dominik,

  Apologies for the delay in responding to you. what I think is that  It is important to size the generic IP pool correctly for the long term needs of the IWAN site. VPN requirements dictate that subnets must be defined and allocated internally (up front) before any sites are provisioned. Therefore, once the site and service provider sizing is set, it is frozen for the life of the controller.

Reference - Software Configuration Guide for Cisco IWAN on APIC-EM - Configure Hub Site and Settings [Cisco Application Policy Infra…

Thanks and Regards,

Geevarghese

Thank You for reply.

IP pool is correctly sized for current lab use so my first concern is solved.

But the main problem is shown on three last picutres that show GUI problem (when trying to access Hub settings) that prevents me to deploy IWAN app. Some script is constantly failing (even clean install of APIC-EM didn't help) and I can't pass that step to deploy app.

Is there any solution to that problem?

Thank You in advance!

p.s. in case that we increase number of branch sites (for examples with merging two companies) what should we do with the APIC-EM IWAN application regarding IP pool changes?

Hello,

any news about GUI problem/bug?

Thank you in advance

sorry for what may be a silly question. 

I assume you have a routing protocol already configured on the HUB routers?  What is it?

Yes, OSPF.

Have you clicked on the "+" in the top left corner of the HUB to configure your DC parameters?  That is where you supply the routing protocol, AS, and DC prefixes.  It looks like you have not done that yet.

We need to give you a better error message when the DC parameters have not been configured (top left corner).  Can you test this please?

Problems happen after clicking on that "+" that configures Hub.

(second set of pictures in the first post is after clicking that "+")

Thank You for your time!

I am really sorry, I have done this lots of times with no issues.  Just to be completely clear, you did click on the plus in this image?Screen Shot 2016-05-31 at 9.54.21 AM.png

No need to be sorry

Yes, when i click that "+" problems start.

Version is 1.1.2.15 and even clean install didn't help. (Neither did installations of other browsers)

Regarding Issue 2:

As "aradford" mentioned,

Before clicking on SAVE and Continue , You need to make sure to fill out the following in order to click in SAVE and Continue.

(A) All the devices in this case ( Border Router , Master Controller)

(B) WAN Cloud

(C) Routing Protocol ( OSPF or EIGRP ) , depending on your network topology

(D) DC Prefix ( by clicking on + sign )

Once (A) , (B) , (C) and (D) are filled up --> click on SAVE and Continue --> summary Page will show you the information entered. -- > you will have a choice to schedule or provision the network.

hope this helps

I did (A) and (B) before (D) that freezes GUI like in pictures.

Where can I choose (C) Routing Protocol in GUI before clicking on "+" barrel sign that is located left of "HUB" text?