cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
149
Views
0
Helpful
5
Replies
oz.ezer01
Beginner

Java 11 Azul

Hi,

I would like to ask if Cisco JTAPI supports Java 11 Azul ?

 

Thanks,

5 REPLIES 5
davidn#
Cisco Employee

Not afaik.  Please refer to our supported matrix here:

 

https://developer.cisco.com/site/jtapi/documents/cisco-unified-jtapi-supported-jvm-versions/

 

Regards,

 

David

 

It appears that the matrix does not reflect CUCM v14.  I've reached out to the JTAPI team to see about updating it...perhaps Java 11 will appear

In the mean time, I don't think we're aware of any issues with Java 11 (I've certainly been using it for some time), though as always the best practice is to follow the versions as documented.

Hi,

Did you have a chance to check it with the product home ?

I'm also asking for this specific version of Java 11 - Azul.

 

Thanks,

No news as of yet, I'll follow up on the request...

In the mean time, if you have a Cisco TAC support contract, might be worth opening a ticket.

The JTAPI supported JVM matrix has been updated for CUCM 14.0: https://developer.cisco.com/site/jtapi/documents/cisco-unified-jtapi-supported-jvm-versions/

Looks like it brings testing up to Java 1.8 (but not Java 11.)  Interesting that OpenJDK is now tested/supported...

Create
Recognize Your Peers
Content for Community-Ad