cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3795
Views
0
Helpful
8
Replies

SIP Normalization Script to replace Anonymous ID to ==== callerid

monasir
Level 1
Level 1

Hi ,

 

I need help with creating a SIP Normalization Script to replace Anonymous ID to caller ID's

The thing is, when i make a call (from external)  to cucm and the extension has forwarderd all calls to another externally number for example ( mobile) the call is bein rejected.

 

When i do a debug ccsip message i'm seeing something like this in the output:

( From: "Anonymous" <sip:anonymous@voip.XXX.XXX>;tag=XXX.XX.XX.XX+1+4d22ea09+c7ab9eef )

 

So i simply want to replace the From field to a caller id so the calls will get true.

 

Normal calls without forwarded to other extensions are working fine and are not rejected, howe ever i still see in the output

From: "Anonymous" <sip:anonymous@voip.XXX.XXX>;tag=XXX.XX.XX.XX+1+4d22ea09+c7ab9eef )

 

I appreciate all the assistance!

 

 

 

8 Replies 8

Raghavendra G V
Cisco Employee
Cisco Employee

Please check below link might help you.
https://community.cisco.com/t5/ip-telephony-and-phones/normalization-script/m-p/2131611

 

Thanks,
Raghavendra

Hi,

 

I have seen this post, unfortunately this will not work for me.

I'm using cube

are you looking for TCL IVR script on cube? or SIP Normalization script?

 

Thanks,

Raghavendra

Hi,

 

I'm looking for a SIP normalization script.

The thing is when calling from external , calls arriving in the cube with:

 

From: "Anonymous" <sip:anonymous@xx.xx.net>;

 

This is something that we do not want.

We want that calling number needs to be sent with calling id.

We have many issues like SNR, also we are not able to forward calls to other external numbers.

 

This is all because of the fact the calls arrive in the cube with anonymous, the provider is rejecting this .

Because it probably sees its not something valid , not a valid number withing the DID range.

 

Nowe it seems to be possible to make a SIP normalization script to change the from field with a valid number.

I'm a little bit lost because ive tried several workarounds with no succes.

 

any help would be appreciated

I would do this in CUBE before it ever gets to CUCM.  Try something like this:

 

http://technologyordie.com/calling-party-routing-of-anonymous-calls-sip-header-fix-up

 

- Be sure to rate all helpful posts

Hi i've tried the workaround, unfortunately it didnt work for me.

While debugging i still see Anonymous

Would you mind sharing your config?

- Be sure to rate all helpful posts

Hi Schaef,

 

pfa running config

 

===========================================================================

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2018.12.10 10:49:24 =~=~=~=~=~=~=~=~=~=~=~=

CUBE-SCN00214#
CUBE-SCN00214#
CUBE-SCN00214#
CUBE-SCN00214#
CUBE-SCN00214#term len
CUBE-SCN00214#term length 0
CUBE-SCN00214#sh run
CUBE-SCN00214#sh running-config
Building configuration...


Current configuration : 7377 bytes
!
! Last configuration change at 05:38:41 AST Mon Dec 10 2018 by voippoc
! NVRAM config last updated at 07:00:59 AST Wed Dec 5 2018 by voippoc
!
version 15.5
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname CUBE-SCN00214
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
logging buffered 1000000
!
no aaa new-model
clock timezone AST -4 0
!
!
!
!
!
!
!
!
!
!
!


ip host voip.test.net 123.45.67.89
ip name-server xx.xx.xx.xx xx.xx.xx.xx

ip domain name xx.nl
!
!
!
!
!
!
!
!
!
!
subscriber templating
vtp mode transparent
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 12.34.5610 255.255.255.255
  ipv4 12.34.5620 255.255.255.255
  ipv4 123.45.67.89 255.255.255.255
 no ip address trusted authenticate
 address-hiding
 mode border-element license capacity 200
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 no supplementary-service sip handle-replaces
 fax protocol pass-through g711alaw
 sip
  header-passing
  registrar server expires max 3600 min 120
  early-offer forced
  midcall-signaling passthru
!
!
voice class uri InboundCUCM sip
 host ipv4:12.34.5610
 host ipv4:12.34.5620
!
voice class uri InboundSIPSP sip
 host ipv4:123.45.67.89
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729br8
!
voice class codec 2
 codec preference 1 g711alaw
 codec preference 2 g729br8
!
!
!
voice class server-group 1
 ipv4 12.34.5610 preference 1
 ipv4 12.34.5620 preference 2
!
voice class server-group 2
 ipv4 123.45.67.89 preference 1
!
voice class sip-options-keepalive 1
 description TCP Options CUCM
 down-interval 10
 retry 3
 transport tcp
!
voice class sip-options-keepalive 2
 description UDP Options SIP SP
 down-interval 10
 retry 3
 transport udp
!
voice class dial-peer provision-policy 10
 preference 1 called calling
 preference 2 to
!
voice class dial-peer provision-policy 20
 preference 1 called calling
 preference 2 to
!
!
!
!
!
!
!
voice-card 0/4
 no watchdog
!
license udi pid ISR4321/K9 sn FDO22360K8B
!
spanning-tree extend system-id
!
username voippoc privilege 15 password 7 044D040F1F31434D5D4951
!
redundancy
 mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
 description naar internet
 ip address xx.xx.xx.xx 255.255.255.248
 negotiation auto
!
interface GigabitEthernet0/0/1
 description intern
 ip address xx.xx.xx.xx 255.255.255.0
 negotiation auto
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway xx.xx.xx.xx
ip forward-protocol nd
no ip http server
no ip http secure-server

!
!
!
!
!
control-plane
!
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0/1
sccp ccm 12.34.5610 identifier 1 priority 2 version 7.0
sccp ccm 12.34.5620 identifier 2 priority 1 version 7.0
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0/1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register test-MTP2
 associate profile 1 register xx-MTP1
!
!
!
dspfarm profile 1 mtp  
 codec g711ulaw
 codec pass-through
 maximum sessions software 100
 associate application CUBE
!
dspfarm profile 2 mtp  
 codec g711ulaw
 codec pass-through
 maximum sessions software 100
 associate application SCCP
!
dial-peer voice 10 voip
 description Inbound from CUCM
 session protocol sipv2
 session transport tcp
 incoming uri via InboundCUCM
 voice-class codec 1  
 dtmf-relay rtp-nte sip-notify sip-kpml
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 11 voip
 description Outbound to SIPSP
 destination-pattern T
 session protocol sipv2
 session target sip-server
 session transport udp
 voice-class codec 2  
 voice-class sip options-keepalive profile 2
 dtmf-relay rtp-nte sip-notify sip-kpml
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 20 voip
 description Inbound from SIPSP
 session protocol sipv2
 session transport tcp
 incoming uri from InboundSIPSP
 voice-class codec 1  
 voice-class sip bind control source-interface GigabitEthernet0/0/1
 voice-class sip bind media source-interface GigabitEthernet0/0/1
 dtmf-relay rtp-nte sip-notify sip-kpml
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 21 voip
 description Outbound to CUCM
 destination-pattern 123456..
 session protocol sipv2
 session transport udp
 session server-group 1
 voice-class codec 1  
 voice-class sip bind control source-interface GigabitEthernet0/0/1
 voice-class sip bind media source-interface GigabitEthernet0/0/1
 dtmf-relay rtp-nte sip-notify sip-kpml
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
 ip qos dscp cs3 signaling
 no vad
!
!
sip-ua
 xx
xx
xx
net
 retry invite 2
 retry register 10
 timers connect 100
 timers register 100
 registrar dns:voip.test.net expires 300 auth-realm voip.test.net
 sip-server dns:voip.test.net
 host-registrar
 presence enable
!
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input ssh
line vty 5 15
 privilege level 15
 login
 transport input ssh
!
ntp server 192.168.100.97
ntp server 192.168.100.98
!
end