cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2269
Views
10
Helpful
11
Replies
TonySian
Beginner

Business Dashboard Probe UI access

Hi I have installed the dashboard and probe, and the probe's vm/linux box is running and I have configured it per documentation. I am unable to access the GUI. Using the IP address just brings it to a boilerplate webpage for nginx. Attempting https (port 443) it will not load at all. I am able to ping the IP address of both the host and the vm. Just can't figure out how to get into the gui

11 REPLIES 11
David Harper
Cisco Employee

Hi Tony,

 

Are you using one of the pre-packaged VM images from cisco.com, or did you install the probe on to your own ubuntu server?  If you installed on to your own server, was nginx already installed and running prior to installing the probe?  Normally the probe will launch nginx as part of its owm startup procedure and in the process reference its own set of config files.  So if nginx was already installed an running, you will likely have two instances trying to bind to the same ports.  Inevitably, the instance launched by the probe will lose this fight, which would explain what you are seeing here.

 

This is a guess of course.  So if you are doing something different, let us know and we can diagnose the problem further.

 

Cheers,

Dave. 

Thanks for your reply Dave...

I am using the pre-packaged images to install on my esxi server. There are currently no other instances of ubuntu or nginx running on the server so there shouldnt be any conflicts there. I did have the actual Cisco Business Dashboard running, but I noticed the "built-in" probe as part of that wasn't doing much so I assumed that I needed to also run the standalone probe VM. After your suggestion I deleted both VMs and just installed the standalone probe image and ended up with the same result.

 

Navigating to the IP assigned to the probe in my browser just displays the "Welcome to NGINX" page instead of the probe application.

 

I appreciate your help

 

--Tony

What VM image did you download?  Which version I mean.  If you are using our VM images and don't make any changes, then this situation should not arise.  If the probe is running, you should see the login page, and if it is not, you should get a timeout connecting to the webserver.  FWIW, I just downloaded a fresh copy of the 2.2.1 probe ova file and it worked as expected.

 

At this point, I'm going to suggest calling support and get an engineer to speak to you live and look at exactly what is happening.  You can find the local contact numbers at https://cisco.com/go/sbsc.  This shouldn't be that complicated, so I'm sure we are missing something simple.  Walking through the process live should help identify what that is.

 

Cheers,

Dave.

BeardedBlaze
Beginner

Hi Tony,

I'm experiencing identical issues on few of our client's VMs, did you reach out to cisco and were they able to resolve it for you?

 

Thanks

 

Blaze

Hi Blaze,

 

Can you let me know what version of the dashboard you are using and whether you are using the VM image we provide or if you installed the application on your own Linux build?  As I said to Tony earlier, this really shouldn't happen and there no known issues that have come up in testing that would result in this problem, so I'd really like to get to the bottom of what is happening.

 

Cheers,

Dave.

Hi Dave,

I'm using the VM image you provide: Cisco_Business_Dashboard_Probe-2.2.1.20201105.signed.ova

 

I've installed/deployed the probe successfully without issues on 31 different hosts, however there are 5 that exhibit this weird bug and I have not been able to figure out anything those 5 have in common that would cause that....

 

Thanks

 

Blaze

I've just replied to the email you sent me.  Let's work through this one offline and I'll update the thread with the results when we get to the bottom of what's happening.

 

Cheers,

Dave.

I just want to update the thread with the outcome of this.  Blaze and I got to the bottom of the problem with some help from the engineering team.  The root cause is that the version 2.2.x VM images have the Nginx service incorrectly set to start on boot with a default config file.  Normally Nginx is started by the dashboard application, so we get a race condition happening which means sometimes Nginx starts up more quickly than the dashboard and you get this problem.

 

If you run into this problem, you can fix it by logging on to Linux and entering the command 'sudo systemctl disable nginx.service' and then reboot the VM.  This stops Nginx from starting on boot meaning that it can be started correctly by CBD.  The problem will also be fixed in the next release of CBD.

 

Cheers,

Dave.

Thank you David for the update!

 

Regards,

Martin

TonySian
Beginner

Zero resolution. On top of which I was able to determine that CBD only would work on the local network node to the VM it was installed to. Would not connect to or locate information from any other network devices from any other network segments INCLUDING cisco switches. This software does not appear to be ready for primetime in any way, shape, or form.

 

I uninstalled the Cisco Business Dashboard VMs and went back to PRTG. That actually works as advertised

Hi Tony,

 

Did you end up logging a case for the web server problem?  I'm surprised you didn't get a resolution and I'd like to follow up on that, so if you can PM me the case number, I'd appreciate it.

 

I understand that you have already uninstalled dashboard, but I'd still like to try and understand what the limitations were that led you to removing it.  What you have described above is not really correct in general, so I'd like to understand what led you to that conclusion.

 

Thanks,

Dave.