cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5791
Views
5
Helpful
15
Replies

Troubleshooting High CPU Utilization on Cisco CSR1000V Series

aspetukhov
Beginner
Beginner

Hello everybody.

I have some troubles with CPU utilization on a Cisco CSR1000V Series Router. It periodically rises up to 100%. I found out a pair of documents about troubleshooting techniks for this kind of issues. These articles are: Troubleshooting High CPU Utilization on Cisco RoutersTroubleshooting High CPU Utilization. But I think that in the case of CSR1000V those articles are not so usefull and they have not helped me a lot. Mostly because this is a virtual machine that is executed on VMWare, but those articles are for "hardware" Routers.
Can anybody recommend me a good article about troubleshooting high CPU utilization for CSR1000V Series or for a Virtual Router?

P.S.: I tried to find something relative on Cisco-site, but found nothing. Maybe I have overlooked something. If so, please point out it.

Update: Some articles were beign advised to me but there are some small inaccuracies

http://www.cisco.com/c/en/us/support/docs/ip/simple-network-management-protocol-snmp/116213-trouble-asr-eem-00.html

http://www.cisco.com/c/en/us/support/docs/ip/simple-network-management-protocol-snmp/118901-technote-snmp-00.html

Update 2:

As a starting point for troubleshooting can be used: Cisco docwiki CSR1000V:Home

15 Replies 15

Philip D'Ath
Advisor
Advisor

Short bursts to 100% are fine.  Are they just short bursts?

Hi, unfortunatelly it is not a short burst. It can last very long time. Last time it last for about 30 minutes until I reloaded it. Previous time it lasted for some hours but I am not sure whether it began working itself or someone reloaded it by hand.

Of course, I opened an SR but they do not hurry. Since the issue arose I am trying to investigate the issue by myself but I was able to find too little information about this type of issues. I tried to find the same issue in the Bug Search Tool, but without any success. Maybe I am trying to find answers in a wrong place.

Did you get a "show tech-support" for a "show process cpu ..." output to give an indication of what was using the CPU? Is there a newer version of the software you can use?

We are not using the latest version of the software, we stick to the opinion that the proven version is better than newest one. We are using 3.14.2S. Also, we have not got the recommendations for changing the using version of the IOS-XE.

Yes, I got "show tech-support" and "show process cpu...". The main amazing thing - from IOS point of view is consumes 10% of CPU, from VMWare point of view - 99%.

I attached results snipped. I really do not understand what is the process "qfp-ucode-csr". But I read something about IOS-XE and as I understand, the process "linux_iosd-imag" is the common IOS but executed as a distinguished proccess in IOS-XE.

This is the brief results of "show process...".

# show proc cpu plat sorted
CPU utilization for five seconds: 99%, one minute: 99%, five minutes: 99%
# show proc cpu sorted
CPU utilization for five seconds: 14%/1%; one minute: 7%; five minutes: 10%

That sounds like it is just pure packet forwarding performance.

How many vCPUs are allocated and what was the throughput at the time?  Was it perhaps around 200Mb/s of more of throughput with 2 vCPU?