cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

If your Cloud Collaboration question is not answered quickly, please email devsupport@webex.com for additional help

357
Views
5
Helpful
3
Replies
Highlighted
Beginner

How to create a meeting with "Use VOIP only" via XML service

Hello,

   I am current using the Sandbox to try to create a meeting with the "Use VOIP Only" audio option, via the XML service. The documentation is none to clear on how to achieve this and of the few discussions I've seen none are working for me. The XML being posted is:

<?xml version="1.0"?>

-<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

-<header>

  -<securityContext>

   <webExID>xxxxx</webExID>

   <password>xxxxx</password>

   <siteID>xxxxx</siteID>

   <partnerID>xxxxx</partnerID>

   <siteName>xxxxx</siteName>

  </securityContext>

</header>

-<body>

  -<bodyContent xsi:type="java:com.webex.service.binding.meeting.SetMeeting">

   -<accessControl>

    <meetingPassword>xxxxx</meetingPassword>

   </accessControl>

   -<metaData>

    <confName>34a67e4d-f5c4-4a86-9243-b36b5cd4c8e9</confName>

   </metaData>

   -<participants>

    <attendees/>

   </participants>

   -<enableOptions>

    <attendeeList>true</attendeeList>

    <chat>false</chat>

    <poll>false</poll>

    <audioVideo>false</audioVideo>

    <presentation>false</presentation>

    <autoDeleteAfterMeetingEnd>false</autoDeleteAfterMeetingEnd>

    <voip>true</voip>

   </enableOptions>

   -<schedule>

    <startDate>8/3/2017 09:00:00</startDate>

    <openTime>0</openTime>

    <duration>10</duration>

    <timeZoneID>21</timeZoneID>

   </schedule>

   -<telephony>

    <telephonySupport>CALLIN</telephonySupport>

   </telephony>

   -<attendeeOptions>

    <registration>false</registration>

    <emailInvitations>false</emailInvitations>

   </attendeeOptions>

   <meetingkey>621608149</meetingkey>

  </bodyContent>

</body>

</serv:message>

I have set various "enableOptions" to true but still cannot get a meeting created with "Use VOIP Only". I'm unclear as to whether this is a restriction of the sandbox, or I am missing something.

Any help would be appreciated.

Regards,

Craig

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Hi Craig,

To enable VoIP only, you just need to disable telephonySupport. The request below will create a new meeting with this configuration or you can change "CreateMeeting" to "SetMeeting" to update an existing meeting.

<?xml version="1.0" encoding="UTF-8"?>

<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <header>

    <securityContext>

      <webExID></webExID>

      <password></password>

      <siteName></siteName>

      <returnAdditionalInfo>true</returnAdditionalInfo> # we recommend this element so it returns the XML server you hit. This is very helpful if you need to come to us for support with failing requests.

    </securityContext>

  </header>

  <body>

    <bodyContent xsi:type="java:com.webex.service.binding.meeting.CreateMeeting">

      <accessControl>

        <meetingPassword>xxxxx</meetingPassword>

      </accessControl>

      <metaData>

        <confName>34a67e4d-f5c4-4a86-9243-b36b5cd4c8e9</confName>

      </metaData>

      <participants>

        <attendees/>

      </participants>

      <enableOptions>

        <attendeeList>true</attendeeList>

        <chat>false</chat>

        <poll>false</poll>

        <audioVideo>false</audioVideo>

        <presentation>false</presentation>

        <autoDeleteAfterMeetingEnd>false</autoDeleteAfterMeetingEnd>

        <voip>true</voip>

      </enableOptions>

      <schedule>

        <startDate>8/3/2017 09:00:00</startDate>

        <openTime>0</openTime>

        <duration>10</duration>

        <timeZoneID>21</timeZoneID>

      </schedule>

      <telephony>

       <telephonySupport>NONE</telephonySupport>

      </telephony>

      <attendeeOptions>

        <registration>false</registration>

        <emailInvitations>false</emailInvitations>

      </attendeeOptions>

    </bodyContent>

  </body>

</serv:message>

Kasey Schultz

API Developer Services - WebEx - Cisco Systems, Inc..:|:.:|:.

View solution in original post

3 REPLIES 3
Highlighted
Enthusiast

Sorry to push but is anyone able to help with this please?

Regards,


Craig

Highlighted

Moved to the WebEx API developer support forum for questions about the API

Highlighted
Cisco Employee

Hi Craig,

To enable VoIP only, you just need to disable telephonySupport. The request below will create a new meeting with this configuration or you can change "CreateMeeting" to "SetMeeting" to update an existing meeting.

<?xml version="1.0" encoding="UTF-8"?>

<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <header>

    <securityContext>

      <webExID></webExID>

      <password></password>

      <siteName></siteName>

      <returnAdditionalInfo>true</returnAdditionalInfo> # we recommend this element so it returns the XML server you hit. This is very helpful if you need to come to us for support with failing requests.

    </securityContext>

  </header>

  <body>

    <bodyContent xsi:type="java:com.webex.service.binding.meeting.CreateMeeting">

      <accessControl>

        <meetingPassword>xxxxx</meetingPassword>

      </accessControl>

      <metaData>

        <confName>34a67e4d-f5c4-4a86-9243-b36b5cd4c8e9</confName>

      </metaData>

      <participants>

        <attendees/>

      </participants>

      <enableOptions>

        <attendeeList>true</attendeeList>

        <chat>false</chat>

        <poll>false</poll>

        <audioVideo>false</audioVideo>

        <presentation>false</presentation>

        <autoDeleteAfterMeetingEnd>false</autoDeleteAfterMeetingEnd>

        <voip>true</voip>

      </enableOptions>

      <schedule>

        <startDate>8/3/2017 09:00:00</startDate>

        <openTime>0</openTime>

        <duration>10</duration>

        <timeZoneID>21</timeZoneID>

      </schedule>

      <telephony>

       <telephonySupport>NONE</telephonySupport>

      </telephony>

      <attendeeOptions>

        <registration>false</registration>

        <emailInvitations>false</emailInvitations>

      </attendeeOptions>

    </bodyContent>

  </body>

</serv:message>

Kasey Schultz

API Developer Services - WebEx - Cisco Systems, Inc..:|:.:|:.

View solution in original post