Showing results for 
Search instead for 
Did you mean: 

Cisco Jabber and VPN

Level 1
Level 1

Hello eveyone,

I was wondering if anyone using Cisco Jabber and a VPN connection has experienced something about this.

We have an ASA5510 that we use as VPN concentrator. We have deployed Cisco Jabber, either on laptops (mac or pc) or on iPhones & iPads.

We are able to successfully establish a VPN connection on the remote client and Jabber will register correctly.

The issue comes when we want to do the first call. No matter what, the first call will never have audio, we need to do a dummy call and then, the second and subsequent calls will work correctly.

Do you know if this is an expected behaviour when connecting through a VPN? We have been told that this is an expected behaviour as the tunnel doesn't know how to handle packets the first time, but, would this be true?

If we do the same connecting the device to the corporate network (wired o wireless), the first call will work as expected the first time.


8 Replies 8

Muhammad Maqsood Mushtaq
Cisco Employee
Cisco Employee

Hi Daniel,

Thanks for reporting this issue. In order to investigate this issue by Jabber for Windows team, can you do following steps on a machine where Jabber for Windows is installed.

  1. Does the machine have wired and wireless interfaces? If yes, can you disable the wireless temporarily and repeat the tests and see if there is any change to the first call experience?
  2. If the above doesn’t make any difference, then with the wireless still disabled can you capture 2 x Wiresharks (monitoring the wired interface). Satrt capaturing the first wireshark just before the first call is made. Once the first call is ended stop capturing packets and save that wireshark. Then restart the capture for a second call and save that separately.

Please attach the two trace files with this thread. You can attach the files by clicking on "Use advanced editor" on top right of the reply box.



Thanks Maqsood,

I'll work to get those captures as soon as possible.

At this particular moment I could take those captures for Jabber for MAC as I have a macbookpro myself. The behaviour is exactly the same on windows or mac or iPhone, would it help? Could I send you those?


Hi Daniel,

I am on Jabber for Windows team so I can only help to investigate from windows side. When you do get a windows machine please get wireshark traces from the VPN interface than the local wired interface. Can you also provide following information:

- What VPN client you have on the windows machine

- You mentioned that "We have been told that this is an expected behaviour as the tunnel doesn't know how to handle packets the first time". Where did you get this information? 



Hi Maqsood,

We have deployed Cisco Jabber for windows and it does really well inhouse but when I try to connect jabber from a public IP it is not able to connect to the presence server and let me tell you if I use a VPN tunnel it works fine.

My question is do we really need a VPN tunnel for jabber for windows or jabber client for any other device to connect?

We already  have natted the presence servers ip address to a public ip and we are able to resolve the presence servers host name from a public ip.

Ithink it should work without a VPN tunnel, may be I am missing some configuration here.

Any help on this would be really appreciated.

Here is the screenshot of jabber client for windows.

Hi Nirmal,

Jabber for Windows has two deployment models:

1. On-premise deployment model (CUP as presence server)

     This requires VPN connection when outside corporate network to access telephony, voicemail, e.t.c.

2. Cloud-based deployment model

     This does not require VPN connection.



Level 1
Level 1

Hi All,

We are having the exact same issue... were you able to resolve it?



Fahim Sha
Level 1
Level 1



Hello Guys,


I have the exact issue mentioned by DanielGoQ_2 at one of my sites.




Level 1
Level 1

Hello DanielGoQ_2

I had this problem and was solved with this link:

I do not hear anything on my first call, what should I do?
The solution is to deactivate the USB devices standby.


  1. Access the Windows power management : go to the control panel, then select "Hardware and Sound", select "Power options" and then "change plan settings" in progress (Select button).
  2. "Change advanced power settings".

3. Go to "USB settings", then "USB selective suspend settings" and select "Disable" "on battery" and "plugged" as shown in the image below.

Best Regards

Eduardo Caserta