cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11239
Views
20
Helpful
15
Replies

Jabber 11.9 USER-XML not working

Davemzcs2
Beginner
Beginner

After i upgraded Jabber to 11.9 i am not able to use custom tabs, etc. using the jabber-config-user.xml on my windows 10 computer.

 

I tried resetting the jabber, erasing it completly from my computer, i used another computer -also win 10- with a different account, etc. nothing seems to work.

 

does anyone have the same problem with this version?

 

 

1 Accepted Solution

Accepted Solutions

I created a TAC ticket on this and this is the answer I received. Using version 11.9.2

 

TO make this work on a per-user basis you need to create an XML file called jabber-config-user.xml and upload it to Call Manager TFTP server. 

 

Then go to the user account for the user you want to apply it to and override local config and specifiy the file name in the CISCO SUPPORT FIELD under your CSF account, then restart your TFTP server. Make sure all devices have latest code if restarting TFTP during business hours or those out of date phones\devices will experience delay in reconnecting as they upgrade. 

 

The additions I made are - however still not working. I will update once I figure it out. Although it seems I am following TAC's directive to a tee. 

<EnableSaveChatHistoryToExchange>true</EnableSaveChatHistoryToExchange>
    <ExternalExchangeServer>"webmail"</ExternalExchangeServer>
    <InternalExchangeServer>"mail server"</InternalExchangeServer>
    <ExchangeAuthenticateWithSystemAccount>true</ExchangeAuthenticateWithSystemAccount>

 

View solution in original post

15 Replies 15

Jaime Valencia
Cisco Employee
Cisco Employee

If you generate a PRT, do you see the custom .xml you're supposed to be using being downloaded properly?

HTH

java

if this helps, please rate

Rich Eells
Beginner
Beginner
I'm not sure what the workaround is, but I think this is the cause.

I believe this is due to encrypting user data Jabber 11.9+

Once we upgraded to Jabber 11.9 all of the files in the C:\Users\<USERNAME>\AppData\Roaming\Cisco\Unified Communications\Jabber\CSF\Config file changed from .XML to .DAT. The .DAT files are encrypted. It would appear that Jabber ignores all .XML files that are locally edited.

Here are the release notes about the change:
"Encryption of User Data—With the introduction of fast sign-in feature in 11.9 release, user data such as, contacts, chat history, call logs, favorites, cached server configuration, user credentials and voicemail are all encrypted. This security enhancement helps protect customer data in the event of device loss, malware, or a security breach."

Release Notes Link: https://collaborationhelp.cisco.com/article/en-us/ncb2mep

Hi Rich-

 

First of all thank you for the time you spent helping me with this and in the second place i'm trying to find a workaround for this "issue", hope Cisco can help us solve this.

 

regards,

Did anyone find a work around for this?  (using a local .xml file to override some of the global settings)

I have not found the solution for that....i just know that the file that replaced the local XML config is now encrypted so configuring locally is not gonna work.

 

I think there is something we have to do/upload in the CUCM  in order to Jabber to download the config files from it.

 

Regards,

I created a TAC ticket on this and this is the answer I received. Using version 11.9.2

 

TO make this work on a per-user basis you need to create an XML file called jabber-config-user.xml and upload it to Call Manager TFTP server. 

 

Then go to the user account for the user you want to apply it to and override local config and specifiy the file name in the CISCO SUPPORT FIELD under your CSF account, then restart your TFTP server. Make sure all devices have latest code if restarting TFTP during business hours or those out of date phones\devices will experience delay in reconnecting as they upgrade. 

 

The additions I made are - however still not working. I will update once I figure it out. Although it seems I am following TAC's directive to a tee. 

<EnableSaveChatHistoryToExchange>true</EnableSaveChatHistoryToExchange>
    <ExternalExchangeServer>"webmail"</ExternalExchangeServer>
    <InternalExchangeServer>"mail server"</InternalExchangeServer>
    <ExchangeAuthenticateWithSystemAccount>true</ExchangeAuthenticateWithSystemAccount>

 

This method does work.  The drawback is that it requires you provision a CSF device for the user which could impact licensing etc.  The old method was much easier as it would work for an IM-only user.  It seem this may not be possible anymore.

 

TAC's direction is not quite accurate.  You need to provide a FULL Jabber config file using that method.  The client doesn't add the commands from the Cisco Support Field config file, the client uses the file provided in the Cisco Support Field INSTEAD of the base file jabber-config.xml

 

in that field you need use the following format for the unique config file.  It can have any name

configurationfile=bv-jabber-test.xml

 

Thanks for the added info. 

 

I am using this whole file with the added switches for Exchange integration and still not getting joy. 

 

The old method certainly no longer works, that has been proven. 

 

The new method to add CSF (albeit possible license problems) is supposed to work. I am not seeing the added fields so I must be doing something wrong still. 

 

<config version="1.0">
  <Client>
    <Persistent_Chat_Enabled>true</Persistent_Chat_Enabled>
    <EnablePrt>true/EnablePrt>
  </Client>
  <Options>
    <StartCallWithVideo>false</StartCallWithVideo>
    <Start_Client_On_Start_OS>true</Start_Client_On_Start_OS>
    <AllowUserCustomTabs>True</AllowUserCustomTabs>
    <EnableSaveChatHistoryToExchange>true</EnableSaveChatHistoryToExchange>
    <ExternalExchangeServer>"webmail"</ExternalExchangeServer>
    <InternalExchangeServer>"internal"</InternalExchangeServer>
    <Location_Mode>EnabledNoPrompt</Location_Mode>
    <Location_Matching_Mode>MacAddressWithSubnet</Location_Matching_Mode>
    <ConfMediaType>WebExOnly</ConfMediaType>
  </Options>
  <Policies>
    <InitialPhoneSelection>deskphone</InitialPhoneSelection>
    <EnableSIPURIDialling>true</EnableSIPURIDialling>
    <DirectoryURI>mail</DirectoryURI>
    <BDIDirectoryURI>mail</BDIDirectoryURI>
    <TelemetryEnabled>false</TelemetryEnabled>
  </Policies>
  <Directory>
    <BusinessPhone>telephoneNumber</BusinessPhone>
    <BDIBusinessPhone>telephoneNumber</BDIBusinessPhone>
    <OtherPhone>ipPhone</OtherPhone>
    <BDIOtherPhone>ipPhone</BDIOtherPhone>
    <DirectoryURI>mail</DirectoryURI>
    <SipUri>mail</SipUri>
    <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
    <BDISipUri>mail</BDISipUri>
    <BDISipUriToResolveContacts>true</BDISipUriToResolveContacts>
  </Directory>
</config>

 

Did you get any further direction from TAC? 

I am in the same place you are.

My issue I was missing the following in the top of my XML config file.

 

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">

Are you installing locally or pushing through TFTP? Cant get local policy jabber-config-user.xml to work.

You have to use TFTP, local copies are no longer editable.

I have tried all of the above to add the Hunt/Pick up button in the GUI of Jabber for windows 11.9, editing the Jabber-config.xml updating to tftp and also creating and specifying my own in tftp and nothing appeared to work. I was trawling through the Jabber install directory on my client desktop and found Jabber-config-defaults.xml, I modified this and hey  presto there was my configuration change. So next thing is to upload this file to the tftp server to seeif it will work for everyone.

OK so I have tried to upload and use tftp for this using both Jabber-Config-Defaults.xml and Jabber-Config.xml and neither work.

So I can modify locally Jabber-Config-Defaults.xml but can't push out the changes via tftp

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: