Showing results for 
Search instead for 
Did you mean: 


Jabber Contacts resolution with Version 11.9.1 - ""



our cisco jabber contact resolution has always worked perfectly. From version 11.9.1 onwards we have on the Windows client and mobile phones the problem that he can no longer assign the account. But only show with "@". What has changed with the new Jabber version? and what have to adjust with us? Unfortunately we can find nothing in the release notes. Old Jabber versions work flawlessly

Thank you

Slavik Bialik
Rising star

Works fine for me.

I'm guessing you're using Expressway with MRA, right? So... Is the external domain "" is also the internal domain, or the internal domain where the Active Directory and CUCM / IM&P resides is difeerent?

yes exactly will use the expressway mra. with the external domain This is how this contact resolution works from external.
from internal it does not work anymore. here is our domain schnaithmannag.local.

but we do not use internally directly on LDAP, we connect via xphone virtual directory. Here we use "jid" as sAMAccountname

this had always been so

Thanks for the info.

Can you please verify / do:

  1. Under which domain the CUCM & IM&P configured? Internal or external?
  2. Can you please share a screen shot of IM&P settings from: Presence -> Settings -> Advanced Settings.
  3. Can you please share a screen of an end user from CUCM? Please do not censor the following:
    1. User ID
    2. Directory URI
  4. If it's like Active Directory, user should have a full URI, like user@schnaithmannag.local, if so, what is the URI of a user in your VDir, user@schnaithmannag.local or ?

If you have an issue to post those screen shots here publicly, please send it to me privately.

we have configured the external domain everywhere. see screenshots.

in the virtual directory we have no "URI" field. we are working with the parameter: <UserAccountName> jid </ UserAccountName>

jid = sAMAccountName

which field should we add as in the virtual directory and how to fill it? we also need to adjust the jabber-config?

Can't say for 100%, but looks like jabber-config is fine. But, I would try to take a Wireshark capture from the PC running the Cisco Jabber. You should see traffic of TCP/389 that is intended to your VDir, in those packets you can see the filter that the Cisco Jabber applies in order to find those users. Take this filter and try it out on your VDir, and see what is wrong with the filter (if that's the case of course). Update us will the results (or share the capture also with us) so then we'll know better what to modify.

I think I found something, in a "What's New in Cisco Jabber for Windows 11.8.0" document.


Take a look:

Contact Resolution Improvements —Contacts in Jabber can come from different sources. This release includes some changes in the way Jabber compares these contacts and resolves the information to merge the contact records. To view the Contact Resolution data, in the hub window, select Ctrl+ Shift+C.

Jabber compares the contact record fields in the following order:
  1. Jabber ID (JID) – If the records have a JID, the records are matched based on the JIDs and no further comparison is done on the mail or phone number fields.

  2. Mail – If the records have a mail field, then the records are matched based on the mail field and no further comparison is done for phone numbers.

  3. Phone Number – If the records have a phone number, the records are matched based on the phone number. As the records are compared and a match is found, the contact information is merged to create one contact record.


I'm having a feeling that now it tries to look for full JID, for example in your screen shot of VDir you supplied, the JID is "OfficeMaster". So I think it tries now to look for: "".

Can you please try to change the JID of a few users in the VDir and add the "" as a prefix of their JID? And then try to logout & reset cisco jabber settings and login again, and see if those users you changed their JID are resolved now or not.


If the above still not working, I would defenatly try to do what I wrote in my previous comment - take a Wireshark capture.


Edit #1:

Also, just saw now in the same document I was talking about this section:

Cisco Directory Integration (CDI)

This release includes changes to the way LDAP is configured. Cisco Directory Integration (CDI) replaced Basic and Enhanced Directory Integration (BDI and EDI). Jabber uses service discovery to automatically detect the directory server and also how to connect to it. You have some optional configuration available if you want to prioritize authentication methods, or define the primary server.

If you want to customize your LDAP configuration, there is now one set of CDI parameters that apply to all clients. The CDI parameters are the same as EDI parameters, and do not require any further action. The BDI parameters are no longer supported, so if you're upgrading from a BDI-only deployment, you must update your LDAP configuration.

For more details on how CDI works, including a detailed description of how to upgrade to 11.8 from a BDI contact source and a complete list of parameters affected by moving from BDI and EDI to CDI, read LDAP Option: Cisco Directory Integration (CDI) in the Planning Guide for Cisco Jabber 11.8.



It looks like they changed all the EDI and BDI support. As they are stating (marked in bold) that if you moving up to this new release you need to upgrade your directory configurations.


By the way, I don't really like to to make directory configurations in the jabber-config, although I'm mostly working with Active Directory servers at my clients. I'm always configuring the Directory services in the Service Profile in the CUCM. Maybe you can try to do the same and it'll catch. But if you do it, of course remove the settings from jabber-config file so it won't collide.


Edit #2:

Heh, regarding Edit #1, please also see this document, it describes the changes that need to be done for every parameter in the jabber-config if you're coming from mixed EDI/BDI configurations:

Relate to "Scenario 4: If you are upgrading to 11.8 from a mixed EDI/BDI configuration" in the document.

thank you 

I have changed jid to, but then the contact resolution does not work anymore.

the settings we have made as we moved to version 11.8 / 11.9. this has since then also function, only in the 11.9.1 no more.
It is also comical that in the contact list all contacts are displayed correctly, if you click on profile the contact is so funny with @ displayed.

my colleague created a wireshark protocol

Bahh, had hopes for this idea.
I also noticed this strange thing that contacts appear only with "@", it is more common that when the contact resolution isn't working that it'll appear like that: "". Tried to look for similar Cisco bugs, but found none.

See the Wireshark captures and the filters that Cisco Jabber applies when it tries to do the contact resolution, I bet you'll find something there.

BTW, are you saying that in 11.8.x it's working fine? Did you also tried 11.9.0 instead of 11.9.1? Just out of curiosity.

Hi Slavik,

I'm the workmate from @schramlphilipp and will answer some questions. All clients using 11.9.0 and works fine. But in 11.9.1 it doesn't work anymore... Can you take a look on our jabber-configuration.xml file, will this config work in 11.9.1? Did we have to change some parameters in the config, because of Cisco Directory Integration?
Best regards,


can anyone help us please?

I tried to read all the release notes of 11.9.x, and especially 11.9.1.
Also, I tried to look for Cisco Bugs on this matter, but I couldn't find anything that can lead us to the problem. And I know it's not a solution, but maybe for now you can stay and use 11.9.0, and maybe (a big maybe) in 11.9.2 somehow this issue will be fixed, unless it's Cisco bug that wasn't found and reported.

By the way, did you try to pull Wireshark capture and see all the traffic to VDir from the PC running Cisco Jabber? Maybe the filter towards VDir is wrong or something like that, and we can spot it in the capture, so if that's the case it can lead us to the issue and even maybe we can find a related cisco bug or something like that.
If you want, you can share privately the Wireshark capture so I can see if there's something wrong there.
Greg Mora

Did you resolve this? We are now seeing this problem as well. 

Yeah, he resolved it. He sent me the solution in a private message.

He moved the directory settings from the jabber-config.xml file to the Service Profile configurations, like that:VDir-Service-Profile.jpg




I guess I am not having the exact same issue. I am actually connecting to Microsoft AD via Global Catalog but it doesn't resolve on a Mac. Does Mac use CDI or do i still need EDI?
All of our clients are 11.8 +
Recognize Your Peers
Content for Community-Ad