cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1049
Views
0
Helpful
6
Replies
Highlighted

Jabber for IPad no audio or video connected through Internet to VCS-E behind fw NAT

Good Day,

Hope you can assist me with resolving the issue I have with my Jabber for IPAD client connected to the Public network, and registering to my VCS-E with TMS that is behind a fw and both have static NAT. The Jabber client can register to my VCS-E and I am able to make calls to my C40 but no audio or video gets through.

When I do a Wireshark trace I can see the communication between Jabber and the VCS-E both on the public IP. As soon as the call has been setup the communication changes and the Jabber client starts talking direct to the C40 on it's internal Network IP. I understood that the communication will always proxy through the VCS and that is why it's got a static NAT. The network is setup in the following way:

C40 ---> VCS ---> TMS ---> F/W ---> Internet ---> Jabber client on IPAD.

6 REPLIES 6
Highlighted
Participant

Jabber for IPad no audio or video connected through Internet to

Hi,

How is the VCS-e set up - does it have the dual network interface option key?

Is the C40 registered to VCS-e or VCS-c?

Highlighted

Jabber for IPad no audio or video connected through Internet to

Hi,

Thank you for the response. The VCS-e have the dual network interface option but it is not used currently.

The C40 is registered to VCS-e as SIP and H323.

What I have tested this morning was to disable SIP for the C40.

I can now call from my Jabber IPAD Client to the C40 via the Internet, audio is working both ways. Video from the C40 is displayed on my IPAD but the video stream from my IPAD is not getting to the C40.

I have also tested this from a jabber client on my laptop via the Internet. This works perfect. I have Video and Audio both ways.

Highlighted
Participant

Jabber for IPad no audio or video connected through Internet to

Can you confirm the following has been done, on the System > IP web page on the VCS-E if you are using static NAT:

To enable the use of a static NAT:

  1. Ensure that the Dual Network Interfaces option key is installed.
  2. For the externally-facing LAN port:
    1. In the IPv4 address field, enter the VCS Expressway's private IP address.
    2. Select an IPv4 static NAT mode of On.
    3. In the IPv4 static NAT address field, enter the VCS Expressway's public IP address - this is the IP address of the outside of the NAT.

Another thing you could try is the following setting if you SSH to the VCS and log in as admin:

xConfiguration SIP MediaRouting ICE Mode ?

xConfiguration SIP MediaRouting ICE Mode:

"Controls whether the VCS will take the media for an ICE -> non-ICE call where the ICE participant is thought to be behind a NAT device. Default: Off"

Normally it should be set to off though.

Highlighted

Jabber for IPad no audio or video connected through Internet to

Thanks I will try the ssh options. Here is the options loaded:

Active options

20 Non Traversal Calls, 10 Traversal Calls, 2500 Registrations, 1800 TURN Relays, Expressway, Encryption, Interworking, FindMe, Device Provisioning, Dual Network Interfaces.

I am using LAN 2:

with IPv4 address Static NAT on and Static NAT address entered.

Highlighted

Jabber for IPad no audio or video connected through Internet to

Hi, I tried the settings as adviced but still experiencing same problem. Jabber on PC from Public network works fine. Jabber on IPAD from Public network no video being streamed from IPAD to C40.

Highlighted
Participant

Jabber for IPad no audio or video connected through Internet to

Ok, I think this will need a TAC case opened to be able to investigate logs more fully now.

Thanks,

Guy

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey