cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9741
Views
20
Helpful
4
Replies

Stop Jabber From Becoming Default IM

todd coplien
Beginner
Beginner

Hi All!

I'm curious what the correct procedure is for stopping Jabber from taking the default IM away from my preferred IM each time Jabber loads? I know it would be ideal to only use one IM Application but in my case that just isn't possible at the moment. I use Jabber strictly for phone integration and call forwarding as I work remote. I use *cough* Lync as my default IM Application. It is the App I would like integrated with Outlook. Which I can make it the default after every load but is there a way to make it permanent? I know I can change the IM Providers key but if I close Jabber and then load it again, it takes over the default and I have to change it back! Please let me know your thoughts and what, if any, additional info you need from me! :)

4 Replies 4

Dennis Mink
Advisor
Advisor

This behaviour is embedded in the Jabber client software itself. Cannot be disabled. So, good reason to get rid of Lync

Please remember to rate useful posts, by clicking on the stars below.

This is a really unsettling "feature".  I love using Jabber for the soft phone, but our business uses Skype for Business for IM.  So Cisco Jabber automatically becoming the default IM provider without giving me the option is extremely frustrating because it resets my presence indicators and chat features from Office.  Didn't Microsoft get sued and lose years ago because it automatically made IE the default browser and didn't let users have an option to select another?  This is bad form

If you install with

CLICK2X=DISABLED or CLICK2X=Click2Call

on the MSI command line, it will not take over the DefaultIMApp setting.

 

Details about which is the better one to use can be found here.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/12_7/cjab_b_deploy-jabber-on-premises-127/cjab_b_deploy-jabber-on-premises-127_chapter_010000.html?bookSearch=true 

 

itsflannO
Beginner
Beginner

I was able to fix without a re-install

go to Computer\HKEY_CURRENT_USER\SOFTWARE\IM Providers in regedit

Make sure the key "DefaultIMApp" is set to your preferred program, mine is "Teams" 

Right click the key, disable inheritance and set it to read only. 

 

I also deleted the Jabber key under IM Providers, but don't think this did anything in the end, worth trying though if above does not work

or set UpAndRunning to 0

 

extremely disappointing that cisco would force this on without a setting for it. Just scummy behaviour. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers