Showing results for 
Search instead for 
Did you mean: 


Wrong IM Address resolved

Hi all;

I am having an issue with one user. When (so far 2 have reported) trying to message 1 particular user, they get a message that the message could not be delivered. When viewing the profile of the contact, the information is incorrect. The email address is listed as and the IM address is listed incorrectly, also as The IM address in our environment (which works for everyone else) should be It is correct for many other people IMing this person, but for some reason these 2 clients do not resolve it properly.

No personal contact for the user either... i'm stumped!

Bradley Gruesbeck
Cisco Employee


The bad entry could be a result of a few different causes so you may have to perform some testing to track it down. Could be that the end user's did have an old contact or maybe they added the end user's information incorrectly?

I suggest the following:

- Delete the bad contact, and clear the cache from the local computers (see details below). Then perform another search for that user. Did it show up correctly from the directory search? Maybe those users are getting bad info from CUCM or AD? If you add that account then maybe we have a simple case of the account contained incorrect data at one point and somewhere along the way the data was corrected.

We have seen where the local cache can mess with something like this. It could have been where the local cache did a search for the user at one point and had retained the incorrect data prior to that account being added. The main takeaway would be to make sure that the end users (with the record removed and cache cleared) can find the correct data for the account in question. If it doesn't then we know what happened and then you'll have to track down where that data is coming from.

To clear the local pc cache sign out of Jabber and remove/rename the following folders:

Windows 7

%USERPROFILE%\AppData\Roaming\Cisco\Unified Communications\

%USERPROFILE%\AppData\Local\Cisco\Unified Communications\

Windows XP

%SYSTEMROOT%\Documents and Settings\user_name\Local Settings\ApplicationData\Cisco\Unified Communications\

%SYSTEMROOT%\Documents and Settings\user_name\Application Data\Cisco\UnifiedCommunications\

Good Luck,



thank you for the reply. As part of the troubleshooting we deleted the contact by logging in as the user to the presence server (get an error the contact cannot be deleted when trying from client.)

We then re-added the contact through the client. All worked fine for a day or so, then reverted back to the incorrect value...

Thanks for the info.

So this behavior doesn't happen for all users, only a couple?

What version of Jabber are you running? Are all clients the same in your environment?

When you say you re-added the contact back via the client, are you using AD or CUCM for directory resolution?

It is interesting that it worked for a day or so before breaking again. Something updated that record from your directory so you may also need to find out if those accounts are using a jabber-config.xml file as well. If this issue is only affecting just a couple of users then we can say that something on their computers could be causing it (i.e incorrect client version or bad jabber-config.xml file). Might I suggest also, having one of those end users logging into a different computer to see if the issue follows the end uers's account or if it only related to their pcs?

Keep me updated on what you find out.


Correct, not all users. Seems to revolve around a few users sending to ONE specific user. all clients are on 9.2.2. We have Jabber set up in EDI mode.  So AD synchs into CUCM... not sure the answer to your question...

Funny you should ask, I just had someone log into another pc and got the same results. What is very confusing to me is at the client level the IM address is incorrect, but logging into the presence page as the user, the contact is correct.

I appreciate the help. Of course it is happening to one of the directors here!

Brad Pajari


I also have the same issue with a couple of user who have a contact in their Jabber for windows contact list, who's IM address changes out of the blue to to their SMTP address?? Correct on cup server, but wrong on client.  I have user remove user from contact, exit client then search and re add them.. This works, but only temporary.  I will change randomly , user finds out when he IM contact and they get the "Message can't be delivered". We are running 9.2.4 client, and I was told that it can look in serveral place such as AD, Outlook, Recent calls, VM and sometimes merge records. But I can't find where IM address of user is different?

Recognize Your Peers
Content for Community-Ad