cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

CCB user.CourtesyCallbackEnabled shows =0

844
Views
0
Helpful
2
Comments
This document was generated from CDN thread

Created by: Luis Yrigoyen on 10-09-2013 11:09:09 AM
I'm setting up CCB and I'm running into this problem:
The value of the user.CourtesyCallbackEnabled parameter keeps showing up as "0" eventhough I'm changing it to a "1" in ICM. 
In the CVP app logs it shows as "0".  
I've queried the TCD table and I can see that it changes values when Set.

All of my other settings seem to be fine, "probe", etc.

****excerpt from the CVP VXML app activity log:****
start,parameter,_userCourtesyCallbackEnabled=0
start,parameter,_ccbServlet=http://10.8.3.181:8000/cvp/CallbackServlet
custom,probe outcome,id:10.8.3.3;loc:GW-3925-03;trunks:20
Validate_02,data,result,none
Validate_02,exit,none
*************

That I know of, this parameter is not dependent on any other CCB ralated setting, it is used to manually "Enable callback or shut it off".

Running UCCE 9.0.1, CVP 9.0.1

thank you for your help

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Paul Tindall on 10-09-2013 12:16:55 PM
Make sure your call is in queue.

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Luis Yrigoyen on 10-09-2013 01:32:50 PM
Paul,
The call is being queued, I can see it in the RT.
I thought the user.CourtesyCallbackEnabled parameter was only to turn it on/off. 


thanks

Subject: Re: New Message from Luis Yrigoyen in Customer Voice Portal (CVP) - General
Replied by: Bill Westby on 10-09-2013 01:48:07 PM
That is correct, set it to "1" to enable it as it seems you have done, I
include the quote marks around it to make it a string.  No need to pass it
in with the VXML params, comes in automagically.  I'm on 8.5.4.

10.48.143.193.1378818804249.79869.CallbackEntry,09/10/2013
08:13:30.327,,end,duration,6
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,newcall,
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,ani,6512641438
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,areacode,651
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,exchange,264
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,uui,NA
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,iidigits,NA
*10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,_userCourtesyCallbackEnabled=1
*10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,ani=6512641438
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,qname=DBSOSGOVT
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,callid=92FCA68D195111E39C7A44D3CAF1C680
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,q=n
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,queueapp=DBSOSGOVTQueue
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,_ccbServlet=
http://10.48.143.211:8000/cvp/CallbackServlet
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,ewt=0
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,_ani=6512641438
10.48.143.193.1378818791124.79867.CallbackEntry,09/10/2013
08:13:11.124,,start,parameter,_ccbServletReqTimeout=10

Bill Westby.

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Luis Yrigoyen on 10-09-2013 02:14:25 PM
Bill,
I'm setting it using a set node non-vxml (set call.call...) value "1".
I've done a couple of CCB implementations and frankly I've never given this variable much attention. I create it, set it to "1" and move on.
Does it depend on other settings/status?

Thanks

Subject: Re: New Message from Luis Yrigoyen in Customer Voice Portal (CVP) - General
Replied by: Bill Westby on 10-09-2013 02:31:25 PM
I agree, should be a no brainer.

I've got it in my ECC variable user.CourtesyCallbackEnabled configured with
max length 1, Enabled, and Persistent.  The ops console got both call
servers configured for CCB, here's what I followed:


1)     Login to CVP Operations Console

2)     Go to System->Courtesy Callback

3)     On the General tab:

a.     Select the Reporting Server to use for Courtesy Callback

b.    Do *not* enable “Secure Communications” with Courtesy Callback
database option.

c.     Check box “Allow Unmatched Dialed Numbers”

d.    Leave maximum number of calls per calling number at 0.

4)     On the Call Server Deployment tab:

a.     Deploy to both Side A and Side B Call Servers

5)     Click Save and Deploy when finished.

Other than that I didn't have to do anything else on 8.5.4.

Bill.

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Luis Yrigoyen on 10-09-2013 03:10:47 PM
yep, I've done all that...
On the activity log I can see everything coming back as it should i.e. probe OK, GW assigned, queue defaults, etc. 
but since the user.CourtesyCallbackEnabled = 0, the second Validate element retruns with a "none" which means "The callback is not allowed".

Subject: Re: New Message from Luis Yrigoyen in Customer Voice Portal (CVP) - General
Replied by: Janine Graves on 10-09-2013 03:49:07 PM
Luis, I don't know if this matters, but did you configure through the Ops Console System>Courtesy Callback - and select a Reporting Server and the allowed dialed numbers? -- Janine Graves

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Luis Yrigoyen on 10-09-2013 08:36:55 PM
Janine,
Yes, I have it the "allow unmatched Dialed Numbers" checked.


thanks

Subject: RE: CCB user.CourtesyCallbackEnabled shows =0
Replied by: Luis Yrigoyen on 11-09-2013 11:42:32 AM
I restarted the call server services via OPS and that fixed it...I had done it the night before also but they were some changes to the reporting server during the day.
Once the restart happened, CVP started seeing the variable but before it didn't know it was there.

thank you all very much for your help...

On a raltated topic; while troubleshooting, I tried to pass a "_userCourtesyCallbackEnabled=1" , using ToExtVXML to CVP but it didn't work.
Isn't that doable?

thanks
Comments
Beginner

Hello,

I can record the Name and The Phone Number afterwards the prompt says that the Courtest CallBack Request has been successfully scheduled Good Bye.

I made the agent ready. But CCB is not getting done (and agent is not getting reserved). Jyust FYI I am testing the CCB first for IP base environment.

Looking forward for your kind response,

BR,

Durraze

Cisco Employee

Hi Durraze,

The CCB triggering depends on multiple factors apart from agent being ready. The critical one is EWT time. Once all criteria are met the callback occurs. I hope the other conditions are met for the callback to trigger.

Please refer the CCB configuration section in the CVP design doc : Design Guide for Cisco Unified Customer Voice Portal, Release 10.5(1) - Features and Functions [Cisco Unified Customer …

Thanks

Bikram

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here