cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

JavaCil.jar and Jdk version 1.5

798
Views
0
Helpful
1
Comments
This document was generated from CDN thread

Created by: Vijay Jayapalan on 29-09-2009 09:53:06 PM
We are unable to run the samples provided with the CTIOS installation.
We require to build against JDK 1.5 only and need to know if there is a JavaCil.jar that is compatible with version Sun JDK 1.5
 

Subject: RE: New Message from Vijay Jayapalan in Computer Telephony Integration Obje
Replied by: David Lender on 30-09-2009 01:58:54 PM
CTIOS 7.5(x) supports JDK 1.4.2 (see the CTIOS Developer's Guide)

JDK 1.5 support is not currently provided.

.

Subject: RE: New Message from Vijay Jayapalan in Computer Telephony Integration Obje
Replied by: David Lender on 30-09-2009 02:11:54 PM
Update:

CTIOS JavaCil 7.0 => JRE/JDK 1.4.2_05
7.0 SR 1 => JRE/JDK 1.4.2_08
7.0 SR 2, 7.1(1), 7.1(2), 7.1(3), 7.1(4), 7.1(5) =>  JRE/JDK 1.4.2_10

7.2(1), 7.2(2), 7.2(3), 7.2(4), 7.2(5) => JRE/JDK 1.4.2_13

For release 7.5(x), Java JRE/JDK 1.6_05 or higher is supported.

7.5(x) => JRE/JDK 1.6_05 (or higher)

Subject: RE: New Message from Vijay Jayapalan in Computer Telephony Integration Obje
Replied by: Becky Plourde on 20-08-2010 05:25:44 PM
Has anyone successfully recompiled the 7.5(9) JavaCIL (JRE/JDK 1.6) files with JRE/JDK 1.4?  Customer's environment only supports 1.4 and we are upgrading ICM/CTIOS to 7.5(9).  As stated earlier in this post, the 7.5 developer's guide states that Java 1.4 is supported, but everything else says 1.6 and I cannot find a 1.4 version of the 7.5(9) CIL.
 
Any info provided is greatly appreciated.
 
 
Comments
Contributor

CCE does not support changing the Java major/minor version, such as 1.6 to 1.7.

Refer to the product security guide and compatibility matrix for CCE version-specific details.

Jim

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.