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szelenka
Cisco Employee
Cisco Employee

TITLE

Jabber Mac not pulling pictures from directory

SYMPTOMS

Contact picture and some phone numbers are not getting pulled from LDAP, where you might be only getting the mobile number or nothing at all.  The CUPS directory mapping is configured to map the userid to sAMAccoutnName, and you have pictures stored on a web server with SSL encryption for each user that maps to their sAMAccoutName.  The client diagnostics may illustrate something similar to:

2012-05-11 10:49:58.392 WARNING [main] - [OldCSILDAPPersonRecord photoURL] - was not able to transform URL https://domain.ext/path_to_images/%%sAMAccountName%%.jpg

ENVIRONMENT

Cisco Jabber for Mac 8.5.1

Cisco Unified Presence Server 8.5.1-10000-35

Contact images on 3rd part web server with SSL

CAUSES

The web server hosting the pictures has an invalid or unsigned SSL certificate which is not trusted by the Mac OS.  So when the client attempts to download the images, it will abort after the SSL certificate verification fails.

RESOLUTION

  1. Use a signed security certificate on the web server that's hosting the contact images
  2. Verify the web server certificate is trusted at the Mac OS level
  3. Alternatively use a non-SSL web server to host images (http://domain.ext/path_to_images/%%sAMAccountName%%.jpg)

PREVENTION

Verify CUPS, AD, and web server configuration where images are being stored.  Also be aware of any security issues when accessing the web server, such as invalid or self-signed certificates.

RELATED TOPICS

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