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Symptoms

Cisco Jabber MRA login fails from Android and iOS

Diagnosis

      ++ Jabber for IOS 14.1.0 on IOS Version 15.3.1. When logging into Jabber, the app locks up when Loading Contacts. The app does not progress. There is no option to pull a problem report. The only option is to close the app and re-launch.

       ++ When a user logs into Jabber for Android 14.1 via expressway, they get a blank screen and cannot use Jabber at all. When they log in via VPN, Jabber logs in fine.

Solution

Enabling Unified CM, CUC & IM&P

To enable OAuth to perform the following procedure
1. Go to Cisco Unified Communications Manager Admin > System > Enterprise
Parameters > SSO and OAuth Configuration
2. "Select OAuth with Refresh Login Flow" set Enable/Disable support OAuth feature

 

 

Enabling Unity Connection:

To enable Unity Connection for OAuth support, the administrator must perform two steps.

1) Go to Cisco Unity Connection  > Enterprise Parameters > Enable the OAuth service

2) To fetch the signing and encryption keys Unity must be configured with the Unified CM
host details and a user account enabled for Unified CM AXL access
Go to AuthZ Servers > Add New

 

Enabling Expressway
If Expressway is providing Mobile and Remote Access to Jabber clients, then the following
the procedure can be used to enable Expressway servers for OAuth with a refresh.
1. Connect to the Expressway-C server and navigate to
Configuration > Unified Communications > Configuration

 

Navigate to the Configuration > Unified Communications > Unified CM servers
and select each cluster by ticking the box next to the publisher address, and then
click refresh servers. This allows Expressway-C to fetch the signing and
encryption keys from Unified CM that will be used by Expressway-C to verify each
access and refresh token used by the Jabber clients connecting over MRA. This
Unified CM refresh operation is a standard practice that needs to be performed after
upgrading or making significant configuration changes on Unified CM.

 

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