06-12-2014 07:59 AM - edited 03-14-2019 01:31 PM
hello everyone
i config a ucce and use CVP to play the promp.
the IVR need to use TTS . now the TTS receive the Gateway send text and creat the audio ,but the gateway not play....i only config GW....
the attachment is my CVP script and TTS audio config
next is my gw config (TTS server is 10.22.1.43)
[BEGIN] 2014/6/12 22:47:33
sh run
Building configuration...
Current configuration : 14308 bytes
!
! Last configuration change at 14:11:27 beijing Tue Jun 10 2014 by admin
! NVRAM config last updated at 16:22:07 beijing Wed Jun 4 2014 by admin
! NVRAM config last updated at 16:22:07 beijing Wed Jun 4 2014 by admin
version 15.1
service timestamps debug datetime msec localtime
service timestamps log datetime msec
no service password-encryption
!
hostname BQ-GW1
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
card type e1 0 1
logging buffered 2000000
no logging console
enable password cisco,123
!
no aaa new-model
clock timezone beijing 8 0
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
network-clock-select 3 E1 0/1/0
network-clock-select 4 E1 0/1/1
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
no ip domain lookup
ip host tts-en-us 10.22.1.43
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
signaling forward unconditional
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
sip
header-passing
!
!
voice class uri tts sip
pattern tts@tts-en-us
voice class codec 1
codec preference 1 g711ulaw
!
voice class h323 1
h225 timeout setup 2
!
!
!
!
voice translation-rule 1
rule 1 /28811090/ /1002/
!
voice translation-rule 2
rule 1 /.*/ /28811090/
!
voice translation-rule 3
rule 1 /1002/ /3333/
!
!
voice translation-profile E1-incoming
translate called 1
!
voice translation-profile E1-outgoing
translate calling 2
!
voice translation-profile failover
translate called 3
!
!
http client cache memory pool 15000
http client cache memory file 500
http client connection timeout 60
http client connection idle timeout 10
http client response timeout 30
ivr prompt memory 15000
ivr asr-server rtsp://asr-en-us/recognizer
ivr tts-server sip:tts@tts-en-us
!
application
service new-call flash:bootstrap.vxml
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
service survivability flash:survivability.tcl
paramspace english language en
paramspace english index 0
param setup-timeout 7
paramspace english location flash
paramspace callfeature med-inact-det enable
paramspace english prefix en
param open-hours-time0 0123456:0000-2359
param open-hours-agent0 3333
!
service CVPSelfService flash:CVPSelfServiceBootstrap.vxml
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
service ringtone flash:ringtone.tcl
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
service cvperror flash:cvperror.tcl
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
service handoff flash:handoff.tcl
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
service bootstrap flash:bootstrap.tcl
paramspace english language en
paramspace english index 0
paramspace english location flash
paramspace english prefix en
!
!
mrcp client timeout connect 10
mrcp client timeout message 10
mrcp client rtpsetup enable
vxml tree memory 500
vxml audioerror
vxml version 2.0
license udi pid C3900-SPE150/K9 sn FOC16286TD8
license accept end user agreement
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
hw-module pvdm 0/2
!
!
!
username admin password 0 cisco,123
username cisco password 0 cisco
!
redundancy
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/0/1
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/1/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/1/1
framing NO-CRC4
pri-group timeslots 1-31
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.22.1.38 255.255.255.0
ip route-cache same-interface
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
fair-queue 64 256 0
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
fair-queue 64 256 0
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
fair-queue 64 256 0
no cdp enable
!
interface Serial0/1/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
fair-queue 64 256 0
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip rtcp report interval 2000
ip route 0.0.0.0 0.0.0.0 10.22.1.1
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
voice-port 0/0/0:15
cptone CN
bearer-cap 3100Hz
!
voice-port 0/1/0:15
cptone CN
bearer-cap 3100Hz
!
voice-port 0/0/1:15
cptone CN
bearer-cap 3100Hz
!
voice-port 0/1/1:15
cptone CN
bearer-cap 3100Hz
!
!
!
mgcp profile default
!
!
dial-peer voice 919191 voip
description CVP SIP ringtone dial-peer
service ringtone
incoming called-number 9191T
voice-class sip rel1xx disable
dtmf-relay rtp-nte h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 929292 voip
description CVP SIP error dial-peer
service cvperror
incoming called-number 9292T
voice-class sip rel1xx disable
dtmf-relay rtp-nte h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 111111 voip
description CVP IVR dial-peer
service bootstrap
incoming called-number 000T
voice-class sip rel1xx disable
dtmf-relay rtp-nte h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1000 voip
description CVP SIP Comprehensive dial-peer
destination-pattern 1...
signaling forward none
session protocol sipv2
session target ipv4:10.22.1.41:5060
voice-class codec 1
dtmf-relay rtp-nte h245-signal h245-alphanumeric
no vad
!
dial-peer voice 1001 voip
description CVP SIP Comprehensive dial-peer
preference 1
destination-pattern 1...
signaling forward none
session protocol sipv2
session target ipv4:10.22.1.42:5060
voice-class codec 1
dtmf-relay rtp-nte h245-signal h245-alphanumeric
no vad
!
dial-peer voice 1 pots
translation-profile incoming E1-incoming
translation-profile outgoing E1-outgoing
service survivability
destination-pattern 9T
progress_ind progress enable 8
progress_ind connect enable 8
progress_ind disconnect enable 8
incoming called-number .
fax rate disable
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 2 pots
translation-profile incoming E1-incoming
translation-profile outgoing E1-outgoing
service survivability
destination-pattern 9T
progress_ind progress enable 8
progress_ind connect enable 8
progress_ind disconnect enable 8
incoming called-number .
fax rate disable
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 500 voip
incoming called-number .
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
codec g711ulaw
!
dial-peer voice 50000 voip
destination-pattern 56...
session target ipv4:10.22.1.36
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 50001 voip
destination-pattern 56...
session target ipv4:10.22.1.37
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 pots
translation-profile incoming E1-incoming
translation-profile outgoing E1-outgoing
service survivability
destination-pattern 9T
progress_ind progress enable 8
progress_ind connect enable 8
progress_ind disconnect enable 8
incoming called-number .
fax rate disable
direct-inward-dial
port 0/1/0:15
!
dial-peer voice 4 pots
translation-profile incoming E1-incoming
translation-profile outgoing E1-outgoing
service survivability
destination-pattern 9T
progress_ind progress enable 8
progress_ind connect enable 8
progress_ind disconnect enable 8
incoming called-number .
fax rate disable
direct-inward-dial
port 0/1/1:15
!
dial-peer voice 6000 voip
destination-pattern 6...
session protocol sipv2
session target ipv4:10.22.1.50:5060
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte sip-kpml sip-notify
codec g711ulaw
no vad
!
dial-peer voice 1003 voip
description CVP down CUCM backup
destination-pattern 3333
session target ipv4:10.22.1.36
voice-class codec 1
voice-class h323 1
dtmf-relay cisco-rtp h245-signal h245-alphanumeric rtp-nte
no vad
!
dial-peer voice 1004 voip
description CVP down CUCM backup
destination-pattern 3333
session target ipv4:10.22.1.37
voice-class codec 1
voice-class h323 1
dtmf-relay cisco-rtp h245-signal h245-alphanumeric rtp-nte
no vad
!
dial-peer voice 1002 voip
preference 1
service survivability
incoming called-number 10..
voice-class codec 1
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
no vad
!
dial-peer voice 100 voip
session protocol sipv2
destination uri tts
dtmf-relay rtp-nte h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
!
gateway
media-inactivity-criteria all
timer receive-rtcp 4
timer receive-rtp 1200
!
sip-ua
retry invite 2
retry bye 2
timers expires 60000
sip-server ipv4:10.22.1.41:5060
reason-header override
permit hostname dns:gateway.bqipcc.com
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 10.22.1.38 port 2000
max-ephones 1200
max-dn 1800
system message primary BQ-IPCC-SRST
alias 1 3333 to 56000 cfw 3333 timeout 12
alias 2 3333 to 56001 cfw 3333 timeout 12
!
!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide