Showing results for 
Search instead for 
Did you mean: 

UCCX Upload XML Doc Issue

I've attached a script and I'm simply trying to get the XML doc dNumWeek (created after keyword transform document step using the create XML step) to upload and replace OnCallAgentUpdate.xml. Even though my script runs through and the agent is authenticated successfully and I get down to the upload document step, it will never actually upload the document. I'm not using the reactive debugger to test this, I'm simply stepping through using the UCCX editor. Everything else within the script works exactly as I need it to but the last step of trying to get the document to upload won't work no matter what I try. Below are a list of the things I've tried so far.


1. On the Upload Document step, I changed the language folder from default[default] to L[en_US] and placed the OnCallAgentUpdate.xml in there

2. I've removed the java code section and tried to do a simply parse out of an XML to generate a string and then perform a keyword transformation and upload that


The only way I can get the upload to step through as successful is to create a document variable and reference no document at all just DOC[] and then tell UCCX to upload that to OnCallAgentUpdate.xml and that works but obviously it just overwrites my xml with no data. The keyword transformation doc that's generated, I can't get that to upload no matter what I do. HELP PLEASE!! I've speed days working on this and beating my head against the table ha. I've attached the script I'm using as well as the XML files.


Anyone have any ideas on this? I would really appreciate it!! Thanks

Content for Community-Ad