cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

How to create a ESXi5 upgrade image with N1K VEM bits

6329
Views
0
Helpful
9
Comments
Cisco Employee

If you plan on doing a live migration from ESX(i) 4.1 to ESXi 5 you need to create an ESXi 5 image that includes the N1K VEM bits.

It's not difficult as long as you have the right tools, steps, and files. This is just a quick quide on how to create an ESXi 5 upgrade image with the Nexus 1000v VEM bits included. Please check out the official documentation. The intent here is to show where to get the actual offline bundles from and how to create the image using PowerCLI.

First you need the following

  1. VMware PowerCLI
  2. ESXi offline bundle file (VMware-ESXi-5.0.0-469512-depot.zip) used to create and upgrade image (available from VMware)
  3. VEM offline file (VEM500-201108271.zip) that gets combined with above ESXi offline bundle to create an upgrade ISO

PowerCLI

You can download PowerCLI from VMware's website at http://downloads.vmware.com/d/info/datacenter_cloud_infrastructure/vmware_vsphere/5_0#drivers_tools

Once you have it downloaded its just a simple double click install.

powercli.JPG

ESXi Offline Bundle

Download the offline bundle. On VMware's website at http://downloads.vmware.com/d/info/datacenter_cloud_infrastructure/vmware_vsphere/5_0

The offline bundle is part of the VMware ESXi 5.0 Installable.

esxi-depot-download.JPG

Nexus 1000v VEM offline bundle

Lastly you need the Nexus 1000V 1.4a zip file available for download from Cisco.com

n1kv-download.JPG

You need to expand the zip file and pull out the VEM offline bundle.

vem-depot.JPG

Make sure to grab the VEM500*.zip file thats the bundle for ESXi 5. Copy the ESXi and VEM offline bundles to the same host that you installed PowerCLI on. I stick them in C:\ So there is less typing

Create the Image

Start  PowerCLI (it looks like a cmd prompt once it's running) and type in the below commands. Assuming you have the same versions of code you can cut and paste. Otherwise you will need to modify the ESXi and VEM build versions. The first 3 commands appear to be optional depending on what version of PowerCLI you have. I still add them but if you get an error message when you type the command in don't worry about it.

Set-ExecutionPolicyremotesigned

Set-ExecutionPolicy unrestricted

add-PSSnapinVMware.ImageBuilder

get-esximageprofile

Nothing should be listed

add-esxsoftwaredepot C:\VMware-ESXi-5.0.0-469512-depot.zip

get-esximageprofile

Now it should show two packages a standard and "no-tools"

add-esxsoftwaredepot c:\VEM500-201108271.zip

get-esxsoftwarepackage -Name cisco*

should see cisco-vem-v131-esx

new-esximageprofile -Cloneprofile ESXi-5.0.0-469512-standard -Name ESXi5-n1k-upgrade

add-esxsoftwarepackage -Imageprofile ESXi5-n1k-upgrade -Softwarepackage cisco-vem-v131-esx

export-esximageprofile -imageprofile ESXi5-n1k-upgrade -Filepath c:\ESXi5-n1k-upgrade.iso -Exporttoiso

So what we are doing is loading the ESXi and VEM offline bundles into the PowerCLI image builder. Cloning the standard ESXi5 image. Adding the VEM bits to that image and finally exporting it to an ISO file that can be uploaded into VMware Update Manager to do an upgrade.

Pretty simple once you know where everything is and how it works.


9 Comments
Beginner

Hello, I tried to perform this procedure and followed it step-by-step and everything worked.  However, when I went to deploy the bundled ESXi image I got the following error message:

VUM+Nexus+Issue.png

Any ideas what the issue is?  The VSM is at version 4.2.1.SV1.4a.  Thanks.

Cisco Employee

Couple of quick questions.

Do you have the most recent version of 1.4a?

What version and type of ESX are uprading from? is ESX or ESXi? is 4.1u1 or some other version?

Where these ESX hosts upgraded previously from 4.0 to 4.1? and same for Nexus 1000v VEM code were they upgraded from previous versions?

thanks

louis

Beginner

Louis,

By most recent version of 1.4a, do you mean the VSM version, if so it is 4.2.1.SV1.4a.  I upgraded them before trying the ESXi upgrade.

I am upgrading from ESXi 4.1.  The build number is 4.1.0, 433742

The Nexus 1000V was installed when the ESXi servers were at version 4.1

Here is the show version and show module from the VSM:

n0-ntpm-n1kv# sh version

Cisco Nexus Operating System (NX-OS) Software

TAC support: http://www.cisco.com/tac

Copyright (c) 2002-2011, Cisco Systems, Inc. All rights reserved.

The copyrights to certain works contained herein are owned by

other third parties and are used and distributed under license.

Some parts of this software are covered under the GNU Public

License. A copy of the license is available at

http://www.gnu.org/licenses/gpl.html.

Software

  loader:    version unavailable [last: loader version not available]

  kickstart: version 4.2(1)SV1(4a)

  system:    version 4.2(1)SV1(4a)

  kickstart image file is: bootflash:/nexus-1000v-kickstart-mz.4.2.1.SV1.4a.bin

  kickstart compile time:  7/27/2011 3:00:00 [07/27/2011 10:57:37]

  system image file is:    bootflash:/nexus-1000v-mz.4.2.1.SV1.4a.bin

  system compile time:     7/27/2011 3:00:00 [07/27/2011 15:29:14]

Hardware

  cisco Nexus 1000V Chassis ("Virtual Supervisor Module")

  Intel(R) Xeon(R) CPU         with 2075740 kB of memory.

  Processor Board ID T5056BA1231

  Device name: n0-ntpm-n1kv

  bootflash:    2332296 kB

Kernel uptime is 5 day(s), 0 hour(s), 58 minute(s), 32 second(s)

plugin

  Core Plugin, Ethernet Plugin, Virtualization Plugin

n0-ntpm-n1kv# sh module

Mod  Ports  Module-Type                       Model               Status

---  -----  --------------------------------  ------------------  ------------

1    0      Virtual Supervisor Module         Nexus1000V          active *

2    0      Virtual Supervisor Module         Nexus1000V          ha-standby

Mod  Sw                Hw

---  ----------------  ------------------------------------------------

1    4.2(1)SV1(4a)     0.0

2    4.2(1)SV1(4a)     0.0

Mod  MAC-Address(es)                         Serial-Num

---  --------------------------------------  ----------

1    00-19-07-6c-5a-a8 to 00-19-07-6c-62-a8  NA

2    00-19-07-6c-5a-a8 to 00-19-07-6c-62-a8  NA

Mod  Server-IP        Server-UUID                           Server-Name

---  ---------------  ------------------------------------  --------------------

1    130.42.0.55      NA                                    NA

2    130.42.0.55      NA                                    NA

* this terminal session

n0-ntpm-n1kv#

Cisco Employee

Robert,

There was a newer version of 1.4a released on 8/24. The only thing that changed in this version is that it included VEM modules for ESXi5. Assuming you added VEM500-201108271 to your image you have the the right version.

I'd open a TAC case. I would be the easiest way to solve the problem at this point.

louis

Cisco Employee

Robert,

Checking in to see if this got resolved ?

louis

Beginner

Louis,

Not yet, but I do have access to the TAC and Cisco Advanced services, if I need to engage their help.  This just kind of got out prioritized by other issues.

Thanks for checking in.

Bob

Beginner

I get the exact same error message about an incompatible package following this procedure. Did you ever get a resolution for this?

Beginner

Simon,

No I have not reached any resolution.  I was thinking about working on this later this week.  If I get this figured out I will post what I found.

Beginner

I got it working in the end by rebooting each host and then doing another VUM scan. That made the error about the incompatible vem disappear.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards
This widget could not be displayed.