cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8216
Views
0
Helpful
15
Replies
Highlighted
Beginner

Certification of ESXi 5.1 with Nexus 1000V

I have a customer who is asking about moving to ESXi 5.1 on their Nexus 1000V platform. They want to know if this version is certified with the 1000V yet.

Thanks,

Peter

15 REPLIES 15
Highlighted
Enthusiast

Yes, you can use Nexus 1000V version 1.5.2. with vSphere 5.1

Highlighted

Please point me to something on Cisco.com<http://Cisco.com> that has we support ESXi 5.1 with 1000V and any caveats.

Highlighted

You can download it from cisco.com at Downloads Home->Products->Switches->Data Center Switches->Cisco Nexus 1000V Series Switches->Cisco Nexus 1000V Switch or simply type nexus in the search window on the download page. 

Release notes has the open caveats. Please check http://www.cisco.com/en/US/products/ps9902/prod_release_notes_list.html

Highlighted

Thanks. I guess I'll have to wait until the VMware and Cisco Nexus 1000V Software Compatibility Table in the Release Notes is undated...

Highlighted

Save wasting your time!

I have Nexus 5.2 installed and have found the host will not upgrade to ESXi5.1 due to incompatible VIB's.

Hope this gets fixed soon, I dont fancy creating a custom ESXi installer.

Thanks,

Matt

Highlighted

Thanks… I think!!!

Highlighted
Beginner

It can be done, but not the easy way with Update Manager.

The downloaded patch from Cisco (updated VEM) will not install on VMWare prior to 5.1, so you have to do a fresh install of the server and then apply the Cisco patch..

The Host will be "out of sync" in the Nexus VMware config, so you have to remove it from the distributed switct and then add it to the distributed switch again...

After that you'll have a 5.1 host with nexus running fine.

Hopefully there will be a 5.1 custom ISO made that have the latest Cisco VEM incorporated... It would me much easier just upgrading all host via Update Manager :-)

Highlighted

This does not work!

Have tried a few methods, all with the same result as per below:-

tmp # esxcli software vib install -v /tmp/cross_cisco-vem-v144-4.2.1.1.5.2.0-3.

0.1.vib

[DependencyError]

VIB Cisco_bootbank_cisco-vem-v144-esx_4.2.1.1.5.2.0-3.0.1 requires esx-base << 5.1.0, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

I also get the same error trying the update the ESXi5.1 Image with the NExus 5.2 VIB using PowerCLI

Basically, Nexus 5.2 appears to have dependency on ESXi5.0

Please can Cisco verify this?

Thanks,

Matt

Highlighted

Hold tight we are working on it. It looks the VIB is missing from the bundle.

Hopefully it will be fixed shortly.

louis

Highlighted

OK after a little digging the VEM is in the bundle from Cisco.

If you download the 1.5.2 bundle from cisco.com (even if you have it from a previous download, redownload the bundle) in the VEM directory there is a file cross_cisco-vem-v144-4.2.1.1.5.2.0-3.1.2.vib.This is the vib you need to use for ESXi5.1

When 1.5.2 came out we had hooks for it to work with ESXi5.1 but we were not allowed to provide the 5.1 VEM module in the bundle until VMware officially shipped ESXi 5.1. So you need to redownload the bundle and pull the VEM module out of the zip file.

Highlighted

Ahh, OK

Thats great, I'll download and get this working hopefully.

Cheers,

Matt

Highlighted

Ok so there is no way to go from 5.0 with 5.2 1000v to 5.1 ? I have to remove the 1000v VEM first and then upgrade to 5.1 and reinstall VEM ? This seems backwards, is that the only way ?

EDIT:

After much searching around I found at http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_2_1_s_v_1_5_2/install_upgrade/vsm_vem/guide/b_Installation_and_Upgrade_Release_4_2_1SV1_5_2_appendix_0100.html#task_177902672B004D0F93380CF04AF2ED45

thatin 4.2.1SV1.5.2 there supposed to be a 3.0.2 VIB, but there isnt. There is only 3.0.1 VIB.

What exactly are we supposed to do ?

Highlighted

Just want to check if there is still an issue with an upgrade from vsphere 5.0 with 1000v 5.2 to vpshere 5.1

Do I still need to remove the VEM , upgrade to 5.1, and reinstall the VEM? Thanks.

Franco

Highlighted

If you are upgrading to 5.1 you will need to install a VEM module that is compatibile with 5.1. The VEM module for 5.0 is not compatibile with 5.1.

You can either build the upgrade image with the 5.1 VEM in it or you can uninstall the host from the n1kv, upgrade to 5.1, and then reinstall the host to the n1kv.

It's not hard to build an upgrade image and add the 5.1 VEM module.

louis

Content for Community-Ad
This widget could not be displayed.