cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

3421
Views
1
Helpful
2
Replies
Highlighted
Beginner

moving VSM onto VEM distributed switch

Hi all,

I have a working nexus setup on two ESX hosts, with a VSM running on each host connected to a standard vSwitch.   VEM is installed and working and its all good.

Mod  Ports  Module-Type                      Model              Status
---  -----  -------------------------------- ------------------ ------------
1    0      Virtual Supervisor Module        Nexus1000V         ha-standby
2    0      Virtual Supervisor Module        Nexus1000V         active *
3    248    Virtual Ethernet Module          NA                 ok
4    248    Virtual Ethernet Module          NA                 ok

We are now trying to move the two VSM's off the vSwitch and onto the distributed switch, but I must be doing something wrong!  The VSM is setup with the following VLANs:

334 - Packet

335 - Control

990 - Management

When we move both hosts onto the distributed switch, one of the VSM's drops its connection to all the VEM's, and the 2nd one goes into a constant reboot cycle.

The configuration on the VSM is as follows:

ip host edpswvsmdmz001 10.193.26.250
vlan 334
  name Packet
vlan 335
  name Control
vlan 990
  name Management

port-profile system-uplink
  capability uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 334-335,990
  channel-group auto mode on
  no shutdown

  system vlan 334-335,990
  state enabled

port-profile trunk-uplink
  capability uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan all
  channel-group auto mode on
  no shutdown
  state enabled

port-profile nexus-packet-v334
  vmware port-group
  switchport mode access
  switchport access vlan 334
  no shutdown
  state enabled
port-profile nexus-control-v335
  vmware port-group
  switchport mode access
  switchport access vlan 335
  no shutdown
  state enabled
port-profile nexus-management-v990
  vmware port-group
  switchport mode access
  switchport access vlan 990
  no shutdown
  state enabled

interface Ethernet3/2
  inherit port-profile system-uplink
interface Ethernet3/4
  inherit port-profile trunk-uplink

interface Ethernet4/2
  inherit port-profile system-uplink
interface Ethernet4/3
  inherit port-profile trunk-uplink

Now these are uplinked into a 3750.. the config on that is as follows:

interface Port-channel1
description vmh001-uplink
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
logging event trunk-status
logging event status
spanning-tree link-type point-to-point
end
!

interface Port-channel2
description vmh002-uplink
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
logging event trunk-status
logging event status
spanning-tree link-type point-to-point
end
!

interface Port-channel11
description vmh001-system
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 334,335,990
switchport mode trunk
switchport nonegotiate
logging event trunk-status
logging event status
spanning-tree link-type point-to-point
end

!
interface Port-channel12
description vmh002-system
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 334,335,990
switchport mode trunk
switchport nonegotiate
logging event trunk-status
logging event status
spanning-tree link-type point-to-point

Can anyone tell me what I am doing wrong here?

Cheers,

  Mark

Everyone's tags (2)
2 REPLIES 2
Cisco Employee

Re: moving VSM onto VEM distributed switch

Are you moving one VSM at a time?

Move the standby VSM first, ensure they re-sync with "show sys red sta"

Then move the other one over.

Also, you did the right thing with making your control/packet/management vlans as "system" vlans on your System-Uplink, but you need to also configure system vlans on the Port Profiles you're assigning to your VSM interfaces.  Missing config shown in RED

port-profile nexus-packet-v334
  vmware port-group
  switchport mode access
  switchport access vlan 334

  system vlan 334
  no shutdown
  state enabled
port-profile nexus-control-v335
  vmware port-group
  switchport mode access
  switchport access vlan 335

  system vlan 335
  no shutdown
  state enabled
port-profile nexus-management-v990
  vmware port-group
  switchport mode access
  switchport access vlan 990

  system vlan 990
  no shutdown
  state enabled

Robert

Beginner

Re: moving VSM onto VEM distributed switch

Hi Robert... adding in those three lines fixed the problem.

I knew it would be something simple!

Thankyou so much for your assistance.  

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards