cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
157
Views
5
Helpful
2
Replies

Nexus 9K Netflow Config on vPortchannel

UKW-NK-Cisco
Beginner
Beginner

Hi, 

i have tried to configure Netflow on a Nexus 9504 Switch, if i try to configure "ip flow monitor IPv4_NETFLOW input" on a vPortchannel i get the Message "ERROR: Monitor IPv4_NETFLOW can't be shared under both L3 interface and L2 interface"

 

Configuration:

feature netflow
!
flow exporter NETFLOW_TO_SW_FC
description Export NetFlow to Stealthwatch
destination 10.10.10.10
transport udp 2055
source loopback0
version 9
template data timeout 30
flow record SW_FLOW_RECORD
description NetFlow to Stealthwatch
match ipv4 source address
match ipv4 destination address
match ip protocol
match ip tos
match transport source-port
match transport destination-port
collect transport tcp flags
collect counter bytes long
collect counter packets long
collect timestamp sys-uptime first
collect timestamp sys-uptime last
flow monitor IPv4_NETFLOW
record SW_FLOW_RECORD
exporter NETFLOW_TO_SW_FC
!
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 2,3,4,5
vpc 10
!
interface Ethernet1/32
switchport
switchport mode trunk
switchport trunk allowed vlan 2,3,4,5
channel-group 10 mode active
no shutdown


>> conf t
(config)#int po10
(config-if)#ip flow monitor IPv4_NETFLOW input
ERROR: Monitor IPv4_NETFLOW can't be shared under both L3 interface and L2 interface

what other options do I have to configure Netflow here?

Kind regards,

1 Accepted Solution

Accepted Solutions

Sergiu.Daniluk
VIP Advisor VIP Advisor
VIP Advisor

I believe the error its indicating that you have the same netflow monitor "IPv4_NETFLOW" configured already on a L3 Interface, and you cannot configure it on a L2 interface at the same time.

Solution should be either remove the netflow from the L3 interface and cfg on L2 PO, or simply configure another flow monitor for the L2 interfaces.

 

Cheers,

Sergiu

View solution in original post

2 Replies 2

Sergiu.Daniluk
VIP Advisor VIP Advisor
VIP Advisor

I believe the error its indicating that you have the same netflow monitor "IPv4_NETFLOW" configured already on a L3 Interface, and you cannot configure it on a L2 interface at the same time.

Solution should be either remove the netflow from the L3 interface and cfg on L2 PO, or simply configure another flow monitor for the L2 interfaces.

 

Cheers,

Sergiu

Hi Sergio,

Thanks for your suggestion

I have created another monitor with the same config. Now it runs as intended.

So you have to remember in the future with Nexus, one monitor for L2 and another for L3 interfaces. My mistake was that this is handled a little differently on the Catalyst 9000 series.

 

Best regards,

Max

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers