01-04-2022 09:41 AM
In CML2.2.2, I have one csr1000v interface connected to one iosvl2 interface.
On the router side, I've configured subinterfaces, and on the switch side, I've configured a trunk interface plus corresponding SVIs. No ping. My question: Is there a known issue with subinterfaces on the csr1000v?
TIA.
Solved! Go to Solution.
01-04-2022 10:20 AM
Hi @gmcdwllntwrk ,
This is due to the way the CSR1000v handles subinterfaces.
Please refer to the following post for more information on how to solve the issue.
https://community.cisco.com/t5/ipv6/ipv6-address-on-subinterfaces/td-p/4504574
Regards,
01-05-2022 05:13 AM
Thanks So Much Harold,
Trying to get that port-channel working, I was questioning my insanity for a while there.
I wanted to model a connection to a trunk interface on the far side, so I did it like this, and it works.
Note: It may be a bit unusual to have a routing native vlan on the switch, but To everything, There is a season, and for every config, there is a reason...
RTR1 (CSR1000V) | SW (IOSvL2) |
! In lieu of a port-channel i/f | ! On this side a trunk w/ native VL 10 |
bridge-domain 10 | vlan 10 |
bridge-domain 11 | vlan 11 |
bridge-domain 12 | vlan 12 |
interface GigabitEthernet1 | interface GigabitEthernet0/0 |
no shut | switchport trunk allowed vlan 10-12 |
service instance 10 ethernet | switchport trunk encapsulation dot1q |
encapsulation untagged | switchport trunk native vlan 10 |
bridge-domain 10 | switchport mode trunk |
! | negotiation auto |
service instance 11 ethernet | no shut |
encapsulation dot1q 11 | ! |
bridge-domain 11 | interface Vlan10 |
! | ip address 10.10.10.2 255.255.255.0 |
service instance 12 ethernet | no shut |
encapsulation dot1q 12 | ! |
bridge-domain 12 | interface Vlan11 |
! | ip address 11.11.11.2 255.255.255.0 |
! | no shut |
interface BDI10 | ! |
ip address 10.10.10.1 255.255.255.0 | interface Vlan12 |
no shut | ip address 12.12.12.2 255.255.255.0 |
! | no shut |
interface BDI11 | ! |
ip address 11.11.11.1 255.255.255.0 | |
encapsulation dot1Q 11 | |
no shut | |
! | |
interface BDI12 | |
ip address 12.12.12.1 255.255.255.0 | |
encapsulation dot1Q 12 | |
no shut | |
! |
01-04-2022 10:20 AM
Hi @gmcdwllntwrk ,
This is due to the way the CSR1000v handles subinterfaces.
Please refer to the following post for more information on how to solve the issue.
https://community.cisco.com/t5/ipv6/ipv6-address-on-subinterfaces/td-p/4504574
Regards,
01-05-2022 05:13 AM
Thanks So Much Harold,
Trying to get that port-channel working, I was questioning my insanity for a while there.
I wanted to model a connection to a trunk interface on the far side, so I did it like this, and it works.
Note: It may be a bit unusual to have a routing native vlan on the switch, but To everything, There is a season, and for every config, there is a reason...
RTR1 (CSR1000V) | SW (IOSvL2) |
! In lieu of a port-channel i/f | ! On this side a trunk w/ native VL 10 |
bridge-domain 10 | vlan 10 |
bridge-domain 11 | vlan 11 |
bridge-domain 12 | vlan 12 |
interface GigabitEthernet1 | interface GigabitEthernet0/0 |
no shut | switchport trunk allowed vlan 10-12 |
service instance 10 ethernet | switchport trunk encapsulation dot1q |
encapsulation untagged | switchport trunk native vlan 10 |
bridge-domain 10 | switchport mode trunk |
! | negotiation auto |
service instance 11 ethernet | no shut |
encapsulation dot1q 11 | ! |
bridge-domain 11 | interface Vlan10 |
! | ip address 10.10.10.2 255.255.255.0 |
service instance 12 ethernet | no shut |
encapsulation dot1q 12 | ! |
bridge-domain 12 | interface Vlan11 |
! | ip address 11.11.11.2 255.255.255.0 |
! | no shut |
interface BDI10 | ! |
ip address 10.10.10.1 255.255.255.0 | interface Vlan12 |
no shut | ip address 12.12.12.2 255.255.255.0 |
! | no shut |
interface BDI11 | ! |
ip address 11.11.11.1 255.255.255.0 | |
encapsulation dot1Q 11 | |
no shut | |
! | |
interface BDI12 | |
ip address 12.12.12.1 255.255.255.0 | |
encapsulation dot1Q 12 | |
no shut | |
! |
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide