cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
287
Visitas
1
ÚTIL
3
Respuestas

HSRP

Gordon Freeman1
Level 1
Level 1

Hola, espero puedan ayudarme con este ejercicio. He configurado HSRP en 2 switches capa 3 para amabs vlans, pero ambas tiene el estado de activo en ambos switches. Adjunto mi configuracion de interfaces y HSRP Menciono que ambos swtiches tienen un channel group con ip.

MLS1 =================================================================

vlan 10,20
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 100.1.1.1 255.255.255.255
!
interface Port-channel1
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel3
no switchport
ip address 10.0.6.1 255.255.255.252
!
interface Ethernet0/0
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/1
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/2
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/3
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 1 mode passive
!
interface Ethernet1/0
no switchport
ip address 10.0.1.2 255.255.255.252
ip ospf authentication key-chain LLAVE1
ip ospf network point-to-point
ip ospf dead-interval 20
ip ospf hello-interval 5
ip ospf cost 20
duplex full
!
interface Ethernet1/1
no switchport
ip address 10.0.5.2 255.255.255.252
ip ospf authentication key-chain LLAVE1
ip ospf network point-to-point
ip ospf dead-interval 20
ip ospf hello-interval 5
ip ospf cost 5
!
interface Ethernet1/2
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 1 mode passive
!
interface Ethernet1/3
!
interface Vlan10
ip address 172.16.10.2 255.255.255.0
ip helper-address 10.0.1.1
standby 10 ip 172.16.10.1
standby 10 timers msec 200 msec 800
standby 10 priority 150
standby 10 preempt
!
interface Vlan20
ip address 172.16.20.2 255.255.255.0
ip helper-address 10.0.1.1
standby 20 ip 172.16.20.1
standby 20 timers msec 200 msec 800
standby 20 priority 80
!
!
router eigrp ENARSI
!
address-family ipv4 unicast autonomous-system 100
!
af-interface default
passive-interface
exit-af-interface
!
topology base
redistribute ospf 1 route-map ospf-to-eigrp

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


MLS1 con0 is now available

 

 

Press RETURN to get started.


MLS1>EN
MLS1#sh
MLS1#show runn
MLS1#show running-config
Building configuration...

Current configuration : 3729 bytes
!
! Last configuration change at 20:31:18 CET Sat Dec 9 2023
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname MLS1
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone CET 1 0
!
!
!
!
!
vtp mode transparent
!
!
!
ip cef
no ipv6 cef
!
key chain LLAVE1
key 1
key-string enarsi123
cryptographic-algorithm hmac-sha-256
!
!
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ENARSI
revision 1
instance 2 vlan 10
instance 3 vlan 20
!
spanning-tree mst forward-time 16
spanning-tree mst max-age 10
spanning-tree mst 2 priority 28672
spanning-tree mst 3 priority 24576
!
!
vlan 10,20
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 100.1.1.1 255.255.255.255
!
interface Port-channel1
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel3
no switchport
ip address 10.0.6.1 255.255.255.252
!
interface Ethernet0/0
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/1
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/2
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode desirable
!
interface Ethernet0/3
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 1 mode passive
!
interface Ethernet1/0
no switchport
ip address 10.0.1.2 255.255.255.252
ip ospf authentication key-chain LLAVE1
ip ospf network point-to-point
ip ospf dead-interval 20
ip ospf hello-interval 5
ip ospf cost 20
duplex full
!
interface Ethernet1/1
no switchport
ip address 10.0.5.2 255.255.255.252
ip ospf authentication key-chain LLAVE1
ip ospf network point-to-point
ip ospf dead-interval 20
ip ospf hello-interval 5
ip ospf cost 5
!
interface Ethernet1/2
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 1 mode passive
!
interface Ethernet1/3
!
interface Vlan10
ip address 172.16.10.2 255.255.255.0
ip helper-address 10.0.1.1
standby 10 ip 172.16.10.1
standby 10 timers msec 200 msec 800
standby 10 priority 150
standby 10 preempt
!
interface Vlan20
ip address 172.16.20.2 255.255.255.0
ip helper-address 10.0.1.1
standby 20 ip 172.16.20.1
standby 20 timers msec 200 msec 800
standby 20 priority 80

MLS2

vlan 10,20
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 100.2.2.2 255.255.255.255
!
interface Port-channel2
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel3
no switchport
ip address 10.0.6.2 255.255.255.252
!
interface Ethernet0/0
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode auto
!
interface Ethernet0/1
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode auto
!
interface Ethernet0/2
no switchport
no ip address
channel-protocol pagp
channel-group 3 mode auto
!
interface Ethernet0/3
no switchport
no ip address
!
interface Ethernet1/0
no switchport
ip address 10.0.2.2 255.255.255.252
ip ospf authentication key-chain LLAVE1
ip ospf network point-to-point
ip ospf dead-interval 20
ip ospf hello-interval 5
ip ospf cost 20
!
interface Ethernet1/1
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 2 mode active
!
interface Ethernet1/2
!
interface Ethernet1/3
switchport trunk allowed vlan 10,20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 2 mode active
!
interface Vlan10
ip address 172.16.10.3 255.255.255.0
ip helper-address 10.0.2.1
standby 10 ip 172.16.10.1
standby 10 timers msec 200 msec 800
standby 10 priority 80
!
interface Vlan20
ip address 172.16.20.3 255.255.255.0
ip helper-address 10.0.2.1
standby 20 ip 172.16.20.1
standby 20 timers msec 200 msec 800
standby 20 priority 150
standby 20 preempt

 

"GRACIAS DE ANTEMANO"

 

3 RESPUESTAS 3

M02@rt37
VIP
VIP

Hello @Gordon Freeman1 

En la interfaz Vlan10 en MLS1, la prioridad HSRP está configurada como 150. Asegúrate de que sea menor que la prioridad configurada en MLS2 para la misma VLAN (Vlan10). Cambia la prioridad a un valor menor, por ejemplo, 120:

interface Vlan10
standby 10 priority 120

En la interfaz Vlan10 en MLS2, la prioridad HSRP está configurada como 80. Asegúrate de que sea mayor que la prioridad configurada en MLS1 para la misma VLAN (Vlan10). Cambia la prioridad a un valor mayor, por ejemplo, 110:

interface Vlan10
standby 10 priority 110

En la interfaz Vlan20 en MLS2, la prioridad HSRP está configurada como 150. Asegúrate de que sea menor que la prioridad configurada en MLS1 para la misma VLAN (Vlan20). Cambia la prioridad a un valor menor, por ejemplo, 90:

interface Vlan20
standby 20 priority 90

Después de realizar estos cambios, espera unos momentos y verifica el estado de HSRP en ambos switches para ambas VLANs. Los switches deberían sincronizarse y uno de ellos debería ser el activo mientras que el otro es el en espera para cada VLAN.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

He probado la configuracion y siguen saliendo ambas vlans en ambos switch como activas, compartiré mi confirmación de MST en caso de que ese sea el problema. Debo destacar que el objetivo es que MLS1 tenga vlan 10 como activa y vlan 20 como standby, MLS2 vlan 10 como stanby y vlan 20 como activa.

MLS1==========================================

spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ENARSI
revision 1
instance 2 vlan 10
instance 3 vlan 20
!
spanning-tree mst forward-time 16
spanning-tree mst max-age 10
spanning-tree mst 2 priority 28672
spanning-tree mst 3 priority 24576

 

MLS2===================================

spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ENARSI
revision 2
instance 2 vlan 10
instance 3 vlan 20
!
spanning-tree mst forward-time 16
spanning-tree mst max-age 10
spanning-tree mst 2 priority 24576
spanning-tree mst 3 priority 28672

balaji.bandi
Hall of Fame
Hall of Fame

i want to point to couple of things.

1. One of the switch running MST - so make sure you have running spanning tree correctly, since this very important when layer 2 between switches.

2. Alaways use different priroty value - so Right device can act as HSRP active (in your case both use same value, so lower the priority the one you looking to be standby  - (default is 100).

3. Use always HSRP v2 for better outcome and many bugs fixed - by issue command on the interface both the side. (standby version 2)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help