cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
760
Views
0
Helpful
4
Replies

Citrix Connectivity Issue after upgrading to 2.3

gputhota
Cisco Employee
Cisco Employee

Hi,

We upgrade our CPO lab environment  from 2.2 to 2.3 and installed the Hotfixes 2 and 3.

The CPO console can be accessed directly on the server through the fat client, but not through a citrix connection.

While launching the console through Citrix, we are seeing two different errors at different times :

1) Cannot access the file ADAPTERS\Tidal.Automation.Sap.Custom.dll, because its being used by another process.

2) Tidal.Automation.Console.exe - .NET Framework Initilization Error : " To run this application, you must first install one of the following versions of the .NET Framework : v4.0.30319"

Error 1 is seen first and after repeated attempts to launch the console through Citrix, Error 1 goes away and we see Error 2. .NET Framework : v4.0.30319 is installed on the CPO server and on the machine from which we are trying to launch the CPO applicaiton through Citrix.

Does the .NET Framework v4 needs to be updated on the Citrix server as well?

Thanks,
Greg

2 Accepted Solutions

Accepted Solutions

Shaun Roberts
Cisco Employee
Cisco Employee

For

1) do you use SAP content or ABAP connections? You need to make sure you upgrade to the NCO 3.0.6 or later for use with 2.3. This is in the abap guide.

As far as citrix goes, I do not know. As far as I'm aware QA/support/dev do not test against citrix setups. I will throw this developments way as well, but probably need to raise a case for it.

-shaun

--Shaun Roberts
Principal Engineer, CX
shaurobe@cisco.com

View solution in original post

Von Jones
Level 4
Level 4

Certainly .net v4 needs to be installed on the machine hosting the expert interface, which in this case would be the Citrix server.

I'd start with that and see if the issue doesn't go away.

View solution in original post

4 Replies 4

Shaun Roberts
Cisco Employee
Cisco Employee

For

1) do you use SAP content or ABAP connections? You need to make sure you upgrade to the NCO 3.0.6 or later for use with 2.3. This is in the abap guide.

As far as citrix goes, I do not know. As far as I'm aware QA/support/dev do not test against citrix setups. I will throw this developments way as well, but probably need to raise a case for it.

-shaun

--Shaun Roberts
Principal Engineer, CX
shaurobe@cisco.com

Thank you Shaun.

No. We are not using any SAP content. We havent imported any of the SAP TAPs other than the core content.

Greg

Von Jones
Level 4
Level 4

Certainly .net v4 needs to be installed on the machine hosting the expert interface, which in this case would be the Citrix server.

I'd start with that and see if the issue doesn't go away.

Thank you Von.

Citrix Team has updated the .NET Framework on the Citrix server and it turned out there are few more issues with the configuration on the Citrix server. But the original error is no longer seen.

Greg