cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
305
Views
0
Helpful
4
Replies
Highlighted

all out calls go to busy when i set service aa

hi my guys i have a big problem

when i set service aa on dial-peer voice 1 pots my all outside calls go to busy and when i use no service on dial-peer it works correctly

my router config is:

Current configuration : 11867 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Ru201.Padideh.net

!

boot-start-marker

boot system flash c2800nm-adventerprisek9_ivs-mz.124-24.T.bin

boot-end-marker

!

card type e1 0 1

logging message-counter syslog

enable secret 5 $1$2KQv$jnhcn/4qud040i60EknaF.

!

no aaa new-model

clock timezone ir 3 30

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

network-clock-select 2 E1 0/1/1

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

no ip domain lookup

ip domain name Ru05.Padideh.net

no ipv6 cef

ntp server 10.17.104.1

ntp server 129.6.13.35

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

!

!

voice-card 0

!

!

application

service aa flash:app-b-acd-aa-2.1.2.2.tcl

paramspace english index 1

param number-of-hunt-grps 2

param menu-timeout 6

param handoff-string aa

param dial-by-extension-option 5

paramspace english language en

param max-time-vm-retry 2

param max-extension-length 4

param aa-pilot 1054

paramspace english location flash:

param second-greeting-time 60

param welcome-prompt _bacd_welcome.au

param call-retry-timer 1

param max-time-call-retry 1

param service-name queue

!

service queue flash:app-b-acd-2.1.2.2.tcl

param queue-len 30

param aa-hunt1 1200

param queue-manager-debugs 1

param aa-hunt2 2100

param number-of-hunt-grps 2

!

!

!

!

!

!

username ARM password 7 155A08051729246D

username MKZ password 7 041159555F701E1D59484F

archive

log config

hidekeys

!

!

!

!

!

controller E1 0/1/0

pri-group timeslots 1-31

!

controller E1 0/1/1

pri-group timeslots 1-31

!

!

class-map match-any Wifi-Guest

match any

!

!

policy-map Wifi-Guest

class Wifi-Guest

police 256000

!

!

!

!

!

interface Loopback38888

ip address 10.16.254.1 255.255.255.0

!

interface Tunnel201

ip address 10.17.255.18 255.255.255.252

!

interface GigabitEthernet0/0.240

encapsulation dot1Q 240

ip address 10.16.97.1 255.255.255.0

ip helper-address 10.17.104.11

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.250

encapsulation dot1Q 250

ip address 10.16.99.1 255.255.255.0

ip access-group Wifi-Guest in

ip helper-address 10.17.104.11

ip nat inside

ip virtual-reassembly

service-policy output Wifi-Guest

!

interface GigabitEthernet0/0.260

encapsulation dot1Q 260

ip address 10.16.100.1 255.255.255.0

ip helper-address 10.17.104.11

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.270

encapsulation dot1Q 270

ip address 10.16.101.1 255.255.255.0

ip helper-address 10.17.104.11

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

router eigrp 200

network 10.16.97.0 0.0.0.255

network 10.16.99.0 0.0.0.255

network 10.16.100.0 0.0.0.255

network 10.16.101.0 0.0.0.255

network 10.17.100.0 0.0.0.127

network 10.17.104.0 0.0.0.255

network 10.17.255.16 0.0.0.3

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 80.191.241.129

ip route 10.11.12.0 255.255.255.0 GigabitEthernet0/0.144

ip http server

no ip http secure-server

ip http path usbflash0:/GUI

!

!

ip nat inside source list 1 interface GigabitEthernet0/0.135 overload

ip nat inside source static tcp 10.17.104.5 3389 80.191.241.132 3389 extendable

!

ip access-list extended Wifi-Guest

permit tcp 10.16.99.0 0.0.0.255 host 10.17.104.11 eq domain

permit udp 10.16.99.0 0.0.0.255 host 10.17.104.11 eq domain

deny ip 10.16.99.0 0.0.0.255 10.0.0.0 0.255.255.255

permit ip any any

!

access-list 1 permit 10.16.99.0 0.0.0.255

access-list 1 permit 10.16.97.0 0.0.0.255

access-list 1 permit 10.17.104.0 0.0.0.255

!

!

!

!

route-map clients permit 10

match ip address 110

set ip next-hop 10.17.104.17

!

route-map clients permit 20

!

tftp-server usbflash0:/7906-7911/cvm11sccp.8-3-2-27.sbn alias cvm11sccp.8-3-2-27.sbn

tftp-server usbflash0:/7906-7911/jar11sccp.8-3-2-27.sbn alias jar11sccp.8-3-2-27.sbn

tftp-server usbflash0:/7906-7911/SCCP11.8-3-3S.loads alias SCCP11.8-3-3S.loads

tftp-server usbflash0:/7906-7911/term06.default.loads alias term06.default.loads

tftp-server usbflash0:/7931/apps31.8-3-2-27.sbn alias apps31.8-3-2-27.sbn

tftp-server usbflash0:/7931/cnu31.8-3-2-27.sbn alias cnu31.8-3-2-27.sbn

tftp-server usbflash0:/7931/cvm31sccp.8-3-2-27.sbn alias cvm31sccp.8-3-2-27.sbn

tftp-server usbflash0:/7931/dsp31.8-3-2-27.sbn alias dsp31.8-3-2-27.sbn

tftp-server usbflash0:/7931/jar31sccp.8-3-2-27.sbn alias jar31sccp.8-3-2-27.sbn

tftp-server usbflash0:/7931/SCCP31.8-3-3S.loads alias SCCP31.8-3-3S.loads

tftp-server usbflash0:/7931/term31.default.loads alias term31.default.loads

tftp-server flash:/apps75.8-3-2-27.sbn alias apps75.8-3-2-27.sbn

tftp-server flash:/cnu75.8-3-2-27.sbn alias cnu75.8-3-2-27.sbn

tftp-server flash:/cvm75sccp.8-3-2-27.sbn alias cvm75sccp.8-3-2-27.sbn

tftp-server flash:/dsp75.8-3-2-27.sbn alias dsp75.8-3-2-27.sbn

tftp-server flash:/jar75sccp.8-3-2-27.sbn alias jar75sccp.8-3-2-27.sbn

tftp-server flash:/SCCP75.8-3-3S.loads alias SCCP75.8-3-3S.loads

tftp-server flash:/term75.default.loads alias term75.default.loads

!

control-plane

!

!

!

voice-port 0/1/0:15

!

voice-port 0/1/1:15

!

!

mgcp fax t38 ecm

!

!

!

dial-peer voice 1100 voip

destination-pattern 11..

session protocol sipv2

session target ipv4:10.17.8.1

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 2100 voip

destination-pattern 21..

session protocol sipv2

session target ipv4:10.17.40.1

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 3100 voip

destination-pattern 31..

session protocol sipv2

session target ipv4:10.17.72.7

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 5100 voip

destination-pattern 51..

!

dial-peer voice 91 voip

destination-pattern 91

session protocol sipv2

session target ipv4:10.17.8.1

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 92 voip

destination-pattern 92

session protocol sipv2

session target ipv4:10.17.40.1

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 93 voip

destination-pattern 93

session protocol sipv2

session target ipv4:10.17.72.7

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 95 voip

destination-pattern 95

!

dial-peer voice 8 pots

service aa

incoming called-number 1054

port 0/1/1:15

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 30

max-dn 60

ip source-address 10.16.101.1 port 2000

system message PADIDEH.NET

load 7911 SCCP11.8-3-3S.loads

load 7931 SCCP31.8-3-3S.loads

load 7975 SCCP75.8-3-3S.loads

time-zone 33

time-format 24

date-format yy-mm-dd

max-conferences 8 gain -6

moh en_bacd_music_on_hold.au

multicast moh 239.1.1.1 port 2100

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1

and my debug massage is:

*Dec 16 04:45:20.523: //-1/127ABE148015/CCAPI/cc_api_display_ie_subfields:

cc_api_call_setup_ind_common:

cisco-username=

----- ccCallInfo IE subfields -----

cisco-ani=7662228

cisco-anitype=4

cisco-aniplan=1

cisco-anipi=0

cisco-anisi=3

dest=9763495

cisco-desttype=0

cisco-destplan=1

cisco-rdie=FFFFFFFF

cisco-rdn=

cisco-lastrdn=

cisco-rdntype=-1

cisco-rdnplan=-1

cisco-rdnpi=-1

cisco-rdnsi=-1

cisco-redirectreason=-1 fwd_final_type =0

final_redirectNumber =

hunt_group_timeout =0

*Dec 16 04:45:20.523: //-1/127ABE148015/CCAPI/cc_api_call_setup_ind_common:

Interface=0x4CE0A3B8, Call Info(

Calling Number=7662228,(Calling Name=)(TON=Subscriber, NPI=ISDN, Screening=Network, Presentation=Allowed),

Called Number=9763495(TON=Unknown, NPI=ISDN),

Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,

Incoming Dial-peer=0, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,

Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

*Dec 16 04:45:20.527: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Dec 16 04:45:20.527: :cc_get_feature_vsa malloc success

*Dec 16 04:45:20.527: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Dec 16 04:45:20.527: cc_get_feature_vsa count is 1

*Dec 16 04:45:20.527: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Dec 16 04:45:20.527: :FEATURE_VSA attributes are: feature_name:0,feature_time:1217509232,feature_id:35

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/cc_api_call_setup_ind_common:

Set Up Event Sent;

Call Info(Calling Number=7662228(TON=Subscriber, NPI=ISDN, Screening=Network, Presentation=Allowed),

Called Number=9763495(TON=Unknown, NPI=ISDN))

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/cc_process_call_setup_ind:

Event=0x4AD03A98

*Dec 16 04:45:20.527: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

Try with the demoted called number 9763495

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/ccCallSetContext:

Context=0x4D03C814

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/cc_process_call_setup_ind:

>>>>CCAPI handed cid 79 with tag 0 to app "_ManagedAppProcess_Default"

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/ccCallSetupAck:

Call Id=79

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/cc_api_set_transfer_info:

Transfer Number=, Transfer Reason=0x0

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/ccGenerateToneInfo:

Stop Tone On Digit=TRUE, Tone=Dial Tone,

Tone Direction=Network, Params=0x0, Call Id=79

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/ccSetDigitTimeouts:

Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)

*Dec 16 04:45:20.527: //79/127ABE148015/CCAPI/ccSetDigitTimeouts:

Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))

*Dec 16 04:45:20.531: //79/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:

(callID=0x4F, digit_event=0x1, enable=TRUE, consume=FALSE)

*Dec 16 04:45:20.531: //79/127ABE148015/CCAPI/ccCallReportDigits:

Enabled=TRUE, Call Id=79

*Dec 16 04:45:20.531: //79/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:

(vdbPtr=0x4CE0A3B8, callID=0x4F, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)

*Dec 16 04:45:20.531: //79/127ABE148015/CCAPI/cc_api_call_report_digits_done:

Enabled=TRUE, Disposition=0x0, Interface=0x4CE0A3B8, Call Id=79

*Dec 16 04:45:20.531: //79/127ABE148015/CCAPI/cc_api_call_report_digits_done:

Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=10000(ms))

*Dec 16 04:45:20.579: %ISDN-6-CONNECT: Interface Serial0/1/0:0 is now connected to 7662228 N/A

plz help me

Everyone's tags (7)
4 REPLIES 4
Contributor

all out calls go to busy when i set service aa

I think you're missing the mandatory param voicemail in your aa script config.

You're debug massage doesnt give enough info really

all out calls go to busy when i set service aa

tanx for reply, i debug again my router and i got this massage, can you cheak it? tnx

*Dec 17 02:33:41.343: //156//TCL :/tcl_PutsObjCmd:

proc init_perCallvars

*Dec 17 02:33:41.343:*Dec 17 02:33:41.343: //156//TCL :/tcl_PutsObjCmd:
proc init_perCallvars
*Dec 17 02:33:41.343:

Contributor

all out calls go to busy when i set service aa

You probably want to try something like the following...

application

service aa flash:app-b-acd-aa-2.1.2.2.tcl

param voice-mail 1234

where 1234 is your voicemail pilot

all out calls go to busy when i set service aa

i try do it but it's not correct, tnx for answer

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards