cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
136
Views
0
Helpful
3
Replies
Beginner

caller-id enable no longer working

I've been doing some updates at several remote locations and somehow I broke Caller-id. We used some older 2811's as H.323 gateways as well as routers on a stick, during the process I updated the IOS from 12.4 to 15.1, increased the RAM, PVDM2, and added and additional FXS card and convert them into H.323 gateways only. The only other change was I updated the IP scheme. We use CUCM 11.5, and aside from changing the SRST and Gateway IP there was no other changes. I found out today that Caller-ID hasn't been working since I made the changes. We use a pretty basic config on the FXO ports I've pasted below, and I'm of the opinion that the cause lies in the upgrade for the IOS. I thought it may be an issue with a command that was previously on by default in 12.4 needing defined in 15.1, but I'm uncertain at this point. Everything else works, Caller-ID not so much.

 

 

voice-port 0/3/1
 timing hookflash-out 50
 connection plar xxxx
 description Main Line - xxx-xxx-xxxx
 caller-id enable

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: caller-id enable no longer working

Not sure if this will correct your issue or not, because it looks as if all these commands for Caller ID were put in place before 12.4 except 1. It appears as if you are missing the station name and station number as well as the cptone. 

 

voice-port 1/0/1
cptone northamerica
station name A. sample
station number 4085550111
caller-id enable

 

Here is the link to the command reference guide, maybe you will see something I didn't though. Good luck and post your solution.

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/vcr1/vcr1-cr-book/vcr-c4.html#wp1987466130

 

Jason

3 REPLIES 3
Beginner

Re: caller-id enable no longer working

Not sure if this will correct your issue or not, because it looks as if all these commands for Caller ID were put in place before 12.4 except 1. It appears as if you are missing the station name and station number as well as the cptone. 

 

voice-port 1/0/1
cptone northamerica
station name A. sample
station number 4085550111
caller-id enable

 

Here is the link to the command reference guide, maybe you will see something I didn't though. Good luck and post your solution.

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/vcr1/vcr1-cr-book/vcr-c4.html#wp1987466130

 

Jason

Beginner

Re: caller-id enable no longer working

It's incoming calls from the local TelCo on a FXO card we are not seeing Caller-ID on. I checked CPTONE and it is set to US as default. The Version 15 updates just added 2 new country codes from the notes. Oddly enough I went a head and added cptone US and low and behold we have caller-ID. I'm uncertain as to why it wasn't working as the default, but now works when it's explicitly defined but I'll take the win. Thanks for the assist.
Beginner

Re: caller-id enable no longer working

I agree, doesn't seem like that should be the issue, but I am with you, take them where you can get them. Glad it worked for you without too much extra trouble.

 

Jason

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards