Showing results for 
Search instead for 
Did you mean: 

CallManager 5.1.3 to 6.0 Upgrade Fails

I am currently running CallManager on a two server cluster. I received the the CM5.x to CM6.0 upgrade disks via the SASU contract we have.

I have tried to install the upgrade on the publisher by going to the OS Admin page and Install/Upgrade and choosing the local source(CD/DVD) option but it fails to find any upgrade files.

So I decided to checkout what was on the DVD and found the file:


I then copied it from the disk to a known working ftp/sftp server and tried to use the Install/Upgrade page again on the publisher with the same message.

The error I am receiving is:

Errors encountered.

The directory was located and searched but no valid options or upgrades were available. Note, a machine cannot be downgraded so option and upgrade files for previous releases were ignored.

For grins I tried to do the same on the subscriber just to see if it would even recognize the patch file and I got the same error.

Has anyone else experienced this problem? I haven't had trouble with either of the servers recognizing patch/upgrade files in the past.




Make sure your file you downloaded has an sgn extension. If you have set your folder options on windows OS (on your PC from which you are browsing to Callmanager) to not hide file extensions of known type, then you need to make sure that the sgn extension is there for this file. This used to be a known bug for 5.1 patches that i did a while back. So all you do is make sure that the sgn extension is there, if not select the file, hit F2, add the .sgn to the end of the file.



PS: please remember to rate posts!

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus


The file has the appropriate extension on it. I have the option unchecked in Windows to see the full file extension.





Hello Aaron!

I had a similar problem upping from 5.1.2 to 6X on a 2 server cluster. In my scenario I had two CCM's on 2 different subnets, and after having upped my Publisher, I had no way of upping the Subscriber with the exact same message you're facing. As it turned out the Sub, after the upgrade was not in sync with the Pub and I had to reboot the Pub into the Inactive, old 5.1.2 version, prior to upping my Sub. With both servers in sync, I could finally upgrade the Sub and then reboot both into fianl 6X versions on the Acive side.

I have encountered this on a different site also. However, I have also noticed that from time to time I have to retry the upgrade mechanism so that the .sgn image gets recognized.

So, it is possible that you may have to check database sync betweeen the Pub and the Sub before the two disgruntingly let you upgrade. Try a reboot of the two at night and set up a syslog to check what they're doing. Then attempt another upgrade.


Thanks for the tip. I'll try a reboot of both the servers and try it again. Hopefully it will work.



I have tried restarting both the pub and sub and trying the upgrade again and get the same error message.

I then tried moving back to 5.1.2 and doing the upgrade on pub and sub and got the same error as I was getting in 5.1.3

Anyone else have any suggestions? Not really sure where to go from here.




Aaron, I have the exact same problem. I've worked with TAC for over 6 hours today and still no luck. We cannot get the CM 5.1.3 to recognize the file. I downloaded another file from him and still had no luck. He says the file is recognized on a earlier version of CM in his lab (5.1.1 I think). Have you had any additional success?

No I don't have any progress to report. TAC has been terribly slow to respond to this issue. They escalted the case but I have not heard back from the new engineer as of yet.

I'm working on buiding a new CM from scratch to see if I can go from 5.0.4 to 5.1.3 (restore my backup), and then upgrade to 6.0.1 from there.

Let me know if you find anything out.


When I ordered the upgrade from Cisco, they also sent a bootable CD with the full version of CM 6.01a on it. I installed it in VMWare and it does check to see if a previous version exists. I'm not sure if this will "upgrade" a 5.1.3 install or simply erase the disk and require and data restore. Have you tried this?

They included the Cisco CallManager Business Edition System Installation DVD in the SASU kit. The only problem with that is I will not be able to import my data(phones, users, etc) and I will have get licensing straightened out, etc.


I was sent a DVD (part# 80-8777-02) that contains both CUCM 6.0(1a) and Business Edition 6.0(1a). It asks which version you want when you boot from it. I had already run the 6.0 DMA tool on my 4.1.3 server prior to upgrading to 5.1.3. So, I just did a new install of 6.01a and restored the database from the DMA. I never was able to get 5.1.3 to recognize the 6.01 upgrade file. TAC said 5.1.2 will recognize the file.

Hope this helps.

Guys I had a similar issue, but was able to over come it. My issue was upgrading my Sub to the version of 6.0.1 that my pub was running. It orginally wouldn't see the upgraded file. I did the following to fix my problem..This may help you figure something out or not. However I was running into a bug, but here's what I did:

1. Download the 6.0(1-2000-4) iso

2. Rename the 6.0(1.2000-4) iso to 'ES' name: UCSInstall_UCOS_ES_6.0.1.2000-4.sgn.iso

3. Burn file to DVD as a file (not as iso image) or place it on SFTP server.

4. Begin subscriber install with either 6.0(1) / 6.0(1.1000.37) or 6.0(1a) / 6.0(1.2000.3) media and select option to install ES/SR as part of install. When prompted for SR or ES upgrade information, specify DVD or the SFTP server containing the file UCSInstall_UCOS_ES_6.0.1.2000-4.sgn.iso. The installation will recognize this ES file as valid upgrade and proceed to install subscriber as version 6.0(1.2000.4). Given that the version on the subscriber and publisher match, the subscriber will be able to properly communicate with publisher and the installation will complete.

Nice call on the file rename. Im upgrading a 6.01.2003 to 6.01.2107 and I had to rename the 1.7gig file from gz to this file name (or whatever it was listed in the Readme file that goes with the upgrade file.)

So make a note, you have to change the file name so it matches what is in the file name CM6 to upload the ISO image to the server for upgrade.

Thanks! 5 points for you!

I posted the following on a separate thread under the heading: IP Telephony: Upgrading CUCM from to and did not receive any reply. I am posting it here again, though it is not an upgrade from 5.1.3 to 6.0. Hope someone can help me here. CUCM Upgrade from 6.0.1 to 6.0.1a



IP Telephony: Upgrading CUCM from to

Posted by: mp5766

Nov 1, 2007, 5:31am PST

After upgrading CUCM from to and selecting the option to reboot into the upgraded version of CUCM, when the Server starts up I get the following error message on the console screen and the system hangs.

FS: Cannot open root device “LABEL=/partB” or 00:00

Please append a correct “boot=” boot option

Kernel panic: VFS: Unable to mount root FS on 00:00

I have to use the recovery disk to switch the boot partitions to get the system up and running again with the old version

I know it is an OS problem (kernel panic), but there are not any cisco documents available, which will help in trouble shooting.

Any idea how to fix this and get the system to boot from the upgraded version?

Thanks in advance for your help.



I would remove that inactive partition and start over with the upgrade.

Recognize Your Peers
Content for Community-Ad