11-11-2014 10:53 AM - edited 03-17-2019 12:53 AM
Hi,
I've got strange issue and I ran out of ideas what could be wrong.
I have UC520 connected to ISP provider - SIP trunk. And there are some IP phones (CIPC and SPAs) on LAN side.
I created two dial peers:
- 100 for incoming calls: incoming called-number .
- 110 for outgoing calls: destination-pattern 0.T
There are no problems with incoming calls - everything works perfect.
But the problem is when I try to make outgoing call nothing happenes:
debug voip dialpeer inout
7365: Nov 11 18:29:46.187: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
007366: Nov 11 18:29:46.187: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=030331859, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
007367: Nov 11 18:29:46.187: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=110
Debug ccsip messages doesn't show any packet send from UC500 to ISP's SBC. Nothing.
Everything ends here.
How to troubleshoot this further?
11-11-2014 12:51 PM
It could be several things, can you please upload your configuration?
Thanks,
Frank
11-11-2014 10:56 PM
Hi, please find config below. Thank you!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
service sequence-numbers
!
hostname uc520
!
boot-start-marker
boot system flash uc500-advipservicesk9-mz.151-4.M7
boot-end-marker
!
!
logging buffered 4096
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network default local
!
!
!
!
!
aaa session-id common
!
clock timezone slo 1 0
network-clock-participate wic 1
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
ip cef
!
!
!
ip dhcp pool lan
network 192.168.1.0 255.255.255.0
option 150 ip 10.10.10.1
default-router 192.168.1.1
!
ip dhcp pool voice
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
option 150 ip 10.10.10.1
!
!
!
ip domain name test.local
ip inspect log drop-pkt
ip inspect dns-timeout 10
ip inspect tcp synwait-time 5
ip inspect tcp max-incomplete host 10 block-time 0
ip inspect name wan_out dns
ip inspect name voice_in sip
ip inspect name voice_in rtsp
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW udp router-traffic
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
!
stcapp feature access-code
!
!
!
!
parameter-map type inspect global
log dropped-packets enable
!
!
!
voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
registrar server expires max 3600 min 3600
no update-callerid
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
voice class sip-profiles 1000
request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove
request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove
!
!
voice register global
mode cme
source-address 10.10.10.1 port 5060
max-dn 10
max-pool 10
timezone 28
time-format 24
date-format D/M/Y
file text
create profile sync 0007442844154204
!
!
!
voice translation-rule 12
rule 1 /\(^105817\)/ //
!
voice translation-rule 22
rule 3 // /105817/
!
voice translation-rule 23
rule 1 /\(^0\)/ /00/
!
!
voice translation-profile translate-in
translate called 12
!
voice translation-profile translate-out
translate calling 22
translate called 23
!
!
voice-card 0
!
!
!
license udi pid UC520W-8U-2BRI-K9 sn FHL213627WT
license accept end user agreement
!
!
bridge irb
!
!
!
!
interface FastEthernet0/0
ip address 10.192.10.50 255.252.0.0
ip access-group wan_voice_in in
ip nat outside
ip inspect voice_in out
ip virtual-reassembly in
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1/0
switchport access vlan 600
no ip address
spanning-tree portfast
!
interface FastEthernet0/1/1
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/2
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/3
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport mode trunk
no ip address
spanning-tree portfast
!
interface FastEthernet0/1/5
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/6
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/7
no ip address
shutdown
spanning-tree portfast
!
interface FastEthernet0/1/8
no ip address
shutdown
spanning-tree portfast
!
interface BRI0/1/0
no ip address
!
interface BRI0/1/1
no ip address
!
interface Dot11Radio0/5/0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface Vlan600
ip address dhcp
ip access-group wan_in in
ip inspect SDM_LOW out
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip access-group lan_in in
ip nat inside
ip virtual-reassembly in
!
interface BVI100
ip address 10.10.10.1 255.255.255.0
ip access-group voice_in in
ip nat inside
ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list nat_lan interface FastEthernet0/0 overload
ip nat inside source list nat_voice interface FastEthernet0/0 overload
ip route SBC_IP 255.255.255.255 10.192.10.1
!
ip access-list standard ssh_access
permit 192.168.1.0 0.0.0.255
!
ip access-list extended lan_in
permit ip 192.168.1.0 0.0.0.255 host 10.10.10.1
permit udp any any eq bootps
permit udp any any eq bootpc
permit udp any eq bootps any
permit udp any eq bootpc any
permit icmp any any echo
permit icmp any any echo-reply
permit ip 192.168.1.0 0.0.0.255 host 192.168.1.1
deny ip any any log
ip access-list extended nat_lan
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended nat_voice
permit ip 10.10.10.0 0.0.0.255 any
ip access-list extended voice_in
permit ip 10.10.10.0 0.0.0.255 host 10.10.10.1
permit udp any any eq bootps
permit udp any any eq bootpc
permit udp any eq bootps any
permit udp any eq bootpc any
permit icmp any any echo
permit icmp any any echo-reply
deny ip any any log
ip access-list extended wan_in
deny ip any any log
deny icmp any any
deny igmp any any
deny gre any any
deny ahp any any
deny esp any any
deny ipinip any any
ip access-list extended wan_voice_in
permit udp host SBC_IP host 10.192.10.50 log
permit ip host SBC_IP any
deny ip any any log
!
!
!
!
!
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
tftp-server flash:/English_United_States/rp-sccp.jar
!
!
!
control-plane
!
bridge 1 route ip
bridge 100 route ip
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control
description Muso vad
!
!
dial-peer voice 110 voip
translation-profile outgoing translate-out
destination-pattern 0.T
no modem passthrough
session protocol sipv2
session target ipv4:SBC_IP
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
dtmf-relay rtp-nte
fax rate disable
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 100 voip
translation-profile incoming translate-in
no modem passthrough
session protocol sipv2
session target sip-server
session transport udp
incoming called-number .
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
dtmf-relay rtp-nte
fax rate disable
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
sip-ua
keepalive target ipv4:SBC_IP:5060
no remote-party-id
retry invite 2
retry register 10
timers connect 100
timers keepalive active 100
sip-server ipv4:SBC_IP:5060
host-registrar
!
!
!
telephony-service
protocol mode ipv4
max-ephones 10
max-dn 20
ip source-address 10.10.10.1 port 2000
cnf-file location flash:
cnf-file perphone
load 502G spa50x-30x-7-5-2b
time-zone 28
time-format 24
date-format dd-mm-yy
max-conferences 4 gain -6
moh flash:/media/music-on-hold.au
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 3
number 30
label centrala
description centrala
name centrala
!
!
ephone-dn 4
number 31
description test
name test
!
!
ephone 3
device-security-mode none
mac-address E02F.6D71.A6AF
max-calls-per-button 2
type 502G
button 1:3
!
!
!
ephone 4
device-security-mode none
mac-address 1234.1234.1234
type CIPC
button 1:4
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
session-timeout 600
access-class ssh_access in
timeout login response 10
session-limit 2
transport input ssh
line vty 5 132
session-timeout 600
access-class ssh_access in
timeout login response 10
session-limit 2
transport input ssh
!
ntp source Vlan600
end
11-12-2014 12:32 AM
make
Debug ccsip mess
when making inbound call
and ask your sip provider what should be calling and called numbers for outgoing calls
what number you calling?
11-12-2014 02:17 AM
The issue was just solved - the problem was at ISP side.
UC500 config was ok all the time.
Thanks anyway for help!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide