cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2619
Views
10
Helpful
8
Replies

cisco ip phone registering for ever------CCNA Lab

yasiromer11
Beginner
Beginner

HI 

guys my ip phones is registering for ever, dhcp is good i can ping them from the cme router but can't register in the CIPC phone i am getting a message says failed to retreive configuration from tftp server 10.15.0.1. the physical phone just shows registering for ever

 

Router#sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
10.10.0.11          0110.1f74.6a79.59       Jan 24 2015 05:24 AM    Automatic
10.15.0.12          0100.170e.d3ef.2d       Jan 24 2015 06:56 AM    Automatic
10.15.0.13          0100.170e.c859.6c       Jan 24 2015 06:53 AM    Automatic
10.15.0.14          0100.170e.c85e.de       Jan 24 2015 06:54 AM    Automatic

 

Router#ping 10.15.0.14
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.15.0.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 


Router#sh run
Building configuration...


Current configuration : 2676 bytes
!
! Last configuration change at 06:20:15 UTC Fri Jan 23 2015
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
! card type command needed for slot/vwic-slot 0/1
! card type command needed for slot/vwic-slot 0/2
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.10.0.1 10.10.0.10
ip dhcp excluded-address 10.15.0.1 10.15.0.10
!
ip dhcp pool data
 network 10.10.0.0 255.255.255.0
 default-router 10.10.0.1
 option 150 ip 10.10.0.1
!
ip dhcp pool voice
 network 10.15.0.0 255.255.255.0
 default-router 10.15.0.1
 option 150 ip 10.15.0.1
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1106A3D1
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description Data
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0/0.11
 description managment vlan
 encapsulation dot1Q 11
 ip address 10.11.0.1 255.255.255.0
!
interface FastEthernet0/0.15
 description voice
 encapsulation dot1Q 15
 ip address 10.15.0.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
tftp-server flash:SCCP41.9-1-1SR1S.loads
tftp-server flash:SCCP41.9-1-1SR1S
tftp-server flash:SIP41.9-1-1SR1S.loads
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
telephony-service
 no auto-reg-ephone
 max-ephones 5
 max-dn 10
 ip source-address 10.15.0.1 port 2000
 auto assign 1 to 2
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 4001
!
!
ephone-dn  2  dual-line
 number 4002
!
!
ephone-dn  3  dual-line
 number 4003
!
!
ephone-dn  4  dual-line
 number 4004
!
!
ephone  1
 device-security-mode none
 mac-address 0017.0ED3.EF2D
 type 7961
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 0017.0EC8.596C
 type 7961
 button  1f2
!
!
!
ephone  3
 device-security-mode none
 mac-address 0017.0EC8.5EDE
 type 7961
 button  1:3 2m2
!
!
!
ephone  4
 device-security-mode none
 mac-address 4025.C2C6.A238
 type CIPC
 button  1:4
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
 transport input all
!
scheduler allocate 20000 1000
end

 

 

 

Router#sh flash

CompactFlash directory:
File  Length   Name/status
  1   67902292  c2800nm-adventerprisek9-mz.151-4.M7.bin
  2   2911906  apps41.9-1-1TH1-16.sbn [deleted]
  3   517968   cnu41.9-1-1TH1-16.sbn [deleted]
  4   2625591  cvm41sip.9-1-1TH1-16.sbn
  5   541453   dsp41.9-1-1TH1-16.sbn [deleted]
  6   1631314  jar41sip.9-1-1TH1-16.sbn
  7   660      SIP41.9-1-1SR1S.loads
  8   660      term41.default.loads [deleted]
  9   660      term61.default.loads [deleted]
 10   2911906  apps41.9-1-1TH1-16.sbn
 11   517968   cnu41.9-1-1TH1-16.sbn
 12   2189038  cvm41sccp.9-1-1TH1-16.sbn
 13   541453   dsp41.9-1-1TH1-16.sbn
 14   1629575  jar41sccp.9-1-1TH1-16.sbn
 15   660      SCCP41.9-1-1SR1S.loads
 16   660      term41.default.loads
 17   660      term61.default.loads
 18   8160     Analog1.raw
 19   8160     Analog2.raw
 20   5280     AreYouThere.raw
 21   5040     AreYouThereF.raw
 22   8160     Bass.raw
 23   12240    CallBack.raw
 24   16040    Chime.raw
 25   8160     Classic1.raw
 26   16080    Classic2.raw
 27   10800    ClockShop.raw
 28   2823     DistinctiveRingList.xml
 29   9600     Drums1.raw
 30   13440    Drums2.raw
 31   15840    FilmScore.raw
 32   16080    HarpSynth.raw
 33   8160     Jamaica.raw
 34   16080    KotoEffect.raw
 35   12720    MusicBox.raw
 36   8160     Piano1.raw
 37   15360    Piano2.raw
 38   9360     Pop.raw
 39   7200     Pulse1.raw
 40   4000     Ring1.raw
 41   4000     Ring2.raw
 42   4000     Ring3.raw
 43   4000     Ring4.raw
 44   4000     Ring5.raw
 45   4000     Ring6.raw
 46   4000     Ring7.raw
 47   495      RingList.xml
 48   10800    Sax1.raw
 49   14160    Sax2.raw
 50   16080    Vibe.raw
 51   130548   P003-08-9-00.bin
 52   130952   P003-08-9-00.sbn
 53   15       OS79XX.TXT
 54   459      P0S3-08-9-00.loads
 55   756320   P0S3-08-9-00.sb2
 56   496521   music-on-hold.au
 57   11848167  TSP-SingleLine-2.2.0.5.exe
 58   1755     cucme-mlpp/cucme-mlpp-readme.txt
 59   8532     cucme-mlpp/G729/ATQA.wav
 60   9052     cucme-mlpp/G729/BNEA.wav
 61   7612     cucme-mlpp/G729/BPA.wav
 62   10872    cucme-mlpp/G729/ICA.wav
 63   8062     cucme-mlpp/G729/PALA.wav
 64   9312     cucme-mlpp/G729/UPA.wav
 65   9282     cucme-mlpp/G729/VCA.wav
 66   68980    cucme-mlpp/G711AU/ATQA.au
 67   73090    cucme-mlpp/G711AU/BNEA.au
 68   61550    cucme-mlpp/G711AU/BPA.au
 69   87706    cucme-mlpp/G711AU/ICA.au
 70   65165    cucme-mlpp/G711AU/PALA.au
 71   75199    cucme-mlpp/G711AU/UPA.au
 72   74976    cucme-mlpp/G711AU/VCA.au
 73   10728    dkern9971.100609R2-9-1-1SR1.sebn
 74   1506972  kern9971.9-1-1SR1.sebn
 75   35209984  rootfs9971.9-1-1SR1.sebn
 76   55698    7921-dictionary.xml
 77   137616   7921-font.dat
 78   1723     7921-kate.utf-8.xml
 79   1729     7921-kate.xml
 80   59183    be-sccp.jar
 81   1413     g3-tones.xml
 82   72136    gp-sccp.jar
 83   59183    ipc-sccp.jar
 84   59183    mk-sccp.jar
 85   19318    tc-sccp.jar
 86   59183    td-sccp.jar
 87   23636    tc-sip.jar
 88   68617    rp-sccp.jar
 89   2784     tags_file
 90   2784     utf8_tags_file
 91   119114   rtl-sccp.jar
 92   75616    gd-sip.jar
 93   75616    gh-sip.jar
 94   70611    td-sip.jar
 95   70579    be-sip.jar
 96   23840    gp-sip.jar
 97   70611    ipc-sip.jar
 98   70362    mk-sip.jar
 99   76693    lk-sip.jar
 100   626      CME-locale-en_US-English-8.8.2.5.tar.cfg
 101   131470   Desktops/320x212x12/CampusNight.png
 102   80565    Desktops/320x212x12/CiscoFountain.png
 103   8156     Desktops/320x212x12/CiscoLogo.png
 104   138278   Desktops/320x212x12/Fountain.png
 105   726      Desktops/320x212x12/List.xml
 106   109076   Desktops/320x212x12/MorroRock.png
 107   108087   Desktops/320x212x12/NantucketFlowers.png
 108   10820    Desktops/320x212x12/TN-CampusNight.png
 109   9657     Desktops/320x212x12/TN-CiscoFountain.png
 110   2089     Desktops/320x212x12/TN-CiscoLogo.png
 111   7953     Desktops/320x212x12/TN-Fountain.png
 112   7274     Desktops/320x212x12/TN-MorroRock.png
 113   9933     Desktops/320x212x12/TN-NantucketFlowers.png
 114   726      Desktops/320x216x16/List.xml
 115   726      Desktops/320x212x16/List.xml
[136799560 bytes used, 375683764 available, 512483324 total]
500472K bytes of ATA CompactFlash (Read/Write)

 

 

 

please help 

thanks in advance 

 

8 Replies 8

yasiromer11
Beginner
Beginner

here is debug tftp events


*Jan 24 08:48:30.035: TFTP: Looking for CTLSEP00170EC8596C.tlv
*Jan 24 08:48:30.219: TFTP: Looking for ITLSEP00170EC8596C.tlv
*Jan 24 08:48:30.383: TFTP: Looking for ITLFile.tlv
*Jan 24 08:48:30.819: TFTP: Looking for SEP00170EC8596C.cnf.xml.sgn
Router#
*Jan 24 08:48:31.063: TFTP: Looking for XMLDefault.cnf.xml.sgn
*Jan 24 08:48:31.979: TFTP: Looking for CTLSEP00170EC8596C.tlv
Router#
*Jan 24 08:48:32.187: TFTP: Looking for ITLSEP00170EC8596C.tlv
*Jan 24 08:48:32.383: TFTP: Looking for ITLFile.tlv
*Jan 24 08:48:32.799: TFTP: Looking for SEP00170EC8596C.cnf.xml.sgn
*Jan 24 08:48:33.059: TFTP: Looking for XMLDefault.cnf.xml.sgn
Router#
*Jan 24 08:49:05.351: TFTP: Looking for term61.default.loads
Router#
*Jan 24 08:49:09.251: TFTP: Looking for term61.default.loads
Router#
*Jan 24 08:50:30.859: TFTP: Looking for CTLSEP00170EC85EDE.tlv
*Jan 24 08:50:31.055: TFTP: Looking for ITLSEP00170EC85EDE.tlv
*Jan 24 08:50:31.247: TFTP: Looking for ITLFile.tlv
*Jan 24 08:50:31.655: TFTP: Looking for SEP00170EC85EDE.cnf.xml.sgn
Router#
*Jan 24 08:50:31.891: TFTP: Looking for XMLDefault.cnf.xml.sgn
Router#
*Jan 24 08:50:32.903: TFTP: Looking for CTLSEP00170EC85EDE.tlv
*Jan 24 08:50:33.099: TFTP: Looking for ITLSEP00170EC85EDE.tlv
*Jan 24 08:50:33.259: TFTP: Looking for ITLFile.tlv
*Jan 24 08:50:33.687: TFTP: Looking for SEP00170EC85EDE.cnf.xml.sgn
Router#
*Jan 24 08:50:33.927: TFTP: Looking for XMLDefault.cnf.xml.sgn


thanks appreciate your help

 

 

here is 

Router#sh telephony-service tftp-bindings
tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml
tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml
tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7920-font.xml
tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml
tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml
tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7920-kate.xml
tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml
tftp-server system:/its/vrf1/XMLDefault7961.cnf.xml alias SEP00170ED3EF2D.cnf.xml
tftp-server system:/its/vrf1/XMLDefault7961.cnf.xml alias SEP00170EC8596C.cnf.xml
tftp-server system:/its/vrf1/XMLDefault7961.cnf.xml alias SEP00170EC85EDE.cnf.xml
tftp-server system:/its/vrf1/XMLDefaultCIPC.cnf.xml alias SEP4025C2C6A238.cnf.xml
tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
tftp-server system:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml
tftp-server system:/its/vrf1/ATADefault.cnf.xml alias ATADefault.cnf.xml
tftp-server system:/its/vrf1/XMLDefault7961.cnf.xml alias SEP64D4DA6DBE48.cnf.xml 

    one thing i notice the firmware on the phone 7961 and the come are different

    2.tftp can't access the phone

     

     

     

    So you have two phones?

    One HardPhone (7961)

    One SoftPhone (CIPC)

     

    Are you having troubles with both? where or which frimware difference you found?

     

    Regards.

    Rolando Valenzuela.

    Hi.

    Please activate a debug ephone register and post the output.

    Please post also the output of a show telephony-service command

     

    Thanks

     

    Regards

     

    Carlo

     

    Please rate all helpful posts "The more you help the more you learn"

    total i have 6 phones 4x7961 and 2 soft phone (CIPC&IPB) the soft phone is working fine now

    but the 7961 phones are stuck in registering for ever

    guys this may help i check the

    status message from the 7961 phones 

    trust list update failed 

    no ipv4 DNS server

    TFTP time out:xmldefault.cnf.xml.sgn

     

    under Trust List 

    ITL file i see this password

    48 9F 29 D3 C2 E3 B7 C6

    86 98 13 D6 C5 79 A9 EA

     

    i also check security configuration  on th phone i get this message

    802.1x authentication 

    under 802.1x authentication status

    transaction status 

    disabled

    i factory default 2 of the 7961 and they failed to upgrade firmware they stuck in 

    the cisco logo

     

    HERE IS 

     

    Router#debuG EPHone register
    EPHONE registration debugging is enabled
    Router#
    *Jan 24 19:19:08.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, chang   ed state to up

     

     

    thanks CARLO

    total i have 6 phones 4x7961 and 2 soft phone (CIPC&IPB) the soft phone is working fine now

    but the 7961 phones are stuck in registering for ever

    guys this may help i check the

    status message from the 7961 phones 

    trust list update failed 

    no ipv4 DNS server

    TFTP time out:xmldefault.cnf.xml.sgn

     

    under Trust List 

    ITL file i see this password

    48 9F 29 D3 C2 E3 B7 C6

    86 98 13 D6 C5 79 A9 EA

     

    i also check security configuration  on th phone i get this message

    802.1x authentication 

    under 802.1x authentication status

    transaction status 

    disabled

    i factory default 2 of the 7961 and they failed to upgrade firmware they stuck in 

    the cisco logo

    Firmware  on the phone 

    sscp41.9-3-1es11s

     

    thanks rolando

    Check this links, and check the debug more carefully, you need to activate it and THEN plug a phone in order to see information

     

    https://supportforums.cisco.com/document/53201/info-about-debug-output-running-voice-gateways

     

    http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/troubleshooting/guide/ts_phreg.html

     

    Regards.

    Rolando Valenzuela

    thanks the two phone s is working after i delete the ITL file but the other two i factory default before i delete the ITL password and now failed to upgrade firmware and stuck in the cisco logo i can't access the setting to delete the ITL files, is there any another

    wat  to delete the ITL file.  

    yasiromer11
    Beginner
    Beginner

    Thanks guys i solve the problem the status message in the phone is very helpful, i erase ITL file and it works fine 

    now i factory default two of the phones and i can't access the setting to erase the ITL file because the phone stuck on the cisco logo and failed to upgrade due to the ITL password, any solution please.

     

    here is the procedure 

    Choose these steps in order to manually delete the ITL file on one of the IP phones:

    1. Choose Settings > Security Configuration.

    2. Press**# and erase the ITL file in order to unlock the IP Phone.

    3. Make sure it works properly afterwards and check that there are no ITL errors. Then the fix for all the other IP phones would be to complete the rollback procedure.

      This allows the phones to get a blank ITL file, which allows them to then download the new correct ITL file that can authenticate their configuration files.

      Even if you point the phones back to a CUCME, they still do not accept their configuration files due to the ITL file being on the phone. It has to be removed or a blank (empty) ITL has to be put on the phones for them to work properly with CUCME.

      The rollback option is not on CUCME . It would have to be done on CUCM 8.x . You can power on the CUCME and the phones would register since its old (cached) configuration file is still on the phone, however configuration changes would not

    Getting Started

    Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

    Recognize Your Peers