cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
263
Views
0
Helpful
3
Replies

Configure VGW for AF31 and EF Traffic

richard-matthews
Beginner
Beginner

Hi,

I have been asked to configure QoS on our router for voice traffic. The link is 1GB and the request is for 4.8Mb EF and 200kb AF31 traffice to be configured.

I have only ever had to configure traffic for one dscp before, setting up an ACL with "permit ip any any dscp ef". How would I go about setting traffic for both? 

Would the below work?

ip access-list extended VOICE_ACL
permit ip any any dscp ef
permit ip any any dscp af31

policy-map VOICE_EF
class VOICE_CLASS
bandwidth 4800
class class-default
fair-queue

policy-map VOICE_AF31
class VOICE_CLASS
bandwidth 200
class class-default
fair-queue

class-map match-any VOICE_CLASS
match access-group name VOICE_ACL

interface GigabitEthernet0/0/0
service-policy output VOICE_EF
service-policy output VOICE_AF31

Thanks in advance for any help or info anyone can give!

1 Accepted Solution

Accepted Solutions

Hi,

Actually the 2nd config is the correct one. The old one was wrong and won't work. The only thing I can suggest on top of it, do you want to use CBWFQ (which is bandwidth command) for voice traffic EF. Instead you case use LLQ (which is priority command) for voice traffic EF and leave CBWFQ for voice traffic AF31.  

This is qos best practice based on QoS srnd. Also, you need to make sure that your endpoints are marking traffic as you are using dscp values in ACLs. I usually prefer to use ports instead of markings as it is safer (avoiding apps sending EF traffic such as skype). A combination of both is much better.  

View solution in original post

3 Replies 3

richard-matthews
Beginner
Beginner

OK I have done some more research and have seen that you cannot add two output service policies onto 1 interface, so changed my config to the following:

policy-map SIP_Trunk
class Voice_EF
bandwidth 4800
fair-queue
class Voice_AF31
bandwidth 200
fair-queue
!
!
class-map match-any Voice_EF
match access-group name Voice_EF

class-map match-any Voice_AF31
math access-group name VOice_AF31
!
ip acces-list extended Voice_EF
permit ip any any descp ef
!
ip access-list extended Voice_AF31
permit ip any any dscp af31
!
int gi0/0/0
service-policy output SIP_Trunk

Will this work? Or am I over complicating things??

Thanks

Hi,

Actually the 2nd config is the correct one. The old one was wrong and won't work. The only thing I can suggest on top of it, do you want to use CBWFQ (which is bandwidth command) for voice traffic EF. Instead you case use LLQ (which is priority command) for voice traffic EF and leave CBWFQ for voice traffic AF31.  

This is qos best practice based on QoS srnd. Also, you need to make sure that your endpoints are marking traffic as you are using dscp values in ACLs. I usually prefer to use ports instead of markings as it is safer (avoiding apps sending EF traffic such as skype). A combination of both is much better.  

richard-matthews
Beginner
Beginner

Thanks Mohammed.

I have taken your advise and switched to LLQ for the EF traffic.

Thanks again :)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: