cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
349
Views
0
Helpful
1
Replies
sharma.amit23
Enthusiast

CUBE configuration issue

Hello,

 

i have CUBE configuration and it is connected with ITSP.

now ITSP wants to send g729r8 codec when call goes from CUCM. see CUBE configuration:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2015.05.27 01:27:31 =~=~=~=~=~=~=~=~=~=~=~=

Building configuration...


Current configuration : 12136 bytes
!
! Last configuration change at 01:22:02 AST Wed May 27 2015 by admin
! NVRAM config last updated at 01:22:58 AST Wed May 27 2015 by admin
! NVRAM config last updated at 01:22:58 AST Wed May 27 2015 by admin
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CUBE-B
!
boot-start-marker
boot-end-marker
!
!
no logging queue-limit
no logging rate-limit
!
aaa new-model
!
!
 --More--         aaa authentication login AAA-VPN local
aaa authorization network AAA-VPN local
!
!
!
!
!
aaa session-id common
clock timezone AST 3 0
clock calendar-valid
!
ip cef
!
!
!
ip dhcp excluded-address 10.100.107.254 10.100.107.255
ip dhcp excluded-address 10.100.106.1 10.100.106.15
ip dhcp excluded-address 10.100.106.254 10.100.106.255
ip dhcp excluded-address 10.100.105.1 10.100.105.15
ip dhcp excluded-address 10.100.105.254 10.100.105.255
ip dhcp excluded-address 10.100.107.1 10.100.107.15
!
ip dhcp pool IP Phones
 --More--          network 10.100.107.0 255.255.255.0
 default-router 10.100.107.1
 option 150 ip 10.100.106.7 10.100.106.8
!
ip dhcp pool Data
 network 10.100.105.0 255.255.255.0
 default-router 10.100.105.1
 dns-server 8.8.8.8 8.8.4.4
!
!
!
ip domain name vodafone.qa
ip host vodafone.qa 172.16.9.4
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
 --More--         !
crypto pki trustpoint TP-self-signed-1241508841
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1241508841
 revocation-check none
 rsakeypair TP-self-signed-1241508841
!
!
crypto pki certificate chain TP-self-signed-1241508841
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323431 35303838 3431301E 170D3134 30313233 31313230
  34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32343135
  30383834 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100F17F 77654DC5 6E11ACA8 D87C3B5F 053AF681 4AFC9366 937D07CA 2992DCA5
  69C62457 A5FF85F6 CEAC5005 39F5FC5B 8BD041A5 CF4F7790 8C22B70A C8AD3E24
  BE40FC12 6949818B 6540EAFA BA25BBC1 587DC548 9F9D39D2 5C09190A 8FF37461
  AC5B0773 CE6F4A40 CD24E39B BFDE5D5E 76870778 62D77460 46FE4BFC 8C5726FA
  A3DD0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 145DCC3D A3769852 593EE270 50E81FEC 5424BE5C 78301D06
  03551D0E 04160414 5DCC3DA3 76985259 3EE27050 E81FEC54 24BE5C78 300D0609
 --More--           2A864886 F70D0101 05050003 8181002E 10F78D93 6CB5AC71 5FC245A4 1EA22D0A
  9E5DBBA4 DEE1575E 316689D5 AAFC7DE8 71F6C2EC 5AC89AB3 C3063469 53F67E20
  1026A8FF 7A0B59A5 032556CE 9C697C83 6C982706 D8F5576A A1DE7F8C EDF7C0EE
  9136608E 7E1287C7 948A1EA9 F19D828B 9628EE01 CEDEB69B C8F78EC8 BCAF73A9
  F202D03E EDF9A91A 2DE12497 A42B13
      quit
voice-card 0
!
!
!
voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
  ipv4 0.0.0.0
 mode border-element license capacity 100
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  rel1xx disable
  header-passing
  error-passthru
  no update-callerid
  bearer-capability clear-channel rdi
 --More--           early-offer forced
  midcall-signaling passthru
  g729 annexb-all
  sip-profiles 400
!
voice class codec 4
 codec preference 1 g729br8
 codec preference 2 g711ulaw
!
voice class sip-profiles 400
 request INVITE sip-header Diversion modify "sip:(.*>)" "sip:+97440002300@vodafone.qa>"
 request REINVITE sip-header Diversion modify "sip:(.*>)" "sip:+97440002300@vodafone.qa>"
 request INVITE sip-header From modify "<sip:(.*)@(.*)>" "<sip:\1@vodafone.qa>"
 request INVITE sip-header Diversion modify "sip:(.*>)" "sip:+97440002330@vodafone.qa>"
 request REINVITE sip-header Diversion modify "sip:(.*>)" "sip:+97440002330@vodafone.qa>"
!
!
!
!
 --More--         voice translation-rule 2
 rule 1 /^9\(.*\)/ /\1/ type any national plan any isdn
!
!
voice translation-profile QE-out
 translate called 2
!
!
!
license udi pid CISCO2911/K9 sn FCZ17276032
hw-module pvdm 0/0
!
!
!
username admin privilege 15 secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
username vodafone password 0 v367897
!
redundancy
!
!
!
!
!
 --More--         !
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp client configuration group vpnall
 key gb34567
 dns 8.8.8.8
 pool VPNALLPOOL
!
crypto isakmp client configuration group vodafone
 key voda67890
 dns 8.8.8.8
 pool VPNALLPOOL
!
!
crypto ipsec transform-set 3des-sha esp-3des esp-sha-hmac
 mode tunnel
!
!
!
 --More--         crypto dynamic-map dynmap 10
 set transform-set 3des-sha
!
!
crypto map vpn client authentication list AAA-VPN
crypto map vpn isakmp authorization list AAA-VPN
crypto map vpn client configuration address respond
crypto map vpn 10 ipsec-isakmp dynamic dynmap
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.50
 --More--          encapsulation dot1Q 50
 ip address 10.100.105.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 10.100.106.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/0.70
 encapsulation dot1Q 70
 ip address 10.100.107.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1
 description Alcatel Router pointing interface
 ip address 10.72.0.66 255.255.255.248
 ip access-group RESTRICT-VODAFONE in
 ip nat outside
 ip virtual-reassembly in
 --More--          duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description internet
 ip address 80.76.165.118 255.255.255.252
 ip access-group RESTRICT-INTERNET in
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 crypto map vpn
!
ip local pool VPNALLPOOL 10.100.109.1 10.100.109.254
ip forward-protocol nd
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat pool INTERNET 80.76.165.118 80.76.165.118 netmask 255.255.255.252
ip nat inside source list NAT-ACL interface GigabitEthernet0/2 overload
 --More--         ip route 0.0.0.0 0.0.0.0 80.76.165.117
ip route 172.16.9.4 255.255.255.255 10.72.0.65
!
ip access-list extended NAT-ACL
 deny   ip 10.100.105.0 0.0.0.255 10.100.109.0 0.0.0.255
 deny   ip 10.100.106.0 0.0.0.255 10.100.109.0 0.0.0.255
 deny   ip 10.100.107.0 0.0.0.255 10.100.109.0 0.0.0.255
 permit ip 10.100.105.0 0.0.0.255 any
 permit ip 10.100.106.0 0.0.0.255 any
 permit ip 10.100.107.0 0.0.0.255 any
ip access-list extended RESTRICT-INTERNET
 deny   udp any any eq 5060
 deny   tcp any any eq 5061
 deny   udp any any eq 5061
 deny   tcp any any eq 5060
 deny   tcp any any eq telnet
 deny   tcp any any eq www
 deny   icmp any any echo
 deny   tcp any any eq 22
 deny   tcp any any eq 1720
 deny   tcp any any eq 1719
 permit ip any any
 permit esp any any
 --More--         ip access-list extended RESTRICT-VODAFONE
 deny   tcp any any eq telnet
 deny   tcp any any eq www
 deny   tcp any any eq echo
 deny   tcp any any eq 1720
 deny   tcp any any eq 1719
 permit ip any any
ip access-list extended SPLIT-TUNNEL-ACL
 permit ip 10.100.109.0 0.0.0.255 10.100.105.0 0.0.0.255
 permit ip 10.100.109.0 0.0.0.255 10.100.106.0 0.0.0.255
 permit ip 10.100.109.0 0.0.0.255 10.100.107.0 0.0.0.255
ip access-list extended VPNACL_REMOTE
 permit ip 10.100.109.0 0.0.0.255 any
!
access-list 2 permit 10.100.105.0 0.0.0.255
access-list 2 permit 10.100.106.0 0.0.0.255
access-list 2 permit 10.100.107.0 0.0.0.255
!
!
!
!
!
control-plane
 --More--         !
 !
 !
 !
!
!
!
mgcp profile default
!
!
dial-peer voice 100 voip
 description ** INBOUND LAN SIDE DIAL_PEER FROM CUCM TO CUBE **
 session protocol sipv2
 session target sip-server
 incoming called-number 9T
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 200 voip
 description ** OUTBOUND LAN SIDE DIAL_PEER FROM CUBE TO CUCM **
 preference 1
 destination-pattern +9744000....$
 session protocol sipv2
 --More--          session target ipv4:10.100.106.7:5060
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 201 voip
 description ** OUTBOUND LAN SIDE DIAL_PEER FROM CUBE TO CUCM 2 **
 preference 2
 destination-pattern +9744000....$
 session protocol sipv2
 session target ipv4:10.100.106.8:5060
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 1000 voip
 description ** INBOUND WAN SIDE DIAL_PEER FROM SP TO CUBE **
 session protocol sipv2
 session target sip-server
 incoming called-number +9744000....$
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 3000 voip
 description *** LOCAL DIALING POOL WAN-SIDE DIAL_PEER ***
 --More--          translation-profile outgoing QE-out
 destination-pattern 9[4].......$
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 2000 voip
 description *** MOBILE DIALING POOL WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 9[3567].......$
 session protocol sipv2
 session target sip-server
 voice-class codec 4  
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
!
dial-peer voice 4000 voip
 --More--          description *** EMERGENCY DIALING WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 999$
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 5000 voip
 description *** INTERNATIONAL DIALING WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 900T
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
!
 --More--         dial-peer voice 5001 voip
 description *** INTERNATIONAL DIALING WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 900#T
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 6000 voip
 description *** SPECIAL LOCAL DIALING WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 9[28]......$
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 --More--         !
dial-peer voice 7000 voip
 description *** SHORT DIALING WAN-SIDE DIAL_PEER ***
 translation-profile outgoing QE-out
 destination-pattern 91..$
 session protocol sipv2
 session target sip-server
 voice-class sip profiles 400
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 1 voip
 fax-relay ecm disable
 fax-relay sg3-to-g3
 fax nsf 000000
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
gateway
 timer receive-rtp 1200
!
 --More--         sip-ua
 sip-server dns:vodafone.qa:5061
!
!
!
gatekeeper
 shutdown
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 transport input telnet ssh
 --More--         line vty 5 15
 exec-timeout 0 0
 privilege level 15
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp master
ntp server pool.ntp.org
!
end

!!!!

!!
!

CUCM region is g711ulaw so that when i calls out or incoming call, it shows g711ulaw codec to us.

 

Telephony call-legs: 0
SIP call-legs: 2
H323 call-legs: 0
Call agent controlled call-legs: 0
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2
0    : 19765 1079700530ms.1 (01:28:37.808 AST Wed May 27 2015) +6530 pid:100 Answer +97440002335 active
 dur 00:00:25 tx:1433/229280 rx:1432/229120 dscp:0 media:0 audio tos:0xB8 video tos:0x0
 IP 10.100.106.7:27966 SRTP: off rtt:0ms pl:0/0ms lost:0/0/0 delay:0/0/0ms g711ulaw TextRelay: off Transcoded: No
 media inactive detected:n media contrl rcvd:n/a timestamp:n/a
 long duration call detected:n long duration call duration:n/a timestamp:n/a

0    : 19766 1079700530ms.2 (01:28:37.808 AST Wed May 27 2015) +6520 pid:2000 Originate 66774169 active
 dur 00:00:25 tx:1432/229120 rx:1579/252640 dscp:0 media:0 audio tos:0xB8 video tos:0x0
 IP 172.16.9.4:29328 SRTP: off rtt:0ms pl:0/0ms lost:0/0/0 delay:0/0/0ms g711ulaw TextRelay: off Transcoded: No
 media inactive detected:n media contrl rcvd:n/a timestamp:n/a
 long duration call detected:n long duration call duration:n/a timestamp:n/a


Telephony call-legs: 0
SIP call-legs: 2
H323 call-legs: 0
Call agent controlled call-legs: 0
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2


!

 

 

how can we apply g729 for incoming and outgoing calls?

!

as we have the UCCX and call recording is configured so would be affect this change?

!

 

Warm Regard's
Amit Sahrma
1 REPLY 1
Marcelo Morais
Advocate

Hi,

 did you change in CUCM the CUBE Region to G.729?

 

Regards.

Content for Community-Ad

Spotlight Awards 2021