cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
815
Views
0
Helpful
3
Replies

CUCI-Lync Visual Voicemail

Nick Richards
Beginner
Beginner

I have a TAC case open for this but wanted to ping the community...

* We're doing the latest CUCI-Lync with the CUCM 8.6 and UCxn 8.6 (I think 8.6 is the newest; whatever is newest).

* UCxn and CUCM users are integrated with LDAP; UCxn users were all imported from LDAP.

* We're using a 10-digit dial plan (not +E.164)

* I have Visual VoiceMail configured and working from the 7962 desk phones

Here's the problem:

In CUCILync, pressing the Messages button launches the audio voicemail sign-in.  I want to do Visual Voicemail from CUCI-Lync.  I've done all the tasks in these:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucimoc/8_5/english/installguide/config_servers.html#wp1063920

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a0080ba7d10.shtml#

There's no checkbox to enable this in the CUCI-Lync settings, either.

Any ideas?

3 Replies 3

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

VisualVoicemail on CUCI-Lync is not the same VV that you use on the phone.  It uses the IMAP connection to establish the connection from CUCI-Lync. Make sure ou have IMAP enabled in the COS of the user and that the IMAP service is running.  What port are you using for the connection? Can you post your cuci-lync registry configuration?

HTH,

Chris

I bring up the VVM in case it conflicts with the VV (I assume VV is the right acronym for the IMAP one). Don't see how it would, just erring towards the side of TMI.

I'm using the default COS for all users, and all services are running.

Here is the latest registry, after many iterations:

[HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services Framework\AdminData]

"TftpServer1"="1.1.1.9"

"CcmcipServer1"=""

"LDAP_Server_1"="1.1.2.2"

"LDAP_UserLogonDomain"="cms.local"

"CtiServer1"=""

"AutomaticDeviceSelectionMode"="0"

"LDAP_Server_2"="1.1.2.3"

"VVM_SystemServer_0"="1.1.1.12"

"VVM_Mailstore_ImapPort_0"="143"

"VVM_Mailstore_ImapProtocol_0"="TCP"

"VVM_Mailstore_InboxFolderName"="INBOX"

"VVM_Mailstore_PollingInterval"="60"

"VVM_Mailstore_Server_0"="1.1.1.12"

"UseCUCMGroupForCti"="true"

"CcmcipServerValidation"="0"

Resolved by removing my registry flub.

The problem was that the VM I'm using was once part of my lab domain, and I had pushed the registry entries contained in the HKCU\Policies branch of the registry. Those policies take precedence over any defined in the HKCU\Software folder, and my voicemail settings were not even being referenced.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers