cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1560
Views
0
Helpful
17
Replies
Cisco Employee

I dont see any matching

I dont see any matching outgoing dial-peer.

dial-peer voice 100 voip
 incoming called-number .%
 no vad
!
dial-peer voice 200 voip
 destination-pattern 0822877730.......
 session protocol sipv2
 session target ipv4:10.1.45.20             ( IP from Sip provider router interface)
!
dial-peer voice 300 voip
 session protocol sipv2
 session target ipv4:192.168.50.10          ( CUCM IP address )
 incoming called-number 0822877730.......

 

Please refer to below doc, on how to configure inbound and outbound dial-peers.

 

 

http://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html

Beginner

Hi Aramared please see my

Hi Aramared

 

please see my attached log. my outgoing dial-peer to be paired is 082.......

which is I dialed @ my CUCM 0823055942

 

:( I can't get it working

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2015.02.10 15:48:56 =~=~=~=~=~=~=~=~=~=~=~=


User Access Verification

Password:
CUBE>en
Password:
CUBE#show run
Building configuration...


Current configuration : 2096 bytes
!
! Last configuration change at 07:20:03 UTC Tue Feb 10 2015
! NVRAM config last updated at 07:20:05 UTC Tue Feb 10 2015
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CUBE
!
boot-start-marker
boot-end-marker
!
!
enable password password
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
voice-card 0
!
!
!
voice service voip
 ip address trusted list
  ipv4 10.1.45.20
  ipv4 192.168.50.10
 mode border-element
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
  midcall-signaling passthru
  pass-thru content sdp
!
!
!
!
!
license udi pid CISCO2901/K9 sn FGL171622TN
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.1.45.3 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.1.45.1
!
!
!
!
control-plane
!
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
!
dial-peer voice 100 voip
 destination-pattern 082.......
 session protocol sipv2
 session target ipv4:10.1.45.20
 dtmf-relay rtp-nte
 no vad
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0
 password password
 login
 transport input all
line vty 1 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

CUBE#deb
CUBE#debug voice
CUBE#debug voice ccap
CUBE#debug voice ccapi inout
voip ccapi inout debugging is on
CUBE#deb
CUBE#debug ccsi
CUBE#debug ccsip mess
CUBE#debug ccsip messages
SIP Call messages tracing is enabled
CUBE#clear
CUBE#clear logg
Clear logging buffer [confirm]
CUBE#show log
Syslog logging: enabled (0 messages dropped, 2 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

 

No Inactive Message Discriminator.


    Console logging: level debugging, 2626 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 1298 messages logged, xml disabled,
                     filtering disabled
    Buffer logging:  level debugging, 2626 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled
    Trap logging: level informational, 99 message lines logged

Log Buffer (8192 bytes):
-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552969
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:22:50.163: //41/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1:5060;branch=z9hG4bK517A6
Remote-Party-ID: "DEMO" <sip:200@192.168.50.1>;party=calling;screen=yes;privacy=off
From: "DEMO" <sip:200@192.168.50.1>;tag=391390-A43
To: <sip:0823055942@10.1.45.20>
Date: Tue, 10 Feb 2015 07:22:50 GMT
Call-ID: 73D8D3D4-B02C11E4-8099B5A0-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552970
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:22:51.163: //41/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1:5060;branch=z9hG4bK517A6
Remote-Party-ID: "DEMO" <sip:200@192.168.50.1>;party=calling;screen=yes;privacy=off
From: "DEMO" <sip:200@192.168.50.1>;tag=391390-A43
To: <sip:0823055942@10.1.45.20>
Date: Tue, 10 Feb 2015 07:22:51 GMT
Call-ID: 73D8D3D4-B02C11E4-8099B5A0-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552971
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:22:53.163: //41/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1:5060;branch=z9hG4bK517A6
Remote-Party-ID: "DEMO" <sip:200@192.168.50.1>;party=calling;screen=yes;privacy=off
From: "DEMO" <sip:200@192.168.50.1>;tag=391390-A43
To: <sip:0823055942@10.1.45.20>
Date: Tue, 10 Feb 2015 07:22:53 GMT
Call-ID: 73D8D3D4-B02C11E4-8099B5A0-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552973
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:22:57.163: //41/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1:5060;branch=z9hG4bK517A6
Remote-Party-ID: "DEMO" <sip:200@192.168.50.1>;party=calling;screen=yes;privacy=off
From: "DEMO" <sip:200@192.168.50.1>;tag=391390-A43
To: <sip:0823055942@10.1.45.20>
Date: Tue, 10 Feb 2015 07:22:57 GMT
Call-ID: 73D8D3D4-B02C11E4-8099B5A0-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552977
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:23:05.163: //41/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1:5060;branch=z9hG4bK517A6
Remote-Party-ID: "DEMO" <sip:200@192.168.50.1>;party=calling;screen=yes;privacy=off
From: "DEMO" <sip:200@192.168.50.1>;tag=391390-A43
To: <sip:0823055942@10.1.45.20>
Date: Tue, 10 Feb 2015 07:23:05 GMT
Call-ID: 73D8D3D4-B02C11E4-8099B5A0-212988D7@192.168.50.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 0443218688-0000065536-0000000060-0171092160
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1423552985
Contact: <sip:200@192.168.50.1:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Length: 0


Feb 10 07:23:06.743: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
CANCEL sip:0823055942@192.168.50.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.10:5060;branch=z9hG4bK3b50f5f3c2
From: "DEMO" <sip:200@192.168.50.10>;tag=61~7f88b1b9-f68d-4857-b8e0-e411cd112197-23459567
To: <sip:0823055942@192.168.50.1>
Date: Tue, 10 Feb 2015 07:40:39 GMT
Call-ID: 1a6afb00-4d91b5f7-3c-a32a8c0@192.168.50.10
CSeq: 101 CANCEL
Max-Forwards: 70
Content-Length: 0


Feb 10 07:23:06.743: //40/1A6AFB000000/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x2A42D6F4, Call Id=40
Feb 10 07:23:06.747: //40/1A6AFB000000/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=FALSE, Cause Value=16, Retry Count=0)
Feb 10 07:23:06.747: //41/1A6AFB000000/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Feb 10 07:23:06.747: //41/1A6AFB000000/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=FALSE, Cause Value=16)
Feb 10 07:23:06.747: //40/1A6AFB000000/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
Feb 10 07:23:06.747: //40/1A6AFB000000/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
Feb 10 07:23:06.747: //40/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.50.10:5060;branch=z9hG4bK3b50f5f3c2
From: "DEMO" <sip:200@192.168.50.10>;tag=61~7f88b1b9-f68d-4857-b8e0-e411cd112197-23459567
To: <sip:0823055942@192.168.50.1>
Date: Tue, 10 Feb 2015 07:23:06 GMT
Call-ID: 1a6afb00-4d91b5f7-3c-a32a8c0@192.168.50.10
CSeq: 101 CANCEL
Content-Length: 0


Feb 10 07:23:06.747: //40/1A6AFB000000/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 487 Request Cancelled
Via: SIP/2.0/UDP 192.168.50.10:5060;branch=z9hG4bK3b50f5f3c2
From: "DEMO" <sip:200@192.168.50.10>;tag=61~7f88b1b9-f68d-4857-b8e0-e411cd112197-23459567
To: <sip:0823055942@192.168.50.1>;tag=39564C-9F4
Date: Tue, 10 Feb 2015 07:23:06 GMT
Call-ID: 1a6afb00-4d91b5f7-3c-a32a8c0@192.168.50.10
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=16
Content-Length: 0


Feb 10 07:23:06.747: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0823055942@192.168.50.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.10:5060;branch=z9hG4bK3b50f5f3c2
From: "DEMO" <sip:200@192.168.50.10>;tag=61~7f88b1b9-f68d-4857-b8e0-e411cd112197-23459567
To: <sip:0823055942@192.168.50.1>;tag=39564C-9F4
Date: Tue, 10 Feb 2015 07:40:39 GMT
Call-ID: 1a6afb00-4d91b5f7-3c-a32a8c0@192.168.50.10
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: presence, kpml
Content-Length: 0


Feb 10 07:23:06.751: //40/1A6AFB000000/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x2A42D6F4, Tag=0x0, Call Id=40,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Feb 10 07:23:06.751: //40/1A6AFB000000/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Feb 10 07:23:06.751: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
Feb 10 07:23:06.751: :cc_free_feature_vsa freeing 31839BE0
Feb 10 07:23:06.751: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
Feb 10 07:23:06.751:  vsacount in free is 1
CUBE#undeb
CUBE#undebug all
All possible debugging has been turned off
CUBE#exit

Cisco Employee

Configure below:dial-peer

Configure below:

dial-peer voice 200 voip
 incoming called-number .
 no vad
 
 dial-peer voice 300 voip   ---->this is the dial-p towards CUCM
 session protocol sipv2
 session target ipv4:192.168.50.10          ( CUCM IP address )
 destination pattern 0822877730.......----> mention here the range of CUCM DN's.
 
For incoming through this SIP trunk to reach CUCM DN's, provider will send some number, you need to configure accordingly in above dial-peer voice 300.
If your CUCM DNs are in range 21559 to 21889, you can configure in above dial-peer 300, destination-pattern as 21xxx.
 
If provoider is sending fufl DID number towards CUBE for incoming call, like  21246421559, then configure in above dial-peer 300, destination-pattern as 21246421xxx, then in the CUCM you can configure translation pattern to convert 21246421xxx to 21xxx, so that it rings phones with DNs 21xxx range in CUCM.
 
 
 
 dial-peer voice 100 voip     ---->this is the dial-p towards SIP provider
 destination-pattern 082....... ---->mention here the range for outgoing calls towards SIP provider.
 session protocol sipv2
 session target ipv4:10.1.45.20
 dtmf-relay rtp-nte
 no vad
 In the above dial-peer 100, mention the range for outgoing calls, the called numbers range which will be sent out from CUCBE towards SIP provider.
 
 
 
 ++++From debugs, CUBE is sending INvite Via  192.168.50.1, since you have given bind for media and signalling as GigabitEthernet0/1.
 
 Sent:
INVITE sip:0823055942@10.1.45.20:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.50.1

As you mentioned in your earlier note:  Signalling IP: 10.1.45.3(GigabitEthernet0/0) ( this is the IP they ask from us to be used for signalling)

Make below change:
conf t
voice service voip
sip
bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
 
  Router# wr mem
 
 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards