Showing results for 
Search instead for 
Did you mean: 

How can add Tech-Prefix for did range on gateway?

Level 1
Level 1


I have installed one gatekeeper and two gateway.

gw1 did range 37500-37799

gw2 did range 37800-37999

on gw1

int loopback 0

h323-gateway tech prefix 37[5-7]

on gw2

int loopback 0

h323-gateway tech-prefix 37[8-9]

How can I write did range on gateway. When try to write like below ı have faced problem ;

R1(config-if)#h323-gateway voip tech-prefix 36[5-7]

Incorrect format for Technology Prefix

        regular expression must be of the form  ^[0-9#]+$


1 Reply 1

Yogesh Singh
Level 1
Level 1

You  should not use a DID range as Gatekeeper tech prefix

The technology prefix should not be used as part of the actual routing of the DNs.

The purpose of the field/config is to create groups (Example )


1# are GWs

2# are video enabled GWs

3# are cucm trunks

This are then added to the number you dial and stripped by the GK.

You should take care of your routing using the zones configuration in the GK and not to rely in the tech prefix as an actual part of the DN you're trying to reach.

Here is an Example  but just the basics so you understand the high level concepts. I'll just show 1 route pattern, create as many as needed.

use tech prefix as 1# for all systems

In CUCM register the GK

RP with DN 4[67]...

GW dial-peer  dial peer with session RAS

destination pattern 4[34]...

gw-type-prefix 1#* default-technology

zone local CUCM
zone local CME
zone remote otherGK 1719
zone prefix CUCM 43...
zone prefix CUCM 44...

zone prefix CME 46...

zone prefix CME 47...

zone prefix otherGK 1....

zone prefix otherGK 2....

zone prefix otherGK 3....

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: