cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
236
Views
0
Helpful
1
Replies
Highlighted

ITSP SIP Trunk audio issue

Hi Guys,

call flow:

external caller > service provider SIP Trunk >CUBE VG>CUCM>User ip phone.

no firewall between

we are not facing this audio issue for all the calls but also for few calls , i can say 3 out of 10 calls.

under VG bind media and control command recently added by TAC guys instruction but no use.

recently we changed our office but no changes for device or configuration

also attached debug log for the issue call.

ONE THING I NOTICE 2 HOUR TIME DIFFERENCE IN VOICE GATEWAY than  actual time.

Voice gateway show run: ---------

aaa session-id common

memory-size iomem 10

clock timezone CET 1 0

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00

network-clock-participate wic 0

!

dot11 syslog

ip source-route

!

ip traffic-export profile tac mode capture

!

ip traffic-export profile sniffer mode capture

  bidirectional

!

ip traffic-export profile Test mode capture

  bidirectional

!

!

ip cef

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.18.122.1 172.18.122.50

!

ip dhcp pool PHONES

   network 172.18.122.0 255.255.255.0

   domain-name ldhenergy.net

   option 150 ip 172.18.122.10

   default-router 172.18.122.8

!

!

no ip domain lookup

ip domain name ldhenergy.com

ip host ld-lsn-cm-01 172.18.122.10

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 172.18.122.11 255.255.255.255

dtmf-interworking rtp-nte

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

h323

sip

  bind control source-interface FastEthernet0/0

  bind media source-interface FastEthernet0/0

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

!

!

!

voice translation-rule 20

rule 1 /044578\(....\)$/ /\1/ type any unknown plan any unknown

!

voice translation-rule 30

rule 1 /021343\(....\)$/ /\1/ type any unknown plan any unknown

!

voice translation-rule 40

rule 1 /^\(.*\)/ /0\1/

!

!

voice translation-profile SIPIN

translate called 30

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

crypto pki token default removal timeout 0

!

!

!

!

!

!

controller E1 0/0/0

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.18.122.3 255.255.255.0

ip helper-address 193.73.102.255

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.128.18.9 255.255.255.0

duplex auto

speed auto

!

interface Integrated-Service-Engine1/0

ip unnumbered FastEthernet0/0

service-module ip address 172.18.122.11 255.255.255.0

!Application: CUE Running on NME

service-module ip default-gateway 172.18.122.8

no keepalive

!

router ospf 1005

network 172.18.122.0 0.0.0.255 area 0.0.0.1

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 172.18.122.8

ip route 10.20.0.0 255.255.0.0 172.18.122.8

ip route 172.18.122.11 255.255.255.255 Integrated-Service-Engine1/0

ip tacacs source-interface FastEthernet0/0

!

!

!

!

!

control-plane

!

!

ccm-manager fallback-mgcp

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.18.122.10 

ccm-manager config

!

mgcp call-agent 172.18.122.10 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 172.18.122.10 identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 10 register HW-MTP

associate profile 20 register TRANSCODE

!

dspfarm profile 20 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 4

associate application SCCP

!

dspfarm profile 10 mtp 

codec g711alaw

maximum sessions hardware 24

associate application SCCP

!

dial-peer voice 343 voip

translation-profile incoming SIPIN

session protocol sipv2

incoming called-number .

voice-class sip bind control source-interface FastEthernet0/0

voice-class sip bind media source-interface FastEthernet0/0

dtmf-relay rtp-nte sip-notify sip-kpml cisco-rtp h245-signal h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 344 voip

destination-pattern 0T

session protocol sipv2

session target ipv4:62.2.46.4

voice-class sip bind control source-interface FastEthernet0/0

voice-class sip bind media source-interface FastEthernet0/0

dtmf-relay rtp-nte sip-notify sip-kpml cisco-rtp h245-signal h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 1600 voip

destination-pattern 16..

session protocol sipv2

session target ipv4:172.18.122.10

voice-class sip bind control source-interface FastEthernet0/0

voice-class sip bind media source-interface FastEthernet0/0

dtmf-relay sip-notify

codec g711alaw

no vad

!

dial-peer voice 1616 voip

destination-pattern 1616

session protocol sipv2

session target ipv4:172.18.122.10

dtmf-relay rtp-nte sip-notify sip-kpml cisco-rtp h245-signal h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 1699 voip

destination-pattern 1699

session protocol sipv2

session target ipv4:172.18.122.10

voice-class sip bind control source-interface FastEthernet0/0

voice-class sip bind media source-interface FastEthernet0/0

dtmf-relay sip-notify

codec g711alaw

no vad

!

!

!

sip-ua

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 172.18.122.3 port 2000

max-ephones 42

max-dn 144

Regards

Vigeesh

1 REPLY 1
Highlighted

ITSP SIP Trunk audio issue

I suggest  do a network capture or enable debug ccsip mesages.

look for conneciion ip address inside sdp field and check that are recheacble.

regards