cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
523
Views
0
Helpful
6
Replies
Highlighted

jabber MRA registration issue when exp c1 (of cluster) goes down.

hi guys,

 

running cucm 11.5 with expressways X8.11.4 (both e and c are a cluster deployment).    jabber MRA via exp c 1 was registered to cucm  and working fine (Jabber is registered on cucm with exp c1 ip add).  we decided to test the MRA failover by shutting down the exp c1.  The expectation was that it would register with cucm with exp c 2 IP add.  it didn't register as expected for some reason.  if we log out of MRA jabber while exp c1 is down, it will then register with cucm using exp c 2 ip add.  it seemed that a manual log out/login required to make it work.

so my question is should it automatically fail over to secondary exp c2 when c1 is down? if yes, I am not sure why it didnt failover to expc2.

 

thanks a lot

vijay .

6 REPLIES 6
Highlighted
VIP Advisor

For it to failover, jabber has to wait for reregister message timeout to
register using expc2. This is how sip endpoint failover work. Same case
when cucm nodes within cucm group failover. The MRA cluster is working fine
because when you reregister it works with expc2.

If you want faster failover, you need to tweak the timeout and number of
retry messages.

***** please remember to rate useful posts
Highlighted

I did wait way over 10 minutes for auto reregistration which didnt happen. Thats when i logged off and logged back in.

Highlighted

Can you confirm your sip timers in cucm service parameters? Also, if you
look at jabber log file, are you see attempts to register.
Highlighted

I also notice this issue, putting an expressway c of a cluster into maintenance mode. The Jabber does not failover to register via the other expressway c. Just remains unregistered until a restart of Jabber (waited 10 mins). The cucm service parameter SIP Station KeepAlive Interval is set to the default of 120.

Highlighted

i dont have access to play around and figure out why this happened. but if you have access to Expways for testing then you can modify these values and test again pls.

 

go to exp C configuration->protocol->sip-> and you will see these.

Outbound registration refresh minimum” : 300 seconds

“Outbound registration refresh maximum : 3600 seconds

 

you can change the mininum to 30 sec and maximum to 60 sec. (or 60 and 120 sec) and test again.  if it doesnt help you can put back to original settings.  thanks. 

Highlighted

Failover scenarios are currently not supported. Not supported means that some scenarios might work, and some others don't. As an example, failover works for hardware endpoints. This will be fixed in the next major release, X.14, but might require an UCM upgrade.