08-17-2013 01:37 AM - edited 03-16-2019 06:54 PM
i have switch with cucm on port 1/0/4...
need to apply qos... as per question..
setup is wit 3 sites...and over framerelay..
site -3 have cue...
site-1 have cucm with this switch..
configure switch 1 with policies on the 3750 switch:
1: ensure cos value 5 is mapped to dscp ef /cue signal with cs3
2: in giga int 1/0/4, make sure all incoming cue signal traffic is marked with cs3 and guarantee to 8k bandwidth.
Anything in excess should be first marked down to dsco value of 8 before being transmitted.
3. use requirements listed in the cue section to deliver the list of protocols to be policed.
----------------------------------------------------------------------------------------------------
On HQ Switch side:
-----------------
mls qos map policed-dscp 24 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos
class-map match-any SUB_TO_CUE
match access-group name SUB_TO_CUE
policy-map SUB_TO_CUE
class SUB_TO_CUE
set ip dscp cs3
police 8000 8000 exceed-action policed-dscp-transmit
class class-default
trust dscp
ip access-list extended SUB_TO_CUE
permit tcp host 142.100.64.12 eq 2748 host 142.1.66.253
permit tcp host 142.100.64.12 eq smtp host 142.1.66.253
permit tcp host 142.100.64.12 eq 443 host 142.1.66.253
permit tcp host 142.100.64.12 eq 8443 host 142.1.66.253
permit tcp host 142.100.64.12 eq www host 142.1.66.253
interface GigabitEthernet1/0/1
description R1 Trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,102,202
switchport mode trunk
mls qos trust dscp
spanning-tree portfast trunk
interface GigabitEthernet1/0/3
description Publisher Port
switchport mode access
mls qos trust dscp
spanning-tree portfast
interface GigabitEthernet1/0/4
description Subscriber Port
service-policy input SUB_TO_CUE
switchport access vlan 100
switchport mode access
spanning-tree portfast
interface GigabitEthernet1/0/13
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
interface GigabitEthernet1/0/14
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
interface GigabitEthernet1/0/15
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
!
=====================================================================
On R3 router side:
------------------
-----------------
ip access-list extended cue_TO_sub
permit tcp host 142.1.66.253 eq 2748 host 142.100.64.12
permit tcp host 142.1.66.253 eq smtp host 142.100.64.12
permit tcp host 142.1.66.253 eq 443 host 142.100.64.12
permit tcp host 142.1.66.253 eq 8443 host 142.100.64.12
permit tcp host 142.1.66.253 eq www host 142.100.64.12
!
!
class-map match-any cue_TO_sub
match access-group name cue_TO_sub
!
policy-map cue_TO_sub
class cue_TO_sub
set ip dscp cs3
police 8000 8000 exceed-action policed-dscp-transmit
!
interface serial 0/1/0:0.1 point-to-point
description serial port to HQ Router
service-policy output cue_TO_sub
!
is it ok....or need some mroe changes for work it?
please tell with your inputs...
Warm Regard's
===========
Amit
08-17-2013 09:59 AM
You do not need to do anything of that.
The defices already originate packets with the correctt DSCP value.
All you have to do is configure QoS on the WAN, and nothing else.
11-19-2013 08:49 PM
I don't think so this is valued. I tried to dig in SRND for cue qos. I don t think so no one will get full marks on LAN qos on ccievoice for this lab... one of my friend tried to work around to capture that packets to find out valued solutions.. see this link below, its more helpfull.. Please reply if you find right solution..
http://www.voiceie.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=8;t=003538
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide