11-17-2014 07:08 AM - edited 03-17-2019 12:57 AM
Hello,
I am working on QoS implementation in our network.
I created the test scheme which consists of two switches (Cisco 3560/ Cisco 2960) and four laptops.
My QoS settings the following:
- mark voice traffic in dscp ef
- mark signal traffic in dscp af31
- mark video traffic in dscp af41
- create two egress queues: one for traffic with dscp ef, a31, af41 and second for other traffic. First queue is priority.
- create policy-map QOS_POLICY for marking traffic and
congestion management.
So, the following QoS setting were applied on two switches:
mls qos map policed-dscp 34 46 to 0
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 2 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 2 0 1 2 6 7
mls qos srr-queue output dscp-map queue 1 threshold 2 24 26 32 34 46
mls qos srr-queue output dscp-map queue 2 threshold 2 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 2 threshold 2 8 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 2 threshold 2 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 2 25 27 28 29 30 31 33 35
mls qos srr-queue output dscp-map queue 2 threshold 2 36 37 38 39 40 41 42 43
mls qos srr-queue output dscp-map queue 2 threshold 2 44 45 47 48 49 50 51 52
mls qos srr-queue output dscp-map queue 2 threshold 2 53 54 55 56 57 58 59 60
mls qos srr-queue output dscp-map queue 2 threshold 2 61 62 63
mls qos queue-set output 2 threshold 1 100 50 100 200
mls qos queue-set output 2 threshold 2 100 100 100 400
mls qos queue-set output 2 buffers 5 95 0 0
mls qos
class-map match-all SIGNAL_CLASS
match access-group name SIGNAL
class-map match-all VIDEO_CLASS
match access-group name VIDEO
class-map match-all VOICE_CLASS
match access-group name VOICE
policy-map QOS_POLICY
class VOICE_CLASS
set dscp ef
police 5000000 8000 exceed-action policed-dscp-transmit
class SIGNAL_CLASS
set dscp af31
police 256000 8000 exceed-action drop
class VIDEO_CLASS
set dscp af41
police 10000000 8000 exceed-action policed-dscp-transmit
class class-default
set ip dscp default
Extended IP access list SIGNAL
permit tcp any any range 11000 11999
permit tcp any any range 2000 2002
permit udp any any range 29120 29131
permit tcp any any range 5060 5061
permit udp any any range 5060 5061
permit udp any any range 1718 1719
permit tcp any any eq 1720
permit tcp any any eq 2428
permit udp any any eq 2427
permit ip any any dscp af31
Extended IP access list VIDEO
permit udp any any eq 2326 2485
permit tcp any any eq 5555 5574
permit ip any any dscp af41
Extended IP access list VOICE
permit udp any any range 29100 29119
permit udp any any range 16384 32767
permit ip any any dscp ef
interface FastEthernet0/1
description Trunk to switch2
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 1 100 1 1
queue-set 2
priority-queue out
mls qos trust dscp
interface FastEthernet0/2
description Data traffic
switchport access vlan 20
srr-queue bandwidth share 1 100 1 1
queue-set 2
priority-queue out
mls qos trust dscp
spanning-tree portfast
service-policy input QOS_POLICY
interface FastEthernet0/3
description Voice traffic
switchport access vlan 10
srr-queue bandwidth share 1 100 1 1
queue-set 2
priority-queue out
mls qos cos 5
mls qos trust dscp
service-policy input QOS_POLICY
As I see in results of command - show mls qos int stat, the traffic is marked and added to egress queue correctly.
But when I start iperf I see 25% lost packets for voice traffic and 5% for data traffic when data and voice are sent in the same time.
For test I use the following settings in iperf:
1. For voice traffic
- server - iperf.exe -s -u -i 5
- client - iperf.exe -c host 192.168.1.2 -u -i 5 -t 100 -b 5m
2. For data traffic
- server - iperf.exe -s -u -i 5
- client - iperf.exe -c host 192.168.2.2 -u -i 5 -t 100 -b 100m
But I notice, if I remove the command mls qos map policed-dscp 34 46 to 0 from two switches I don't get lost packets on when I start iperf.
I think, maybe it doesn't work on l2.
Could you help me understand it?
What I do wrong?
Thank you in advance
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide