11-24-2012 07:18 PM - edited 03-16-2019 02:22 PM
I am trying to get my CUCME registered with flowroute. Simple task as I have done it with another provider no problem. However, the register packets being received by flowroute are a little interesting.
REGISTER sip:sip.flowroute.com:5060 SIP/2.0.
Via: SIP/2.0/UDP 72.201.112.131:1557;branch=z9hG4bK69539.
From: <sip:08922051@sip.flowroute.com>;tag=83295764-65.
To: <sip:08922051@sip.flowroute.com >.
Date: Sat, 24 Nov 2012 21:31:26 GMT.
Call-ID: 8905D527-35A211E2-811EE65D-4295C626.
User-Agent: Cisco-SIPGateway/IOS-12.x.
Max-Forwards: 70.
Timestamp: 1353792686.
CSeq: 38 REGISTER.
Contact: <sip:08922051@72.201.112.131:1557>.
Expires: 3600.
Supported: path.
Content-Length: 0.
Notice the Contact field has my IP and a different port number on it? Any idea what would be causing it?
11-24-2012 11:20 PM
Here is my 100% working config from my CME using Flowroute. My CME has the Unity Express AIM-CUE in it as well, and works perfect with Flowroute. Maybe you can pull what you need off of it.
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Call_Manager_C
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$LR7z$ZTu8w3663z2rQVqJ7Y2YA1
!
no aaa new-model
clock timezone EST -4
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.22.100.1 172.22.100.9
ip dhcp excluded-address 172.22.101.1 172.22.101.9
!
ip dhcp pool DATA_SCOPE
network 172.22.101.0 255.255.255.0
default-router 172.22.101.1
!
ip dhcp pool VOICE_SCOPE
network 172.22.100.0 255.255.255.0
default-router 172.22.100.1
option 150 ip 172.22.100.1
!
!
no ip domain lookup
ip name-server 208.67.222.222
ip name-server 208.67.220.220
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
sip
registrar server expires max 160 min 160
localhost dns:sip.flowroute.com:5060
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
voice translation-rule 1
rule 1 /^9\(..........\)$/ /1\1/
!
!
voice translation-profile outgoing
translate called 1
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.6
encapsulation dot1Q 6 native
ip address 172.22.1.71 255.255.255.0
!
interface FastEthernet0/0.11
description Router Interface For Voice Vlan
encapsulation dot1Q 11
ip address 172.22.100.1 255.255.255.0
!
interface FastEthernet0/0.51
description Router interface For Data Vlan
encapsulation dot1Q 51
ip address 172.22.101.1 255.255.255.0
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/0.6
service-module ip address 172.22.1.155 255.255.255.0
service-module ip default-gateway 172.22.1.71
!
interface Ethernet1/0
description Telnet Management
ip address 192.168.2.115 255.255.255.0
half-duplex
ntp broadcast client
!
interface Ethernet1/1
description Ethernet To Internet
ip address 192.168.6.100 255.255.255.0
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.6.1
ip route 172.22.1.155 255.255.255.255 Service-Engine0/0
!
ip http server
no ip http secure-server
ip http path flash:/gui
!
!
tftp-server flash:CP7912080001SCCP051117A.sbin
!
control-plane
!
!
dial-peer voice 1 voip
translation-profile outgoing outgoing
destination-pattern 9..........
voice-class codec 1
session protocol sipv2
session target ipv4:216.115.69.144
dtmf-relay rtp-nte
!
dial-peer voice 2 voip
destination-pattern .T
redirect ip2ip
voice-class codec 1
voice-class sip localhost dns:sip.flowroute.com
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target dns:sip.flowroute.com
incoming called-number .%
dtmf-relay rtp-nte
no vad
!
dial-peer voice 4000 voip
destination-pattern 4000
b2bua
session protocol sipv2
session target ipv4:172.22.1.155
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
sip-ua
credentials username xxxxxxxx password xxxxxxxx realm sip.flowroute.com
authentication username xxxxxxxx password xxxxxxxx
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar ipv4:216.115.69.144 expires 60
connection-reuse
host-registrar
!
!
telephony-service
load 7912 CP7912080001SCCP051117A
max-ephones 4
max-dn 12
ip source-address 172.22.100.1 port 2000
voicemail 4000
max-conferences 4 gain -6
call-forward pattern .T
moh music-on-hold.au
multicast moh 239.23.4.10 port 2000 route 172.22.100.0
web admin system name admin password password
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern 300.
secondary-dialtone 9
create cnf-files version-stamp 7960 Sep 17 2012 15:52:07
!
!
ephone-dn 1
number 12015652954 secondary 3001 no-reg both
label 3001
call-forward busy 4000
call-forward noan 4000 timeout 20
!
!
ephone-dn 2
number 19044982327 secondary 3002 no-reg both
label 3002
call-forward busy 4000
call-forward noan 4000 timeout 20
!
!
ephone-dn 9
number 8000.... no-reg primary
mwi on
!
!
ephone-dn 10
number 8001.... no-reg primary
mwi off
!
!
ephone 1
mac-address 0015.C617.CE82
button 1:1
!
!
!
ephone 2
mac-address 0015.63FF.5284
button 1:2
11-24-2012 11:49 PM
OK, I see a few things I can try. Would the fact that I am also using CME as a SIP registrar cause any problems? I noticed you are using just SCCP phones. I'm trying to use CME as SIP registrar so I can register ATA's.
11-25-2012 01:02 AM
I do not know. That is my extent of SIP on CME. Now I am configuring (learning) my CUCM 7 with that same CME router (but only used as a SIP to SIP gateway, still with Flowroute). I don't have any registration issues, just other issues, like one way audio.
11-25-2012 01:16 AM
Actually, between your suggestions and me digging around, I narrowed it down to an access-list on my routers edge interface. I've tried adding statements to allow the traffic in, but when I apply the below list, the registration and any attempts to make a call die. Line 91 should take care of things, but I'm not having any luck.
Extended IP access list Outside_In
10 permit udp any any eq bootpc (18 matches)
20 permit udp any any eq bootps
30 permit udp any eq bootps any eq bootpc
40 permit udp any host 72.201.112.131 eq isakmp
50 permit udp any host 72.201.112.131 eq non500-isakmp
60 permit esp any host 72.201.112.131 (2821 matches)
70 permit tcp any host 72.201.112.131 eq 443
80 permit tcp any host 72.201.112.131 eq 10000
90 permit udp any eq domain host 72.201.112.131
91 permit ip host 216.115.69.144 any (30 matches)
100 permit icmp any any echo
110 permit icmp any any echo-reply
120 permit icmp any any time-exceeded
130 permit icmp any any unreachable
140 permit icmp any any packet-too-big
150 permit udp host 208.110.65.18 host 72.201.112.131 (48 matches)
160 permit udp host 192.43.244.18 eq ntp any eq ntp (5 matches)
170 permit udp host 204.34.198.40 eq ntp any eq ntp (7 matches)
180 deny ip host 139.130.130.34 host 139.130.130.34 log
190 deny ip 127.0.0.0 0.255.255.255 any log
200 deny ip 169.254.0.0 0.0.255.255 any log
210 deny ip host 255.255.255.255 any log
220 deny ip host 0.0.0.0 any log
230 deny icmp any any redirect log
240 deny icmp any any mask-request log
250 deny ip any any log (2051 matches)
11-25-2012 01:42 AM
OK, I managed to get it. I forgot about the RTP ports. Now I'm working on getting the inbound calling to work. Probably something I forgot about somewhere.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide