cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
675
Views
0
Helpful
6
Replies

UNABLE TO MAKE OUTGOING CALL IN CISCO ROUTER 2911 VIA FXO PORT

naresh_bsf99
Beginner
Beginner

I HAVE REPLACED ROUTER 2821 WITH 2911, BUT AFTER REPLACEMENT EVERY THINGS IS WORKING FINE EXCEPT VOICE CALL THROGH FXO.

I AM UNABLE TO MAKE THE OUTGOING CALL WHILE INCOMING CALL IS WORKING SATISFACTORY. HOWEVER VOICE CALL THROUGH ROUTER 2821 IS FINE.

PSE TELL WHAT I WILL CHANGE  IN NEW ROUTER 2911

MY OLD CONFIGURATION IS

sh run
Building configuration...


Current configuration : 19929 bytes
!
! Last configuration change at 04:55:34 UTC Wed Jan 20 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname beria
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 ZW/BAZ58bAvnLcfmZ8OjgUpd5crX6x.pNAr7/WZMo4M
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group FXO
!
!
!
voice-card 0
!
!
!
voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class dualtone-detect-params 100
freq-max-deviation 25
!

voice class custom-cptone in
dualtone disconnect
frequency 425
cadence 375 375
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FGL170913E2
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 170.xxx.xxx.1 255.255.255.0
duplex auto
speed auto
no clns route-cache
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!

!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
no battery-reversal
cptone IN
timeouts call-disconnect 2
timeouts wait-release 5
!
voice-port 0/0/1
!
!
!
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
description incoming call
destination-pattern 256
port 0/0/0
forward-digits 0
!
dial-peer voice 2 voip
destination-pattern 301
session target ipv4:10.xxx.xxx.2
!

WHEN I DIAL NO 256 IT IMDTLY DISCONNECT

sh voice call summary
PORT CODEC VAD VTSP STATE VPM STATE
============== ========= === ==================== ======================

0/0/0 g711ulaw n S_WAIT_RELEASE_NC FXOLS_OFFHOOK

6 Replies 6

Rajan
Collaborator
Collaborator

Hi Naresh,

I could see forward digits configured to be 0.

dial-peer voice 1 pots
description incoming call
destination-pattern 256
port 0/0/0
forward-digits 0

is this intended ? This means no digits are sent as called number to the Provider. Try removing it or configure it to send required number of digits.

HTH

Rajan

Pls rate all useful posts

SIr

i Have remove 0 but problem still same

Hi Naresh,

Can you provide the current configuration along with the below debug for one failed call with call details.

debug voip ccapi inout

Thanks,

Rajan

Sir

This is my ruuning config

Digberia# sh run
Building configuration...


Current configuration : 19817 bytes
!
! Last configuration change at 06:25:00 UTC Fri Jan 22 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Digberia
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 ZW/BAZ58bAvnLcfmZ8OjgUpd5crX6x.pNAr7/WZMo4M
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group FXO
!
!
!
voice-card 0
!
!
!
voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FGL170913E2
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 170.136.6.1 255.255.255.0
duplex auto
speed auto
no clns route-cache
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
encapsulation ppp
shutdown
clock rate 2000000
no clns route-cache
!
interface Serial0/1/1
ip address 10.10.57.1 255.255.255.0
encapsulation ppp
ip ospf message-digest-key 1 md5 7 096E7D2F26243A21
!
router ospf 100
area 6 authentication message-digest
network 10.10.57.0 0.0.0.255 area 6
network 170.136.6.0 0.0.0.255 area 6
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
no battery-reversal
cptone IN
timeouts call-disconnect 2
timeouts wait-release 5
!
voice-port 0/0/1
supervisory disconnect dualtone mid-call
no battery-reversal
cptone IN
timeouts call-disconnect 2
timeouts wait-release 5
!
!
!
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
description incoming call
destination-pattern 256
port 0/0/0

!
dial-peer voice 2 voip
destination-pattern 301
session target ipv4:10.10.54.2
!

!
dial-peer voice 10 pots
description call to Digveria
destination-pattern 256
port 0/0/1

!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
password 7 00170A15105E06395C355B41
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 120A1C04060E013B793F3327
login
transport input all
!
scheduler allocate 20000 1000
!
end

DEBUG

User Access Verification

Password:
BNDigberia>en
Password:
BNDigberia#sh logging
Syslog logging: enabled (0 messages dropped, 2 messages rate-limited, 30 flushes , 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.


Console logging: level debugging, 7500 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 7176 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
Persistent logging: disabled

No active filter modules.

Trap logging: level informational, 945 message lines logged
Logging Source-Interface: VRF Name:

Log Buffer (8192 bytes):
=211, Source Call Id=209,
Caps(Codec=0x4, Fax Rate=0x2, Fax Version:=0, Vad=0x2,
Modem=0x0, Codec Bytes=20, Signal Type=2)
*Jan 22 06:33:04.038: //209/63EA0739B6A6/CCAPI/cc_api_caps_ind:
Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
Playout Max=1000(ms), Fax Nom=300(ms))
*Jan 22 06:33:04.038: //209/63EA0739B6A6/CCAPI/cc_api_caps_ack:
Destination Interface=0x3285B05C, Destination Call Id=211, Source Call Id=209 ,
Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Fax Version:=0, Vad=ON( 0x2),
Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=5842)
*Jan 22 06:33:04.038: //211/63EA0739B6A6/CCAPI/cc_api_caps_ack:
Destination Interface=0x31B7A24C, Destination Call Id=209, Source Call Id=211 ,
Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Fax Version:=0, Vad=ON( 0x2),
Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=5816)
*Jan 22 06:33:04.038: //211/63EA0739B6A6/CCAPI/cc_api_caps_ack:
Destination Interface=0x31B7A24C, Destination Call Id=209, Source Call Id=211 ,
Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Fax Version:=0, Vad=ON( 0x2),
Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=5842)
*Jan 22 06:33:04.042: //211/63EA0739B6A6/CCAPI/cc_api_voice_mode_event:
Call Id=211
*Jan 22 06:33:04.042: //211/63EA0739B6A6/CCAPI/cc_api_voice_mode_event:
Call Entry(Context=0x334D2B28)
*Jan 22 06:33:04.042: //211/63EA0739B6A6/CCAPI/cc_api_voice_mode_event:
Call Id=211
*Jan 22 06:33:04.046: //211/63EA0739B6A6/CCAPI/cc_api_voice_mode_event:
Call Entry(Context=0x334D2B28)
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/cc_api_call_disconnected:
Cause Value=16, Interface=0x31B7A24C, Call Id=209
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/cc_api_call_disconnected:
Call Entry(Responsed=TRUE, Cause Value=16, Retry Count=0)
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/ccConferenceDestroy:
Conference Id=0x27, Tag=0x0
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/ccConferenceDestroy:

*Jan 22 06:33:34.318: confID:0x27; callEntry1 callID1:0xD1, type:1; callEntry2 c allID2:0xD3, type:6

*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/cc_api_bridge_drop_done:
Conference Id=0x27, Source Interface=0x31B7A24C, Source Call Id=209,
Destination Call Id=211, Disposition=0x0, Tag=0x0
*Jan 22 06:33:34.318: //211/63EA0739B6A6/CCAPI/cc_api_bridge_drop_done:
Conference Id=0x27, Source Interface=0x3285B05C, Source Call Id=211,
Destination Call Id=209, Disposition=0x0, Tag=0x0
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/cc_generic_bridge_done:
Conference Id=0x27, Source Interface=0x3285B05C, Source Call Id=211,
Destination Call Id=209, Disposition=0x0, Tag=0x0
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/ccCallDisconnect:
Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect C ause=16)
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/ccCallDisconnect:
Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
*Jan 22 06:33:34.318: //209/63EA0739B6A6/CCAPI/cc_api_get_transfer_info:
Transfer Number=NULL
*Jan 22 06:33:34.318: //211/63EA0739B6A6/CCAPI/ccCallDisconnect:
Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect C ause=0)
*Jan 22 06:33:34.318: //211/63EA0739B6A6/CCAPI/ccCallDisconnect:
Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
*Jan 22 06:33:34.318: //211/63EA0739B6A6/CCAPI/cc_api_get_transfer_info:
Transfer Number=NULL
*Jan 22 06:33:34.322: //209/63EA0739B6A6/CCAPI/cc_api_get_transfer_info:
Transfer Number=NULL
*Jan 22 06:33:34.322: //209/63EA0739B6A6/CCAPI/cc_api_call_disconnect_done:
Disposition=0, Interface=0x31B7A24C, Tag=0x0, Call Id=209,
Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
*Jan 22 06:33:34.322: //209/63EA0739B6A6/CCAPI/cc_api_call_disconnect_done:
Call Disconnect Event Sent
*Jan 22 06:33:34.322: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 22 06:33:34.322: :cc_free_feature_vsa freeing 2AE60AB0
*Jan 22 06:33:34.322: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 22 06:33:34.322: vsacount in free is 1
*Jan 22 06:33:34.334: //211/63EA0739B6A6/CCAPI/cc_api_call_disconnect_done:
Disposition=0, Interface=0x3285B05C, Tag=0x0, Call Id=211,
Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
*Jan 22 06:33:34.334: //211/63EA0739B6A6/CCAPI/cc_api_call_disconnect_done:
Call Disconnect Event Sent
*Jan 22 06:33:34.334: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 22 06:33:34.334: :cc_free_feature_vsa freeing 2AE60B90
*Jan 22 06:33:34.334: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 22 06:33:34.334: vsacount in free is 0
*Jan 22 06:33:52.922: //-1/F05731ED80D2/CCAPI/cc_api_display_ie_subfields:
cc_api_call_setup_ind_common:
cisco-username=
----- ccCallInfo IE subfields -----
cisco-ani=
cisco-anitype=0
cisco-aniplan=0
cisco-anipi=0
cisco-anisi=0
dest=
cisco-desttype=0
cisco-destplan=0
cisco-rdie=FFFFFFFF
cisco-rdn=
cisco-rdntype=0
cisco-rdnplan=0
cisco-rdnpi=0
cisco-rdnsi=0
cisco-redirectreason=0 fwd_final_type =0
final_redirectNumber =
hunt_group_timeout =0

*Jan 22 06:33:52.922: //-1/F05731ED80D2/CCAPI/cc_api_call_setup_ind_common:
Interface=0x3285B05C, Call Info(
Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Scree ned, Presentation=Allowed),
Called Number=(TON=Unknown, NPI=Unknown),
Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFl ag=TRUE,
Incoming Dial-peer=10, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), C alling IE Present=FALSE,
Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALS E), Call Id=-1
*Jan 22 06:33:52.922: //-1/F05731ED80D2/CCAPI/ccCheckClipClir:
In: Calling Number=256(TON=Unknown, NPI=Unknown, Screening=Not Screened, Pres entation=Allowed)
*Jan 22 06:33:52.922: //-1/F05731ED80D2/CCAPI/ccCheckClipClir:
Out: Calling Number=256(TON=Unknown, NPI=Unknown, Screening=Not Screened, Pre sentation=Allowed)
*Jan 22 06:33:52.922: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 22 06:33:52.922: :cc_get_feature_vsa malloc success
*Jan 22 06:33:52.922: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 22 06:33:52.922: cc_get_feature_vsa count is 1
*Jan 22 06:33:52.922: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 22 06:33:52.922: :FEATURE_VSA attributes are: feature_name:0,feature_time:7 19719320,feature_id:167
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/cc_api_call_setup_ind_common:
Set Up Event Sent;
Call Info(Calling Number=256(TON=Unknown, NPI=Unknown, Screening=Not Screened , Presentation=Allowed),
Called Number=(TON=Unknown, NPI=Unknown))
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/cc_process_call_setup_ind:
Event=0x326676F8
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/ccCallSetContext:
Context=0x334CC4F8
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/cc_process_call_setup_ind:
>>>>CCAPI handed cid 212 with tag 10 to app "_ManagedAppProcess_Default"
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/ccCallProceeding:
Progress Indication=NULL(0)
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/ccCallDisconnect:
Cause Value=28, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect C ause=0)
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/ccCallDisconnect:
Cause Value=28, Call Entry(Responsed=TRUE, Cause Value=28)
*Jan 22 06:33:52.922: //212/F05731ED80D2/CCAPI/cc_api_get_transfer_info:
Transfer Number=NULL
*Jan 22 06:34:04.622: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/ 1, changed state to down
*Jan 22 06:34:04.622: %LINK-3-UPDOWN: Interface Serial0/1/1, changed state to do wn
*Jan 22 06:34:04.622: %OSPF-5-ADJCHG: Process 100, Nbr 11.1.1.69 on Serial0/1/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 22 06:34:39.186: %LINK-3-UPDOWN: Interface Serial0/1/1, changed state to up
*Jan 22 06:34:39.210: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/ 1, changed state to up
*Jan 22 06:34:40.682: %OSPF-5-ADJCHG: Process 100, Nbr 11.1.1.69 on Serial0/1/1 from LOADING to FULL, Loading Done

WHEN I TRY TO MAKE CALL ONLY 0.5 SEC TONE RECD FROM FXO AND IMDTLY DISCONNECT AND THE SUMMARY STATUS IS

BNDigberia#sh voice call summary
PORT CODEC VAD VTSP STATE VPM STATE
============== ========= === ==================== ======================
0/0/0 - - - FXOLS_ONHOOK
0/0/1 g729r8 y S_CONNECT FXOLS_OFFHOOK


BNDigberia#sh voice call summary
PORT CODEC VAD VTSP STATE VPM STATE
============== ========= === ==================== ======================
0/0/0 - - - FXOLS_ONHOOK
0/0/1 - - - FXOLS_RINGING

BNDigberia#sh voice call summary
PORT CODEC VAD VTSP STATE VPM STATE
============== ========= === ==================== ======================
0/0/0 - - - FXOLS_ONHOOK
0/0/1 g711ulaw n S_WAIT_RELEASE_NC FXOLS_OFFHOOK

BNDigberia#sh voice call summary
PORT CODEC VAD VTSP STATE VPM STATE
============== ========= === ==================== ======================
0/0/0 - - - FXOLS_ONHOOK
0/0/1 g711ulaw n S_WAIT_RELEASE_NC FXOLS_OFFHOOK

Hi Naresh,

Can you configure the below and let us know the outcome:

dial-peer voice 1 pots
description incoming call
destination-pattern 256
port 0/0/0
forward-digits all

dial-peer voice 10 pots
description call to Digveria
destination-pattern 256
port 0/0/1

forward-digits all

If the issue persists, pls let us know what is the exact call flow as I see in the debug that the calling number is 256.

HTH

Rajan

Pls rate all useful posts

sir

dial-peer voice 10 pots
description call to Digveria
destination-pattern 256
port 0/0/1

forward-digits all

when i configure these the incoming and outgoing both are out of service

and when enter this command , incoming call is functional but outgoing call is not functional

dial-peer voice 10 pots
description call to Digveria
destination-pattern 256
port 0/0/1

forward-digits 0

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: