02-24-2023 01:21 PM
Ok, so I'm working on an Audio over IP system that recommends the 'switchport voice vlan dot1p" command on the switch ports utilized for their equipment.
I'm pretty sure I understand what the dot1p command is doing, it takes traffic received from a phone on the access port (or AoIP device in this case) that has tagging, DOT1Q + DOT1P tag, and tells the switch to put that traffic on the "Native VLAN".
The "Native VLAN" terminology is what is throwing me here... so really I just want to confirm the below
tldr; When utilizing the "switchport voice vlan dot1p" command, is the "Native VLAN" referenced in the documentation, which the switch forwards the Voice traffic on, the VLAN that is configured with the "switchport access vlan XXXX" command, or if not, where is the "Native Vlan" set for an access port or VoiceVLAN traffic?
(Using C3850 switches running version 16.x)
02-24-2023 05:39 PM
#switchport voice vlan ?
<1-4094> Vlan for voice traffic
dot1p Priority tagged on PVID
It all depends on requirements:
switchport voice vlan vlanid - which is what is covered in this topic which says that voice traffic will be sent tagged by whatever vlan was configured using this command and the PC data will be sent untagged.
switchport voice vlan dot1p - says that the voice traffic will be sent using vlan 0 and PC traffic untagged.
In this case qos abilities by adding 802.1p COS tag. The phone will actually tag it’s own voice traffic with vlan id equal to 0, and send it with a 802.1p priority of 5 by default. (call control gets a priority of 3). The benefit of this mode is that you get QOS abilities without needing a separate voice vlan created on your switches and routers. The PC traffic should be the default priority of 0 or best effort.
Most standard setup people use as below config :
interface gig 0/0
switchport mode access
switchport access vlan 10
switchport voice vlan 20
The phone will now send voice packets tagged with your voice vlan ID to the switch, with Layer 3 IP precedence and Layer 2 CoS values, which are both set to 5 by default, while the data packets are sent along untagged to the access vlan.
cisco Phones required CDP enabled on the switch, other phones required LLDP.
02-25-2023 05:59 AM
Confusion about voice vlan | Tom G CCIE Blog (wordpress.com)
this link can answer you
02-27-2023 08:28 AM
This definitely appears to confirm that it operates like I think it does, but it doesn't explicitly state that the dot1p traffic ends up on the VLAN defined with the "switchport access vlan XXX" command on that port.
02-27-2023 03:16 PM
sure but you need to look where you looking to deploy.
if this just an access switch, I will go with access vlan x to make simple
02-27-2023 03:29 PM - edited 02-27-2023 03:29 PM
sorry I dont get your Q
02-27-2023 03:44 PM
I apologize, I probably wasn't concise.
Given the following switchport config, what VLAN are packets that arrive to the interface with a DOT1Q header VLAN ID of 0 transmitted onto?
!
interface GigabitEthernet1/0/2
switchport mode access
switchport access vlan 14
switchport nonegotiate
switchport voice vlan dot1p
switchport block multicast
spanning-tree portfast
spanning-tree bpduguard enable
no ip igmp snooping tcn flood
service-policy output TELOS
!
02-27-2023 04:21 PM
see the figure above
Data will be untag
Voice will be tag with VLAN-ID = 0
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide