cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3948
Views
0
Helpful
2
Replies

6rd dynamic addressing

HQuest
Level 1
Level 1

Hello.

My DSL ISP provides IPv6 connectivity using 6rd as its addressing scheme. Since this is a dynamic IPv4 address service, I need to do some dec-to-hex math in order to get my assigned IPv6 address.

As their leased modems are all Linux-based, they can use some utilities/shell scripting to make that happen. By manually entering my ipv6 addresses and prefixes on both external and internal interfaces, it works like a champ, but I really wonder if there is a way to make the IOS do that by itself.

Below is the current configuration piece, based on IOS 15.3. IP addresses were changed to ficticious ones, but this is more on how to implement a feature than how to fix what is (sort of) already working. The "26:282A:2C" prefix is my (ficticious current) IPv4 address 38.40.42.44 in hex format, and this is what I am looking to auto generate based on the tunnel source interface IPv4 address.

Caveats: since my BR is on a totally different network (224.0.0.0/8) than the one I'm connected to (38.0.0.0/8), the obvious command "tunnel 6rd ipv4 prefix-len 31" returns me the following warning:

% The derived V4 Prefix for Tunnel0 is 38.40.42.44. It does not cover the

BR address 224.9.9.10. Either configure a different source address or

prefix-len for Tunnel0 or remove its BR configuration using 'no tunnel 6rd br'.

With the "no tunnel 6rd br" command, no working 6rd tunnel.

Ideas?

!

version 15.3

!

ipv6 dhcp pool DHCPoolV6

address prefix 2599:26:282A:2C00::/64

dns-server 2001:BEEF::1

!

interface Tunnel0

description IPv6 6rd Tunnel

no ip address

no ip redirects

ipv6 address 2599:26:282A:2CFF::1/128

ipv6 enable

tunnel source Dialer1

tunnel mode ipv6ip 6rd

tunnel path-mtu-discovery

tunnel 6rd prefix 2599::/24

tunnel 6rd br 224.9.9.10

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

ipv6 address 2599:26:282A:2C00::/64 eui-64

ipv6 address prefix 2599:26:282A:2C00::/64 eui-64

ipv6 enable

ipv6 nd autoconfig prefix

ipv6 nd autoconfig default-route

ipv6 nd prefix 2599:26:282A:2C00::/64

ipv6 nd ra interval 15

ipv6 dhcp server DHCPoolV6

!

! The below address is generated from the 6rd BR IP address as set on Tun0

ipv6 route ::/0 Tunnel0 2599:E0:909:A00::

Thanks and regards,

Alex

1 Accepted Solution

Accepted Solutions

Ole Troan
Cisco Employee
Cisco Employee

Firstly have a look at

http://docwiki.cisco.com/wiki/6rd_Configuration_Example

for a 6rd configuration example. If you use the ipv6 general prefix mechanism then you don't have to configure the resulting IPv6 prefixes manually.

There is also a show command you can use "show tunnel 6rd" I believe, that will show you the parameters so that you don't have to do the conversion yourself.

We recommend that the BR is a part of the 6rd link. I.e. has an address within the same IPv4 prefix.

This simplifies troubleshooting.

The "prefix-len" subcommand is used when not the whole IPv4 address is encoded in the IPv6 address.

Is that your deployment? E.g. if the IPv4 address is 10.0.0.1, a prefix-length of 8 means only "0.0.1" is

encoded in the IPv6 prefix.

Best regards,

Ole

View solution in original post

2 Replies 2

Ole Troan
Cisco Employee
Cisco Employee

Firstly have a look at

http://docwiki.cisco.com/wiki/6rd_Configuration_Example

for a 6rd configuration example. If you use the ipv6 general prefix mechanism then you don't have to configure the resulting IPv6 prefixes manually.

There is also a show command you can use "show tunnel 6rd" I believe, that will show you the parameters so that you don't have to do the conversion yourself.

We recommend that the BR is a part of the 6rd link. I.e. has an address within the same IPv4 prefix.

This simplifies troubleshooting.

The "prefix-len" subcommand is used when not the whole IPv4 address is encoded in the IPv6 address.

Is that your deployment? E.g. if the IPv4 address is 10.0.0.1, a prefix-length of 8 means only "0.0.1" is

encoded in the IPv6 prefix.

Best regards,

Ole

Hi Ole.

Thanks for simplifying lots on my side - config is way cleaner now, although I still have to dig more on the why's.

Thanks also for the prefix-len explanation. I had a totally different view on the function, now it makes more sense.

Last but not least, thanks for making my setup works as it should.

!

version 15.3

!

ipv6 source-route

ipv6 general-prefix DELEGATED-PREFIX 6rd Tunnel0

ipv6 unicast-routing

ipv6 cef

ipv6 dhcp pool DHCPoolV6

! since it is a stateless DHCP, no address definition is needed

dns-server 2001:BEEF::1

!

interface Tunnel0

description IPv6 6rd Tunnel

no ip address

no ip redirects

! no ipv6 address here since IOS complains on overlapping

ipv6 enable

tunnel source Dialer1

tunnel mode ipv6ip 6rd

tunnel path-mtu-discovery

tunnel 6rd prefix 2599::/24

tunnel 6rd br 224.9.9.10

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

ipv6 address DELEGATED-PREFIX ::/64 eui-64

ipv6 nd other-config-flag

ipv6 dhcp server DHCPoolV6

!

! The below address is generated from the 6rd BR IP address as set on Tun0

ipv6 route ::/0 Tunnel0 2599:E0:909:A00::

Alex

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: