cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
22773
Views
16
Helpful
4
Replies

Can't enable IPv6 on my 3560 Switch

GuoPatrick02
Level 1
Level 1

Hi, I got a Cisco WS-C3560-24PS-E Switch today and I can't enable IPv6 on it. I know the global command to enable it is "ipv6 unicast-routing" but that wouldn't show up in the global command list. Cisco Packet Tracer's layer 3 switch is the exact same model as mine and I even used the same IOS image as packet tracer's and it didn't work ("ipv6 unicast-routing" works on packet tracer though). Even tried upgrading to the LATEST IOS image and still got nothing. Can anyone please help? Is there something that I didn't do?

Switch#show version

Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE6, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Mon 23-Jul-12 13:10 by prod_rel_team

Image text-base: 0x01000000, data-base: 0x02F00000

ROM: Bootstrap program is C3560 boot loader

BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(44)SE5, RELEASE SOFTWARE (fc1)

Switch uptime is 1 minute

System returned to ROM by power-on

System image file is "flash:/c3560-ipservicesk9-mz.122-55.SE6.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C3560-24PS (PowerPC405) processor (revision Q0) with 131072K bytes of memory.

Processor board ID CAT1124ZHE7

Last reset from power-on

1 Virtual Ethernet interface

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 00:1C:B0:15:06:00

Motherboard assembly number     : 73-9673-09

Power supply part number        : 341-0029-05

Motherboard serial number       : CAT11235JLK

Power supply serial number      : DTN112241YW

Model revision number           : Q0

Motherboard revision number     : B0

Model number                    : WS-C3560-24PS-E

System serial number            : CAT1124ZHE7

Top Assembly Part Number        : 800-26380-04

Top Assembly Revision Number    : D0

Version ID                      : V06

CLEI Code Number                : COM1100ARC

Hardware Board Revision Number  : 0x01

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 26    WS-C3560-24PS      12.2(55)SE6           C3560-IPSERVICESK9-M

Configuration register is 0xF

Switch#show flash

Directory of flash:/

    2  -rwx    12752912   Mar 1 1993 00:06:44 +00:00  c3560-ipservicesk9-mz.122-55.SE6.bin

    3  -rwx        1048   Mar 1 1993 00:01:04 +00:00  multiple-fs

15998976 bytes total (3243008 bytes free)

Switch(config)#ip?

Ip

Switch(config)#ipv?

% Unrecognized command

1 Accepted Solution

Accepted Solutions

Raju Sekharan
Cisco Employee
Cisco Employee

Hi Patrick

Did you configure sdm to support ipv6

If not you can configure it using below command

sdm prefer dual default

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_52_se/configuration/guide/swipv6.html

Thank you

Raju

View solution in original post

4 Replies 4

Raju Sekharan
Cisco Employee
Cisco Employee

Hi Patrick

Did you configure sdm to support ipv6

If not you can configure it using below command

sdm prefer dual default

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_52_se/configuration/guide/swipv6.html

Thank you

Raju

I've seen that page. Uhh, first of all, isn't SDM the GUI configuration? I usually use CLI and not SDM and if I were to do that, would I need a different IOS image(like .tar)? Thanks Raju for the reply

-Pat

Actually, nevermind, it worked. Thanks Raju!

Hani Elgaali
Cisco Employee
Cisco Employee

Hello Patrick,

I do have the same issue with c3560e with c3560e-universalk9-mz.150-2.SE6.bin. first of all what it is SDM? and how did you fixed the issue?

 

Thank you in advance,

Hani