Showing results for 
Search instead for 
Did you mean: 

DHCPv6 problem

Hi guys,

I've configured DHCPv6 on a cisco router. DHCPv6 clients get IPv6 addresses which are shown in the " shoow ipv6 dhcp binding".

on the workstations I disabled router discovery and enabled managed address as I'm running windows vista and windows 7.

When I IPconfig on a workstation IPv6 address is shown but the gateway is an ipv4 address as I'm running a dual stack.

The poblem is I can't ping the gateway and the router doesn't reach its clients.

Your help is appreciated.

Sample DHCPv6 config:

ipv6 dhcp pool IPV6_DHCPPOOL

address prefix 2001:0:1:5::/64 lifetime infinite infinite

interface FastEthernet0/0

ip address

duplex auto

speed auto

ipv6 address 2001:0:1:5::1/64

ipv6 enable

ipv6 nd ra suppress

ipv6 ospf 1 area 1

ipv6 dhcp server IPV6_DHCPPOOL

Cisco Employee

Hi, Jory:

With DHCPv6, currently there is no equivalent of the "default-router" option as in DHCPv4. The following draft describes a way to handle this with DHCPv6, but it's currently not implemented:

Also see section 5.5.2 (Absence of Router Advertisements) in RFC 4862. Basically, the assumption is that the dhcp client still needs to learn the gateway through RA, so you still need to enable RA on the router.



Hi Wzhang,

Thank you for the response.

I used this command to enable RA on the router:

ipv6 nd ra suppress

Is it right?

On Vista workstation I tried to enable Router Discovery and managed address at the same time, but it doesn't like it. Only one is enabled at a time.

Hi Jory,

You need the 'no' form of that syntax. "no ipv6 nd ra supress". This should be the default setting in IOS therefore when you apply the command you should not see it in your running config.


Hi stmillet,

Thank you for replying.

I used the no form of that command.

I get an IPv6 address on a workstation, and it's the own shown in the show ipv6 dhcp binding but still I can't ping the gateway.

Is this a limitation of DHCPv6 or I have a problem that should be resolved??


If you can't ping the gateway, then it's unlikely an RA or DHCPv6 problem. If you statically configure the workstation with an IPv6 address on the same network as the gateway, does it work? If not, can you take a packet capture to see if you get the NS/NA packets as you are supposed to?



Hi wzhanq,

If I assign a static ipv6 or use stateless autoconfiguration everything works perfect.

It's only when an Ipv6 assigned from DHCPv6.


I think you should configure a link-local IPv6 address on the router interface. Then the client can learn the default gateway through router's RA and use the router's link-local address as the default gateway. You cannot get the default gateway info through DHCP v6.

Hi zhenningx,

I tried configuring a link-local address on the interface and it pings successfully from the DHCPv6 client workstation.

But the problem is this PC then can't communicate with other workstations in the network.

I believe I need to configure link-local addresses on other connected interfaces to be able to ping them.

Can anyone please correct me if I'm wrong.

Do you mean this PC can't communicate with other workstations in other subnets?

If that is the case, yes you need to configure link-local address on other connected interfaces on the router. In this way, all workstations in each subnet can get the default gateway(router's link-local address) and use that to communicate with any workstations in different subnets. 

Aren't link-local addresses automatically configured on IPv6 enabled interfaces? I didn't think that there was any need to do this.