cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
230
Views
0
Helpful
2
Replies
Highlighted
Beginner

IPV6 Statefull DHCP - Try assign IPV6 address via DHCP

I have setup 2 routers, and one is acting as a IPV6 DHCP server and other as a client.  Client receiving ipv6 address but unable to ping the server.  Please advice where I am wrong.

 

DHCP Router Current running config as following

============================================================================================

DHCP#show run

Building configuration...

 

Current configuration : 774 bytes

!

version 15.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname DHCP

!

!

!

!

!

!

!

!

ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

ipv6 dhcp pool STATEFUL_POOL

address prefix 2000::/64 lifetime 172800 86400

dns-server 2000::1

domain-name sunny.com

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0/0

no ip address

duplex auto

speed auto

ipv6 nd ra suppress

ipv6 address 2000::1/64

ipv6 dhcp server STATEFUL_POOL

!

interface GigabitEthernet0/0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Client Running Config as following

================================================================================================

DHCP#show run

Building configuration...

 

Current configuration : 774 bytes

!

version 15.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname DHCP

!

!

!

!

!

!

!

!

ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

ipv6 dhcp pool STATEFUL_POOL

address prefix 2000::/64 lifetime 172800 86400

dns-server 2000::1

domain-name sunny.com

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0/0

no ip address

duplex auto

speed auto

ipv6 nd ra suppress

ipv6 address 2000::1/64

ipv6 dhcp server STATEFUL_POOL

!

interface GigabitEthernet0/0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Client information as following

============================================================================================

CLIENT#show ipv6 int bri

GigabitEthernet0/0 [up/up]

FE80::2D0:BAFF:FE9E:C101

2000::2025:9E7A:386:4DD9

GigabitEthernet0/1 [administratively down/down]

unassigned

GigabitEthernet0/2 [administratively down/down]

unassigned

Vlan1 [administratively down/down]

unassigned

 

CLIENT#show ipv6 int gi 0/0

GigabitEthernet0/0 is up, line protocol is up

IPv6 is enabled, link-local address is FE80::2D0:BAFF:FE9E:C101

No Virtual link-local address(es):

Global unicast address(es):

2000::2025:9E7A:386:4DD9, subnet is 2000::2025:9E7A:386:4DD9/128 [CAL/PRE]

Joined group address(es):

FF02::1

FF02::1:FF86:4DD9

FF02::1:FF9E:C101

MTU is 1500 bytes

ICMP error messages limited to one every 100 milliseconds

ICMP redirects are enabled

ICMP unreachables are sent

ND DAD is enabled, number of DAD attempts: 1

ND reachable time is 30000 milliseconds

CLIENT#ping 2000::1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2000::1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

============================================================================================

DHCP Server interface configuration as following

 

DHCP#show ipv6 interface bri

GigabitEthernet0/0/0 [up/up]

FE80::201:97FF:FE04:2C01

2000::1

GigabitEthernet0/0/1 [administratively down/down]

unassigned

Vlan1 [administratively down/down]

unassigned

 

DHCP#show ipv6 interface bri

GigabitEthernet0/0/0 [up/up]

FE80::201:97FF:FE04:2C01

2000::1

GigabitEthernet0/0/1 [administratively down/down]

unassigned

Vlan1 [administratively down/down]

unassigned

 

Able to ping itself

DHCP#ping 2000::1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2000::1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/7 ms

 

 

2 REPLIES 2
Highlighted
Beginner

Re: IPV6 Statefull DHCP - Try assign IPV6 address via DHCP

More information about DHCP Pool and Binding.

DHCP#show ipv6 dhcp pool
DHCPv6 pool: STATEFUL_POOL
Address allocation prefix: 2000::/64 valid 172800 preferred 86400 (15 in use, 0 conflicts)
DNS server: 2000::1
Domain name: sunny.com
Active clients: 1

DHCP#show ipv6 dhcp binding
Client: (GigabitEthernet0/0/0)
DUID: 0003000100D0BA9EC101
IA PD: IA ID 16677, T1 0, T2 0
Address: 2000::/64
preferred lifetime 86400, valid lifetime 172800
expires at April 9 2020 9:52:30 pm (172800 seconds)
DHCP#
Highlighted
Collaborator

Re: IPV6 Statefull DHCP - Try assign IPV6 address via DHCP

Hi,

 

   1. Remove this command "ipv6 nd ra suppress".

   2. Shutdown the ports, server and client, unshut the ports.

   3. After the DHCP client gets an IPv6 address, try again  IP connectivity. If it doesn't work, try to connectivity between the link-local addresses and post the output of "show ipv6 neighbors" from both devices.

 

Regards,

Cristian Matei.