cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1413
Views
5
Helpful
15
Replies

ipv6

Siddique
Level 1
Level 1

 

Configuration :

!
ipv6 unicast-routing
ipv6 dhcp pool IT_User_IPV6
address prefix 2001:BF2:640:1AB::/64 lifetime infinite infinite
link-address 2001:BF2:640:1AB/64
dns-server 2001:4860:4860::8888
domain-name seddeeq.com
!
interface GigabitEthernet0/2.276
description IPv6-DHCP-Stateful
encapsulation dot1Q 276
ip address 10.100.200.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address FE80:BF2:640:1AB::1 link-local
ipv6 address 2001:BF2:640:1AB::1/64
ipv6 nd prefix 2001:BF2:640:1AB::/64 14400 14400 no-autoconfig
ipv6 nd managed-config-flag
ipv6 dhcp server IT_User_IPV6
!

Dear Experts, According to above ipv6 dhcpv6 configuration, I am facing an issue with windows pc, which is DHCPv6 client. In picture1 we can see both (ipv6 and ipv4) default gateway. But after 30 to 45 minutes latter ipv6 default gateway vanish and there is ipv6 communication break pc to router and pc to internet through ipv6.     

Please guide me to the right execution .

Thanks 

1 Accepted Solution

Accepted Solutions

Hi @Siddique ,

The issue is not that the router lifetime is set to 30 minutes. I just mentioned this to underline the fact that the PC does not receive the RA for more than 30 minutes before it loses the IPv6 default router.

You need to check why the PC does not receive the RA for more than 30 minutes. Could the switch be the issue?

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

15 Replies 15

Harold Ritter
Cisco Employee
Cisco Employee

Hi @Siddique ,

The IPv6 default route is linked to the reception of the router advertisement (RA). You first need to check whether the RA is being received the PC. You can use Wireshark on the PC to verify that.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Dear Sir, 

Thank you for reply. I am checking. 

But BTW if pc not received RA then what will be solution?

 

Thanks.

seddeeq4_0-1700499575719.png

Yes sir. you right. here no RA captured. Only NA and NS packet are transmit and receive.

 

Hi @Siddique ,

The next step would be to check if the router still sends the RA. Can you provide the output for "show ipv6 interface GigabitEthernet0/2.276".

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

IPV6-CORE-R1#show ipv6 interface GigabitEthernet0/2.276
GigabitEthernet0/2.276 is up, line protocol is up
IPv6 is enabled, link-local address is FE80:BF2:640:1AB::1
No Virtual link-local address(es):
Description: IPv6-DHCP-Stateful
Global unicast address(es):
2001:BF2:640:1AB::1, subnet is 2001:BF2:640:1AB::/64
Joined group address(es):
FF02::1
FF02::2
FF02::1:2
FF02::1:FF00:1
FF05::1:3
MTU is 1500 bytes
ICMP error messages limited to one every 50 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
Input features: Common Flow Table Stile classification
Output features: Common Flow Table Stile Classification
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use DHCP to obtain routable addresses.
Hosts use DHCP to obtain other configuration.
IPV6-CORE-R1#

 

 

!
interface GigabitEthernet0/2.276
description IPv6-DHCP-Stateful
encapsulation dot1Q 276
ip address 10.100.200.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address FE80:BF2:640:1AB::1 link-local
ipv6 address 2001:BF2:640:1AB::1/64
ipv6 nd prefix 2001:BF2:640:1AB::/64 14400 14400 no-autoconfig
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 dhcp server IT_User_IPV6
!

seddeeq4_0-1700501964595.png

 

Hi @Siddique ,

To make sure the router sends the RA, you can do a "debug ipv6 icmp" and check the RA is definitely sent out. If this is the case, you will need to check why the switch between the router and the PC is not letting the RA through.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Now i capture the packet through Wireshark. RA is receiving.    actually the main problem is once i disable and enable the network adapter, pc get ipv6 address's and show both gateway (ipv6 & ipv4). after 30 to 40 minutes latter the ipv6 default gateway gone. just show only ipv4 gateway as i share the picture.

 

 

 

Now RA is ok but still the ipv6 default gateway is gone....  this is the problem 

Hi @Siddique ,

The only thing I can think of is that either there is something wrong with the RA or with the PC.

Can you provide a file with a few RA records from the packet capture.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Dear Sir,

Thanks for your reply. The good news is today whole day i observed and found that both default gateway ( IPV6 and IPV4 ) are working properly. Also i attached the  icmpv6 packet captured.

 

 

Thanks 

Hi @Siddique ,

Glad to hear the issue has gone away for now. If it comes back, you will need to find out why the RA stops being seen on the PC. By the way, I could not see anything wrong in the packet capture you provided.  

One more thing, from the packet capture you provided, the router lifetime is set to 1800 sec (30 minutes) in the RA, which means that the PC will not use the router as a default router if it stops receiving the RA for more than 30 minutes.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

seddeeq4_0-1700623580239.png

Dear Sir,

How i can overcome it? please suggest me .  

 

thanks